summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta-ti-bsp/recipes-security/optee/optee-os_%.bbappend7
1 files changed, 6 insertions, 1 deletions
diff --git a/meta-ti-bsp/recipes-security/optee/optee-os_%.bbappend b/meta-ti-bsp/recipes-security/optee/optee-os_%.bbappend
index 5d50a04f..e268a542 100644
--- a/meta-ti-bsp/recipes-security/optee/optee-os_%.bbappend
+++ b/meta-ti-bsp/recipes-security/optee/optee-os_%.bbappend
@@ -41,7 +41,12 @@ optee_sign_legacyhs() {
41# Signing procedure for K3 HS devices 41# Signing procedure for K3 HS devices
42optee_sign_k3hs() { 42optee_sign_k3hs() {
43 ( cd ${B}/core/; \ 43 ( cd ${B}/core/; \
44 ${TI_SECURE_DEV_PKG}/scripts/secure-binary-image.sh tee-pager_v2.bin tee-pager.bin.signed; \ 44 if [ -f ${TI_SECURE_DEV_PKG}/scripts/secure-binary-image.sh ]; then \
45 ${TI_SECURE_DEV_PKG}/scripts/secure-binary-image.sh tee-pager_v2.bin tee-pager.bin.signed; \
46 else \
47 echo "Warning: TI_SECURE_DEV_PKG not set, OP-TEE not signed."; \
48 cp tee-pager_v2.bin tee-pager.bin.signed; \
49 fi; \
45 mv tee-pager.bin.signed ${B}/bl32.bin; \ 50 mv tee-pager.bin.signed ${B}/bl32.bin; \
46 cp tee.elf ${B}/bl32.elf; \ 51 cp tee.elf ${B}/bl32.elf; \
47 ) 52 )