diff options
-rw-r--r-- | classes/ti-pdk.bbclass | 4 | ||||
-rw-r--r-- | recipes-ti/devtools/gcc-aarch64-none-elf_9.2-2019.12.bb | 38 | ||||
-rw-r--r-- | recipes-ti/devtools/gcc-arm-none-eabi-native_4.9.2015q3.bb | 23 | ||||
-rw-r--r-- | recipes-ti/devtools/gcc-arm-none-eabi_7-2018-q2-update.bb | 29 | ||||
-rw-r--r-- | recipes-ti/devtools/gcc-arm-none-eabi_9-2019-q4-major.bb | 39 | ||||
-rw-r--r-- | recipes-ti/devtools/gcc-linaro-baremetal-aarch64-native.bb | 23 | ||||
-rw-r--r-- | recipes-ti/devtools/gcc-linaro-baremetal-native.bb | 23 | ||||
-rw-r--r-- | recipes-ti/includes/ti-paths.inc | 6 |
8 files changed, 82 insertions, 103 deletions
diff --git a/classes/ti-pdk.bbclass b/classes/ti-pdk.bbclass index 2571234b..37305e89 100644 --- a/classes/ti-pdk.bbclass +++ b/classes/ti-pdk.bbclass | |||
@@ -10,9 +10,9 @@ DEPENDS_remove_ti33x = "ti-cgt6x-native" | |||
10 | DEPENDS_remove_ti43x = "ti-cgt6x-native" | 10 | DEPENDS_remove_ti43x = "ti-cgt6x-native" |
11 | DEPENDS_append_omapl1 = " ti-cgt-arm-native" | 11 | DEPENDS_append_omapl1 = " ti-cgt-arm-native" |
12 | DEPENDS_remove_am65xx = "gcc-arm-none-eabi-native ti-cgt6x-native" | 12 | DEPENDS_remove_am65xx = "gcc-arm-none-eabi-native ti-cgt6x-native" |
13 | DEPENDS_append_am65xx = " ti-cgt-arm-native gcc-linaro-baremetal-aarch64-native" | 13 | DEPENDS_append_am65xx = " ti-cgt-arm-native gcc-aarch64-none-elf-native" |
14 | DEPENDS_remove_j7 = "gcc-arm-none-eabi-native" | 14 | DEPENDS_remove_j7 = "gcc-arm-none-eabi-native" |
15 | DEPENDS_append_j7 = " ti-cgt-arm-native gcc-linaro-baremetal-aarch64-native ti-cgt7x-native" | 15 | DEPENDS_append_j7 = " ti-cgt-arm-native gcc-aarch64-none-elf-native ti-cgt7x-native" |
16 | 16 | ||
17 | S = "${WORKDIR}/git" | 17 | S = "${WORKDIR}/git" |
18 | B = "${WORKDIR}/build" | 18 | B = "${WORKDIR}/build" |
diff --git a/recipes-ti/devtools/gcc-aarch64-none-elf_9.2-2019.12.bb b/recipes-ti/devtools/gcc-aarch64-none-elf_9.2-2019.12.bb new file mode 100644 index 00000000..2ec0f9cf --- /dev/null +++ b/recipes-ti/devtools/gcc-aarch64-none-elf_9.2-2019.12.bb | |||
@@ -0,0 +1,38 @@ | |||
1 | # Copyright (C) 2020 Texas Instruments Inc. | ||
2 | # Released under the MIT license (see COPYING.MIT for the terms) | ||
3 | |||
4 | SUMMARY = "Baremetal GCC for Aarch64 processors" | ||
5 | LICENSE = "GPL-3.0-with-GCC-exception & GPLv3" | ||
6 | |||
7 | LIC_FILES_CHKSUM = "file://share/doc/gcc/GNU-Free-Documentation-License.html;md5=cc1e9a49a59ce7e6ae5ef37cd16eca0c" | ||
8 | |||
9 | PROVIDES = "virtual/aarch64-none-elf-gcc" | ||
10 | |||
11 | SRC_URI = "https://developer.arm.com/-/media/Files/downloads/gnu-a/9.2-2019.12/binrel/gcc-arm-${PV}-x86_64-aarch64-none-elf.tar.xz" | ||
12 | |||
13 | SRC_URI[sha256sum] = "36d2cbe7c2984f2c20f562ac2f3ba524c59151adfa8ee10f1326c88de337b6d1" | ||
14 | |||
15 | S = "${WORKDIR}/gcc-arm-${PV}-x86_64-aarch64-none-elf" | ||
16 | |||
17 | COMPATIBLE_HOST = "x86_64.*-linux" | ||
18 | |||
19 | do_install() { | ||
20 | install -d ${D}${datadir}/aarch64-none-elf/ | ||
21 | cp -r ${S}/. ${D}${datadir}/aarch64-none-elf/ | ||
22 | |||
23 | install -d ${D}${bindir} | ||
24 | # Symlink all executables into bindir | ||
25 | for f in ${D}${datadir}/aarch64-none-elf/bin/aarch64-none-elf-*; do | ||
26 | lnr $f ${D}${bindir}/$(basename $f) | ||
27 | done | ||
28 | } | ||
29 | |||
30 | FILES_${PN} = "${datadir} ${bindir}" | ||
31 | |||
32 | INSANE_SKIP_${PN} = "already-stripped libdir staticdev file-rdeps" | ||
33 | |||
34 | INHIBIT_SYSROOT_STRIP = "1" | ||
35 | INHIBIT_PACKAGE_STRIP = "1" | ||
36 | INHIBIT_PACKAGE_DEBUG_SPLIT = "1" | ||
37 | |||
38 | BBCLASSEXTEND = "native nativesdk" | ||
diff --git a/recipes-ti/devtools/gcc-arm-none-eabi-native_4.9.2015q3.bb b/recipes-ti/devtools/gcc-arm-none-eabi-native_4.9.2015q3.bb deleted file mode 100644 index 1fe5c525..00000000 --- a/recipes-ti/devtools/gcc-arm-none-eabi-native_4.9.2015q3.bb +++ /dev/null | |||
@@ -1,23 +0,0 @@ | |||
1 | DESCRIPTION = "Baremetal GCC for ARM" | ||
2 | LICENSE = "GPL-3.0-with-GCC-exception & GPLv3" | ||
3 | |||
4 | LIC_FILES_CHKSUM = "file://share/doc/gcc-arm-none-eabi/license.txt;md5=cba77c7fde3ed13e866b04a2f3d93918" | ||
5 | |||
6 | inherit native | ||
7 | require recipes-ti/includes/ti-paths.inc | ||
8 | |||
9 | SRC_URI = "https://launchpad.net/gcc-arm-embedded/4.9/4.9-2015-q3-update/+download/gcc-arm-none-eabi-4_9-2015q3-20150921-linux.tar.bz2;name=gcc-arm-none" | ||
10 | |||
11 | SRC_URI[gcc-arm-none.md5sum] = "8a4a74872830f80c788c944877d3ad8c" | ||
12 | SRC_URI[gcc-arm-none.sha256sum] = "c50078bfbd29e6c15615900e746f4d0acde917338e55860b0f145f57387c12ab" | ||
13 | |||
14 | S = "${WORKDIR}/gcc-arm-none-eabi-4_9-2015q3" | ||
15 | |||
16 | do_install() { | ||
17 | install -d ${D}${GCC_ARM_NONE_TOOLCHAIN_RECIPE} | ||
18 | cp -r ${S}/. ${D}${GCC_ARM_NONE_TOOLCHAIN_RECIPE} | ||
19 | } | ||
20 | |||
21 | FILES_${PN} = "${GCC_ARM_NONE_TOOLCHAIN_RECIPE}/*" | ||
22 | |||
23 | INSANE_SKIP_${PN} = "already-stripped" | ||
diff --git a/recipes-ti/devtools/gcc-arm-none-eabi_7-2018-q2-update.bb b/recipes-ti/devtools/gcc-arm-none-eabi_7-2018-q2-update.bb deleted file mode 100644 index f474c87f..00000000 --- a/recipes-ti/devtools/gcc-arm-none-eabi_7-2018-q2-update.bb +++ /dev/null | |||
@@ -1,29 +0,0 @@ | |||
1 | DESCRIPTION = "Baremetal GCC for ARM" | ||
2 | LICENSE = "GPL-3.0-with-GCC-exception & GPLv3" | ||
3 | |||
4 | LIC_FILES_CHKSUM = "file://share/doc/gcc-arm-none-eabi/license.txt;md5=f77466c63f5787f4bd669c402aabe061" | ||
5 | |||
6 | require recipes-ti/includes/ti-paths.inc | ||
7 | |||
8 | SRC_URI = "https://developer.arm.com/-/media/Files/downloads/gnu-rm/7-2018q2/gcc-arm-none-eabi-7-2018-q2-update-linux.tar.bz2;name=gcc-arm-none" | ||
9 | |||
10 | SRC_URI[gcc-arm-none.md5sum] = "299ebd3f1c2c90930d28ab82e5d8d6c0" | ||
11 | SRC_URI[gcc-arm-none.sha256sum] = "bb17109f0ee697254a5d4ae6e5e01440e3ea8f0277f2e8169bf95d07c7d5fe69" | ||
12 | |||
13 | S = "${WORKDIR}/gcc-arm-none-eabi-7-2018-q2-update" | ||
14 | |||
15 | # only x86_64 is supported | ||
16 | COMPATIBLE_HOST = "x86_64.*-linux" | ||
17 | COMPATIBLE_HOST_class-target = "null" | ||
18 | |||
19 | do_install() { | ||
20 | install -d ${D}${GCC_ARM_NONE_TOOLCHAIN_RECIPE} | ||
21 | cp -r ${S}/. ${D}${GCC_ARM_NONE_TOOLCHAIN_RECIPE} | ||
22 | } | ||
23 | |||
24 | FILES_${PN} = "${GCC_ARM_NONE_TOOLCHAIN_RECIPE}/*" | ||
25 | |||
26 | INSANE_SKIP_${PN} = "already-stripped libdir staticdev build-deps file-rdeps" | ||
27 | INHIBIT_PACKAGE_DEBUG_SPLIT = "1" | ||
28 | |||
29 | BBCLASSEXTEND = "native nativesdk" | ||
diff --git a/recipes-ti/devtools/gcc-arm-none-eabi_9-2019-q4-major.bb b/recipes-ti/devtools/gcc-arm-none-eabi_9-2019-q4-major.bb new file mode 100644 index 00000000..84f6dbab --- /dev/null +++ b/recipes-ti/devtools/gcc-arm-none-eabi_9-2019-q4-major.bb | |||
@@ -0,0 +1,39 @@ | |||
1 | # Copyright (C) 2019 Garmin Ltd. or its subsidiaries | ||
2 | # Released under the MIT license (see COPYING.MIT for the terms) | ||
3 | |||
4 | SUMMARY = "Baremetal GCC for ARM-R and ARM-M processors" | ||
5 | LICENSE = "GPL-3.0-with-GCC-exception & GPLv3" | ||
6 | |||
7 | LIC_FILES_CHKSUM = "file://share/doc/gcc-arm-none-eabi/license.txt;md5=c18349634b740b7b95f2c2159af888f5" | ||
8 | |||
9 | PROVIDES = "virtual/arm-none-eabi-gcc" | ||
10 | |||
11 | SRC_URI = "https://developer.arm.com/-/media/Files/downloads/gnu-rm/9-2019q4/${BPN}-${PV}-x86_64-linux.tar.bz2" | ||
12 | |||
13 | SRC_URI[md5sum] = "fe0029de4f4ec43cf7008944e34ff8cc" | ||
14 | SRC_URI[sha256sum] = "bcd840f839d5bf49279638e9f67890b2ef3a7c9c7a9b25271e83ec4ff41d177a" | ||
15 | |||
16 | S = "${WORKDIR}/${BPN}-${PV}" | ||
17 | |||
18 | COMPATIBLE_HOST = "x86_64.*-linux" | ||
19 | |||
20 | do_install() { | ||
21 | install -d ${D}${datadir}/arm-none-eabi/ | ||
22 | cp -r ${S}/. ${D}${datadir}/arm-none-eabi/ | ||
23 | |||
24 | install -d ${D}${bindir} | ||
25 | # Symlink all executables into bindir | ||
26 | for f in ${D}${datadir}/arm-none-eabi/bin/arm-none-eabi-*; do | ||
27 | lnr $f ${D}${bindir}/$(basename $f) | ||
28 | done | ||
29 | } | ||
30 | |||
31 | FILES_${PN} = "${datadir} ${bindir}" | ||
32 | |||
33 | INSANE_SKIP_${PN} = "already-stripped libdir staticdev file-rdeps" | ||
34 | |||
35 | INHIBIT_SYSROOT_STRIP = "1" | ||
36 | INHIBIT_PACKAGE_STRIP = "1" | ||
37 | INHIBIT_PACKAGE_DEBUG_SPLIT = "1" | ||
38 | |||
39 | BBCLASSEXTEND = "native nativesdk" | ||
diff --git a/recipes-ti/devtools/gcc-linaro-baremetal-aarch64-native.bb b/recipes-ti/devtools/gcc-linaro-baremetal-aarch64-native.bb deleted file mode 100644 index 97344f90..00000000 --- a/recipes-ti/devtools/gcc-linaro-baremetal-aarch64-native.bb +++ /dev/null | |||
@@ -1,23 +0,0 @@ | |||
1 | include recipes-ti/devtools/gcc-linaro.inc | ||
2 | |||
3 | PACKAGE_DIR = "gcc-linaro-${PV}-${GCC_ARM_YEAR}-x86_64_aarch64-elf" | ||
4 | S = "${WORKDIR}/${PACKAGE_DIR}" | ||
5 | |||
6 | LIC_CHKSUM = "bc7fad4bba98e7a4cd5ab3042506493c" | ||
7 | |||
8 | inherit native | ||
9 | require recipes-ti/includes/ti-paths.inc | ||
10 | |||
11 | SRC_URI = "https://releases.linaro.org/components/toolchain/binaries/7.2-${GCC_ARM_YEAR}/aarch64-elf/gcc-linaro-${PV}-${GCC_ARM_YEAR}-x86_64_aarch64-elf.tar.xz;name=gcc-linaro-aarch64" | ||
12 | |||
13 | SRC_URI[gcc-linaro-aarch64.md5sum] = "4972f8943820bdd2f577f498de78964b" | ||
14 | SRC_URI[gcc-linaro-aarch64.sha256sum] = "30fb7d876bcb982c502057c593d9c1f11b35d5158a26d986718e2b998388c4c8" | ||
15 | |||
16 | do_install() { | ||
17 | install -d ${D}${GCC_LINARO_BAREMETAL_AARCH64_TOOLCHAIN_RECIPE} | ||
18 | cp -r ${S}/. ${D}${GCC_LINARO_BAREMETAL_AARCH64_TOOLCHAIN_RECIPE} | ||
19 | } | ||
20 | |||
21 | FILES_${PN} = "${GCC_LINARO_BAREMETAL_AARCH64_TOOLCHAIN_RECIPE}/*" | ||
22 | |||
23 | INSANE_SKIP_${PN} = "already-stripped" | ||
diff --git a/recipes-ti/devtools/gcc-linaro-baremetal-native.bb b/recipes-ti/devtools/gcc-linaro-baremetal-native.bb deleted file mode 100644 index 0268ae3d..00000000 --- a/recipes-ti/devtools/gcc-linaro-baremetal-native.bb +++ /dev/null | |||
@@ -1,23 +0,0 @@ | |||
1 | include recipes-ti/devtools/gcc-linaro.inc | ||
2 | |||
3 | PACKAGE_DIR = "gcc-linaro-${PV}-${GCC_ARM_YEAR}-x86_64_arm-eabi" | ||
4 | S = "${WORKDIR}/${PACKAGE_DIR}" | ||
5 | |||
6 | LIC_CHKSUM = "bc7fad4bba98e7a4cd5ab3042506493c" | ||
7 | |||
8 | inherit native | ||
9 | require recipes-ti/includes/ti-paths.inc | ||
10 | |||
11 | SRC_URI = "https://releases.linaro.org/components/toolchain/binaries/7.2-${GCC_ARM_YEAR}/arm-eabi/gcc-linaro-${PV}-${GCC_ARM_YEAR}-x86_64_arm-eabi.tar.xz;name=gcc-linaro" | ||
12 | |||
13 | SRC_URI[gcc-linaro.md5sum] = "9a4a39cfc78c84375b1160aa93587aed" | ||
14 | SRC_URI[gcc-linaro.sha256sum] = "45fc4f90af2e2e9c3197a275f6005ef5639f7a1889fa3eb24c3125ccd70fcd3d" | ||
15 | |||
16 | do_install() { | ||
17 | install -d ${D}${GCC_LINARO_BAREMETAL_TOOLCHAIN_RECIPE} | ||
18 | cp -r ${S}/. ${D}${GCC_LINARO_BAREMETAL_TOOLCHAIN_RECIPE} | ||
19 | } | ||
20 | |||
21 | FILES_${PN} = "${GCC_LINARO_BAREMETAL_TOOLCHAIN_RECIPE}/*" | ||
22 | |||
23 | INSANE_SKIP_${PN} = "already-stripped" | ||
diff --git a/recipes-ti/includes/ti-paths.inc b/recipes-ti/includes/ti-paths.inc index 52a93cf5..d45b77fa 100644 --- a/recipes-ti/includes/ti-paths.inc +++ b/recipes-ti/includes/ti-paths.inc | |||
@@ -48,7 +48,7 @@ export XDC_INSTALL_DIR_RECIPE = "${installdir}/ti-xdctools-tree" | |||
48 | export PDK_INSTALL_DIR_RECIPE = "${installdir}/ti-pdk-tree" | 48 | export PDK_INSTALL_DIR_RECIPE = "${installdir}/ti-pdk-tree" |
49 | export OSAL_INSTALL_DIR_RECIPE = "${installdir}/ti-osal-tree" | 49 | export OSAL_INSTALL_DIR_RECIPE = "${installdir}/ti-osal-tree" |
50 | export M4_TOOLCHAIN_INSTALL_DIR_RECIPE = "${installdir}/ti-cgt-arm" | 50 | export M4_TOOLCHAIN_INSTALL_DIR_RECIPE = "${installdir}/ti-cgt-arm" |
51 | export GCC_ARM_NONE_TOOLCHAIN_RECIPE = "${installdir}/gcc-arm-none-eabi" | 51 | export GCC_ARM_NONE_TOOLCHAIN_RECIPE = "${datadir}/arm-none-eabi" |
52 | export TI_CGT_PRU_INSTALL_DIR_RECIPE = "${installdir}/cgt-pru" | 52 | export TI_CGT_PRU_INSTALL_DIR_RECIPE = "${installdir}/cgt-pru" |
53 | export MATHLIB_C66_INSTALL_DIR_RECIPE = "${installdir}/ti-mathlib-c66x-tree" | 53 | export MATHLIB_C66_INSTALL_DIR_RECIPE = "${installdir}/ti-mathlib-c66x-tree" |
54 | export MATHLIB_C674_INSTALL_DIR_RECIPE = "${installdir}/ti-mathlib-c674x-tree" | 54 | export MATHLIB_C674_INSTALL_DIR_RECIPE = "${installdir}/ti-mathlib-c674x-tree" |
@@ -58,8 +58,8 @@ export CG_XML_INSTALL_DIR_RECIPE = "${installdir}/ti-cg-xml-tree" | |||
58 | export OMP_INSTALL_DIR_RECIPE = "${installdir}/ti-omp-tree" | 58 | export OMP_INSTALL_DIR_RECIPE = "${installdir}/ti-omp-tree" |
59 | export MPM_INSTALL_DIR_RECIPE = "${installdir}/ti-mpm-tree" | 59 | export MPM_INSTALL_DIR_RECIPE = "${installdir}/ti-mpm-tree" |
60 | export TI_CGT6X_7_INSTALL_DIR_RECIPE = "${installdir}/cgt6x-7" | 60 | export TI_CGT6X_7_INSTALL_DIR_RECIPE = "${installdir}/cgt6x-7" |
61 | export GCC_LINARO_BAREMETAL_TOOLCHAIN_RECIPE = "${installdir}/gcc-linaro-baremetal" | 61 | export GCC_LINARO_BAREMETAL_TOOLCHAIN_RECIPE = "${datadir}/arm-none-eabi" |
62 | export GCC_LINARO_BAREMETAL_AARCH64_TOOLCHAIN_RECIPE = "${installdir}/gcc-linaro-baremetal-aarch64" | 62 | export GCC_LINARO_BAREMETAL_AARCH64_TOOLCHAIN_RECIPE = "${datadir}/aarch64-none-elf" |
63 | export TI_CGT7X_INSTALL_DIR_RECIPE = "${installdir}/cgt-c7x" | 63 | export TI_CGT7X_INSTALL_DIR_RECIPE = "${installdir}/cgt-c7x" |
64 | 64 | ||
65 | 65 | ||