summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--recipes-ti/includes/ti-paths.inc2
-rw-r--r--recipes-ti/osal/ti-osal.inc21
-rw-r--r--recipes-ti/osal/ti-osal_1.24.00.09.bb9
3 files changed, 32 insertions, 0 deletions
diff --git a/recipes-ti/includes/ti-paths.inc b/recipes-ti/includes/ti-paths.inc
index b902cbb8..bd80fa11 100644
--- a/recipes-ti/includes/ti-paths.inc
+++ b/recipes-ti/includes/ti-paths.inc
@@ -44,6 +44,7 @@ export VICPLIB_INSTALL_DIR_RECIPE = "${installdir}/ti-vicplib-tree"
44export XDAIS_INSTALL_DIR_RECIPE = "${installdir}/ti-xdais-tree" 44export XDAIS_INSTALL_DIR_RECIPE = "${installdir}/ti-xdais-tree"
45export XDC_INSTALL_DIR_RECIPE = "${installdir}/ti-xdctools-tree" 45export XDC_INSTALL_DIR_RECIPE = "${installdir}/ti-xdctools-tree"
46export PDK_INSTALL_DIR_RECIPE = "${installdir}/ti-pdk-tree" 46export PDK_INSTALL_DIR_RECIPE = "${installdir}/ti-pdk-tree"
47export OSAL_INSTALL_DIR_RECIPE = "${installdir}/ti-osal-tree"
47 48
48# This is where the tools will end up in sysroot 49# This is where the tools will end up in sysroot
49export BIOS_INSTALL_DIR = "${STAGING_DIR_TARGET}${BIOS_INSTALL_DIR_RECIPE}" 50export BIOS_INSTALL_DIR = "${STAGING_DIR_TARGET}${BIOS_INSTALL_DIR_RECIPE}"
@@ -78,6 +79,7 @@ export UIA_INSTALL_DIR = "${STAGING_DIR_TARGET}${UIA_INSTALL_DIR_RECIPE}"
78export XDAIS_INSTALL_DIR = "${STAGING_DIR_TARGET}${XDAIS_INSTALL_DIR_RECIPE}" 79export XDAIS_INSTALL_DIR = "${STAGING_DIR_TARGET}${XDAIS_INSTALL_DIR_RECIPE}"
79export XDC_INSTALL_DIR = "${STAGING_DIR_TARGET}${XDC_INSTALL_DIR_RECIPE}" 80export XDC_INSTALL_DIR = "${STAGING_DIR_TARGET}${XDC_INSTALL_DIR_RECIPE}"
80export PDK_INSTALL_DIR = "${STAGING_DIR_TARGET}${PDK_INSTALL_DIR_RECIPE}" 81export PDK_INSTALL_DIR = "${STAGING_DIR_TARGET}${PDK_INSTALL_DIR_RECIPE}"
82export OSAL_INSTALL_DIR = "${STAGING_DIR_TARGET}${OSAL_INSTALL_DIR_RECIPE}"
81 83
82DSPSUFFIX_omapl137 = "x674" 84DSPSUFFIX_omapl137 = "x674"
83DSPSUFFIX_omapl138 = "x674" 85DSPSUFFIX_omapl138 = "x674"
diff --git a/recipes-ti/osal/ti-osal.inc b/recipes-ti/osal/ti-osal.inc
new file mode 100644
index 00000000..09ee883a
--- /dev/null
+++ b/recipes-ti/osal/ti-osal.inc
@@ -0,0 +1,21 @@
1DESCRIPTION = "TI Operating System Abstraction Library (OSAL)"
2HOMEPAGE = "http://software-dl.ti.com/dsps/dsps_public_sw/sdo_sb/targetcontent/osal"
3LICENSE = "BSD & EPL"
4SECTION = "devel"
5
6require ../includes/ti-paths.inc
7require ../includes/ti-staging.inc
8
9S = "${WORKDIR}/osal_${PV}"
10
11SRC_URI = "http://software-dl.ti.com/dsps/dsps_public_sw/sdo_sb/targetcontent/osal/${PV}/exports/osal_${PV}.tar.gz;name=osaltarball"
12
13do_install() {
14 install -d ${D}${OSAL_INSTALL_DIR_RECIPE}
15 cp -pPrf ${S}/* ${D}${OSAL_INSTALL_DIR_RECIPE}
16}
17
18INSANE_SKIP_${PN}-dev = "staticdev"
19
20ALLOW_EMPTY_${PN} = "1"
21FILES_${PN}-dev += "${OSAL_INSTALL_DIR_RECIPE}"
diff --git a/recipes-ti/osal/ti-osal_1.24.00.09.bb b/recipes-ti/osal/ti-osal_1.24.00.09.bb
new file mode 100644
index 00000000..226458be
--- /dev/null
+++ b/recipes-ti/osal/ti-osal_1.24.00.09.bb
@@ -0,0 +1,9 @@
1require ti-osal.inc
2
3PV = "1_24_00_09"
4PR = "r0"
5
6LIC_FILES_CHKSUM = "file://osal_${PV}_Manifest.html;md5=c110191994d011cee4cd02189ed3c9f4"
7
8SRC_URI[osaltarball.md5sum] = "a7ea85447fa0ff0f786d527a52fa6e8b"
9SRC_URI[osaltarball.sha256sum] = "d14f1f43c8a7965e86add69bd813cea56ea7e38abeb55de3fdcdaf4a69f19bf3"