diff options
-rw-r--r-- | conf/machine/am62xx-lp-evm-k3r5-hs-fs.conf | 14 | ||||
-rw-r--r-- | conf/machine/am62xx-lp-evm-k3r5-hs-se.conf | 7 | ||||
-rw-r--r-- | conf/machine/include/am62xx-lp.inc | 8 | ||||
-rw-r--r-- | recipes-bsp/ti-sci-fw/ti-sci-fw_git.bb | 1 |
4 files changed, 29 insertions, 1 deletions
diff --git a/conf/machine/am62xx-lp-evm-k3r5-hs-fs.conf b/conf/machine/am62xx-lp-evm-k3r5-hs-fs.conf new file mode 100644 index 00000000..0178fcfc --- /dev/null +++ b/conf/machine/am62xx-lp-evm-k3r5-hs-fs.conf | |||
@@ -0,0 +1,14 @@ | |||
1 | #@TYPE: Machine | ||
2 | #@NAME: AM62xx LPSK HS-FS EVM (R5F) | ||
3 | #@DESCRIPTION: Machine configuration for the TI AM62xx LP HS-FS EVM (R5F core) | ||
4 | |||
5 | # Booting HS-FS requires different SYSFW, the rest is handled at runtime | ||
6 | |||
7 | require conf/machine/include/k3r5.inc | ||
8 | SOC_FAMILY_append = ":k3r5-hs-fs" | ||
9 | |||
10 | SYSFW_SOC = "am62x" | ||
11 | SYSFW_CONFIG = "evm" | ||
12 | SYSFW_SUFFIX = "hs-fs" | ||
13 | |||
14 | UBOOT_MACHINE = "am62x_lpsk_r5_defconfig" | ||
diff --git a/conf/machine/am62xx-lp-evm-k3r5-hs-se.conf b/conf/machine/am62xx-lp-evm-k3r5-hs-se.conf index b752ee7e..b44cbe20 100644 --- a/conf/machine/am62xx-lp-evm-k3r5-hs-se.conf +++ b/conf/machine/am62xx-lp-evm-k3r5-hs-se.conf | |||
@@ -11,4 +11,11 @@ SYSFW_SOC = "am62x" | |||
11 | SYSFW_CONFIG = "evm" | 11 | SYSFW_CONFIG = "evm" |
12 | SYSFW_SUFFIX = "hs" | 12 | SYSFW_SUFFIX = "hs" |
13 | 13 | ||
14 | SYSFW_TIBOOT3_SYMLINK = "" | ||
15 | |||
14 | UBOOT_MACHINE = "am62x_lpsk_r5_defconfig" | 16 | UBOOT_MACHINE = "am62x_lpsk_r5_defconfig" |
17 | |||
18 | SPL_BINARY = "" | ||
19 | UBOOT_BINARY = "u-boot-spl.${UBOOT_SUFFIX}" | ||
20 | UBOOT_IMAGE = "u-boot-r5spl-hs-se-${MAINMACHINE}-${PV}-${PR}.${UBOOT_SUFFIX}" | ||
21 | UBOOT_SYMLINK = "u-boot-r5spl-hs-se.${UBOOT_SUFFIX}" | ||
diff --git a/conf/machine/include/am62xx-lp.inc b/conf/machine/include/am62xx-lp.inc index c38de868..02937662 100644 --- a/conf/machine/include/am62xx-lp.inc +++ b/conf/machine/include/am62xx-lp.inc | |||
@@ -8,8 +8,14 @@ SERIAL_CONSOLES_CHECK = "${SERIAL_CONSOLES}" | |||
8 | 8 | ||
9 | TFA_K3_SYSTEM_SUSPEND = "1" | 9 | TFA_K3_SYSTEM_SUSPEND = "1" |
10 | 10 | ||
11 | # Default tiboot3.bin on AM62x LP is for HS-SE | 11 | # Default tiboot3.bin on AM62x LP is for HS-FS |
12 | BBMULTICONFIG = "k3r5-hs-fs" | ||
13 | do_image_wic[mcdepends] = "mc::k3r5-hs-fs:ti-sci-fw:do_deploy" | ||
14 | do_image_tar[mcdepends] = "mc::k3r5-hs-fs:ti-sci-fw:do_deploy" | ||
15 | |||
16 | # Since default tiboot3.bin on AM62x LP is for HS-FS, add a version for HS-SE | ||
12 | BBMULTICONFIG += "k3r5-hs-se" | 17 | BBMULTICONFIG += "k3r5-hs-se" |
18 | IMAGE_BOOT_FILES += " tiboot3-am62x-hs-evm.bin" | ||
13 | do_image_wic[mcdepends] += "mc::k3r5-hs-se:ti-sci-fw:do_deploy" | 19 | do_image_wic[mcdepends] += "mc::k3r5-hs-se:ti-sci-fw:do_deploy" |
14 | do_image_tar[mcdepends] += "mc::k3r5-hs-se:ti-sci-fw:do_deploy" | 20 | do_image_tar[mcdepends] += "mc::k3r5-hs-se:ti-sci-fw:do_deploy" |
15 | 21 | ||
diff --git a/recipes-bsp/ti-sci-fw/ti-sci-fw_git.bb b/recipes-bsp/ti-sci-fw/ti-sci-fw_git.bb index 7d046750..643a2ab3 100644 --- a/recipes-bsp/ti-sci-fw/ti-sci-fw_git.bb +++ b/recipes-bsp/ti-sci-fw/ti-sci-fw_git.bb | |||
@@ -42,6 +42,7 @@ SYSFW_PREFIX_am62xx-evm-k3r5-hs-se = "fs" | |||
42 | SYSFW_PREFIX_am62xx-evm-k3r5-hs-fs = "fs" | 42 | SYSFW_PREFIX_am62xx-evm-k3r5-hs-fs = "fs" |
43 | SYSFW_PREFIX_am62xx-lp-evm-k3r5 = "fs" | 43 | SYSFW_PREFIX_am62xx-lp-evm-k3r5 = "fs" |
44 | SYSFW_PREFIX_am62xx-lp-evm-k3r5-hs-se = "fs" | 44 | SYSFW_PREFIX_am62xx-lp-evm-k3r5-hs-se = "fs" |
45 | SYSFW_PREFIX_am62xx-lp-evm-k3r5-hs-fs = "fs" | ||
45 | SYSFW_PREFIX_am62axx-evm-k3r5 = "fs" | 46 | SYSFW_PREFIX_am62axx-evm-k3r5 = "fs" |
46 | 47 | ||
47 | SYSFW_TISCI = "${S}/ti-sysfw/ti-${SYSFW_PREFIX}-firmware-${SYSFW_SOC}-*.bin" | 48 | SYSFW_TISCI = "${S}/ti-sysfw/ti-${SYSFW_PREFIX}-firmware-${SYSFW_SOC}-*.bin" |