diff options
3 files changed, 63 insertions, 1 deletions
diff --git a/recipes-bsp/powervr-drivers/ti-sgx-ddk-km/0001-buildvars.mk-pass-Wno-cast-function-type.patch b/recipes-bsp/powervr-drivers/ti-sgx-ddk-km/0001-buildvars.mk-pass-Wno-cast-function-type.patch new file mode 100644 index 00000000..e1d2d10d --- /dev/null +++ b/recipes-bsp/powervr-drivers/ti-sgx-ddk-km/0001-buildvars.mk-pass-Wno-cast-function-type.patch | |||
@@ -0,0 +1,26 @@ | |||
1 | From 287ca27cdf9004b4ba9bb0ce30d6139f707246f9 Mon Sep 17 00:00:00 2001 | ||
2 | From: Denys Dmytriyenko <denys@ti.com> | ||
3 | Date: Sun, 14 Oct 2018 19:53:14 -0400 | ||
4 | Subject: [PATCH] buildvars.mk: pass -Wno-cast-function-type | ||
5 | |||
6 | Signed-off-by: Denys Dmytriyenko <denys@ti.com> | ||
7 | --- | ||
8 | eurasia_km/eurasiacon/build/linux2/buildvars.mk | 2 +- | ||
9 | 1 file changed, 1 insertion(+), 1 deletion(-) | ||
10 | |||
11 | diff --git a/eurasia_km/eurasiacon/build/linux2/buildvars.mk b/eurasia_km/eurasiacon/build/linux2/buildvars.mk | ||
12 | index f30e467..f00f852 100644 | ||
13 | --- a/eurasia_km/eurasiacon/build/linux2/buildvars.mk | ||
14 | +++ b/eurasia_km/eurasiacon/build/linux2/buildvars.mk | ||
15 | @@ -48,7 +48,7 @@ | ||
16 | |||
17 | # These flags are used for kernel, User C and User C++ | ||
18 | # | ||
19 | -COMMON_FLAGS := -W -Wall | ||
20 | +COMMON_FLAGS := -W -Wall -Wno-cast-function-type | ||
21 | |||
22 | # Some GCC warnings are C only, so we must mask them from C++ | ||
23 | # | ||
24 | -- | ||
25 | 2.7.4 | ||
26 | |||
diff --git a/recipes-bsp/powervr-drivers/ti-sgx-ddk-km/0001-srvkm-env-linux-osfunc.c-fix-gcc8-stringop-truncatio.patch b/recipes-bsp/powervr-drivers/ti-sgx-ddk-km/0001-srvkm-env-linux-osfunc.c-fix-gcc8-stringop-truncatio.patch new file mode 100644 index 00000000..96e657d0 --- /dev/null +++ b/recipes-bsp/powervr-drivers/ti-sgx-ddk-km/0001-srvkm-env-linux-osfunc.c-fix-gcc8-stringop-truncatio.patch | |||
@@ -0,0 +1,34 @@ | |||
1 | From 353d8b9313abc492e5938171cea4ac697fd991f0 Mon Sep 17 00:00:00 2001 | ||
2 | From: Denys Dmytriyenko <denys@ti.com> | ||
3 | Date: Sun, 14 Oct 2018 19:41:49 -0400 | ||
4 | Subject: [PATCH] srvkm/env/linux/osfunc.c: fix gcc8 stringop-truncation error | ||
5 | |||
6 | gcc8 now checks for strncpy function that potentially truncate the terminating | ||
7 | NUL charcter from the source string. Fails like this: | ||
8 | |||
9 | .../services4/srvkm/env/linux/osfunc.c:3051:13: error: 'strncpy' specified bound 50 equals destination size [-Werror=stringop-truncation] | ||
10 | | strncpy(psEventObject->szName, pszName, EVENTOBJNAME_MAXLENGTH); | ||
11 | | ^~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~ | ||
12 | | cc1: all warnings being treated as errors | ||
13 | |||
14 | Signed-off-by: Denys Dmytriyenko <denys@ti.com> | ||
15 | --- | ||
16 | eurasia_km/services4/srvkm/env/linux/osfunc.c | 2 +- | ||
17 | 1 file changed, 1 insertion(+), 1 deletion(-) | ||
18 | |||
19 | diff --git a/eurasia_km/services4/srvkm/env/linux/osfunc.c b/eurasia_km/services4/srvkm/env/linux/osfunc.c | ||
20 | index 02dfe9b..02c8e3b 100644 | ||
21 | --- a/eurasia_km/services4/srvkm/env/linux/osfunc.c | ||
22 | +++ b/eurasia_km/services4/srvkm/env/linux/osfunc.c | ||
23 | @@ -3048,7 +3048,7 @@ PVRSRV_ERROR OSEventObjectCreateKM(const IMG_CHAR *pszName, PVRSRV_EVENTOBJECT * | ||
24 | if(pszName) | ||
25 | { | ||
26 | /* copy over the event object name */ | ||
27 | - strncpy(psEventObject->szName, pszName, EVENTOBJNAME_MAXLENGTH); | ||
28 | + strncpy(psEventObject->szName, pszName, EVENTOBJNAME_MAXLENGTH-1); | ||
29 | } | ||
30 | else | ||
31 | { | ||
32 | -- | ||
33 | 2.7.4 | ||
34 | |||
diff --git a/recipes-bsp/powervr-drivers/ti-sgx-ddk-km_1.14.3699939.bb b/recipes-bsp/powervr-drivers/ti-sgx-ddk-km_1.14.3699939.bb index a4eb82ae..e84c11b7 100644 --- a/recipes-bsp/powervr-drivers/ti-sgx-ddk-km_1.14.3699939.bb +++ b/recipes-bsp/powervr-drivers/ti-sgx-ddk-km_1.14.3699939.bb | |||
@@ -22,7 +22,9 @@ RCONFLICTS_${PN} = "omapdrm-pvr" | |||
22 | 22 | ||
23 | BRANCH = "ti-img-sgx/${PV}/k4.14" | 23 | BRANCH = "ti-img-sgx/${PV}/k4.14" |
24 | 24 | ||
25 | SRC_URI = "git://git.ti.com/graphics/omap5-sgx-ddk-linux.git;protocol=git;branch=${BRANCH}" | 25 | SRC_URI = "git://git.ti.com/graphics/omap5-sgx-ddk-linux.git;protocol=git;branch=${BRANCH} \ |
26 | file://0001-srvkm-env-linux-osfunc.c-fix-gcc8-stringop-truncatio.patch \ | ||
27 | file://0001-buildvars.mk-pass-Wno-cast-function-type.patch" | ||
26 | 28 | ||
27 | S = "${WORKDIR}/git" | 29 | S = "${WORKDIR}/git" |
28 | 30 | ||