summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--recipes-ti/ipc/ti-ipc-rtos.inc19
-rw-r--r--recipes-ti/ipc/ti-ipc-rtos_3.40.01.08.bb9
-rw-r--r--recipes-ti/ipc/ti-ipc-rtos_git.bb55
-rw-r--r--recipes-ti/ipc/ti-ipc.inc26
-rw-r--r--recipes-ti/ipc/ti-ipc_git.bb29
5 files changed, 87 insertions, 51 deletions
diff --git a/recipes-ti/ipc/ti-ipc-rtos.inc b/recipes-ti/ipc/ti-ipc-rtos.inc
deleted file mode 100644
index d14c7567..00000000
--- a/recipes-ti/ipc/ti-ipc-rtos.inc
+++ /dev/null
@@ -1,19 +0,0 @@
1DESCRIPTION = "TI Inter Process Communication (IPC) Mechanisms (for Uni- and Multi- Processor Configurations)"
2HOMEPAGE="http://processors.wiki.ti.com/index.php/Category:IPC"
3
4LICENSE = "BSD"
5
6require recipes-ti/includes/ti-paths.inc
7require recipes-ti/includes/ti-staging.inc
8
9SRC_URI = "http://software-dl.ti.com/dsps/dsps_public_sw/sdo_sb/targetcontent/ipc/${PV}/exports/ipc_${PV}.zip;name=ipczip"
10
11S = "${WORKDIR}/ipc_${PV}"
12
13do_install() {
14 install -d ${D}${IPC_INSTALL_DIR_RECIPE}
15 cp -pPrf ${S}/* ${D}${IPC_INSTALL_DIR_RECIPE}
16}
17
18ALLOW_EMPTY_${PN} = "1"
19FILES_${PN}-dev += "${IPC_INSTALL_DIR_RECIPE}"
diff --git a/recipes-ti/ipc/ti-ipc-rtos_3.40.01.08.bb b/recipes-ti/ipc/ti-ipc-rtos_3.40.01.08.bb
deleted file mode 100644
index 7c93695b..00000000
--- a/recipes-ti/ipc/ti-ipc-rtos_3.40.01.08.bb
+++ /dev/null
@@ -1,9 +0,0 @@
1require ti-ipc-rtos.inc
2
3PV = "3_40_01_08"
4PR = "r0"
5
6LIC_FILES_CHKSUM = "file://${S}/ipc-linux.mak;beginline=1;endline=30;md5=7b327f9b710fd7c95e545b91cec79255"
7
8SRC_URI[ipczip.md5sum] = "738e1d54da9fab94899ad162f1ad78de"
9SRC_URI[ipczip.sha256sum] = "8cc7d40ad7eab916eae109b355dc7e7876c6ab82e3b40bf5b6bf60474312d6cf"
diff --git a/recipes-ti/ipc/ti-ipc-rtos_git.bb b/recipes-ti/ipc/ti-ipc-rtos_git.bb
new file mode 100644
index 00000000..2e9dba1d
--- /dev/null
+++ b/recipes-ti/ipc/ti-ipc-rtos_git.bb
@@ -0,0 +1,55 @@
1require recipes-ti/includes/ti-paths.inc
2require recipes-ti/includes/ti-staging.inc
3require ti-ipc.inc
4
5PR = "${INC_PR}.0"
6
7DEPENDS = "ti-xdctools ti-sysbios"
8DEPENDS_append_keystone += "ti-cgt6x-native gcc-arm-none-eabi-native"
9DEPENDS_append_omap-15 += "ti-cgt6x-native ti-ccsv6-native gcc-arm-none-eabi-native"
10
11PACKAGES =+ "${PN}-fw"
12FILES_${PN}-fw = "${libdir}/firmware/*"
13FILES_${PN}-dev += "${IPC_INSTALL_DIR_RECIPE}"
14
15INSANE_SKIP_${PN}-fw += "arch"
16INSANE_SKIP_${PN}-dev += "arch"
17
18ALLOW_EMPTY_${PN} = "1"
19
20IPC_TARGETS = ""
21IPC_TARGETS_omap-a15 = "\
22 gnu.targets.arm.A15F="${GCC_ARM_NONE_TOOLCHAIN}" \
23 ti.targets.elf.C66="${STAGING_DIR_NATIVE}/usr/share/ti/cgt-c6x" \
24 ti.targets.arm.elf.M4="${M4_TOOLCHAIN_INSTALL_DIR}" \
25 ti.targets.arm.elf.M4F="${M4_TOOLCHAIN_INSTALL_DIR}" \
26"
27
28IPC_TARGETS_keystone = " \
29 gnu.targets.arm.A15F="${GCC_ARM_NONE_TOOLCHAIN}" \
30 ti.targets.elf.C66="${STAGING_DIR_NATIVE}/usr/share/ti/cgt-c6x" \
31"
32
33EXTRA_OEMAKE = "\
34 PLATFORM=${PLATFORM} \
35 XDC_INSTALL_DIR="${XDC_INSTALL_DIR}" \
36 BIOS_INSTALL_DIR="${SYSBIOS_INSTALL_DIR}" \
37 ${IPC_TARGETS} -f ipc-bios.mak\
38"
39
40do_compile() {
41 oe_runmake clean
42 oe_runmake all
43}
44
45do_compile_append() {
46 sourceipk_do_create_srcipk
47}
48
49do_install() {
50 install -d ${D}${IPC_INSTALL_DIR_RECIPE}
51 cp -pPrf ${S}/* ${D}${IPC_INSTALL_DIR_RECIPE}
52
53 install -d ${D}${libdir}/firmware
54 find . -name "*.xe66" -type f | xargs -I {} install -m 0644 {} ${D}${libdir}/firmware/
55}
diff --git a/recipes-ti/ipc/ti-ipc.inc b/recipes-ti/ipc/ti-ipc.inc
new file mode 100644
index 00000000..d41796de
--- /dev/null
+++ b/recipes-ti/ipc/ti-ipc.inc
@@ -0,0 +1,26 @@
1DESCRIPTION = "TI Inter Process Communication (IPC) Mechanisms (for Uni- and Multi- Processor Configurations)"
2HOMEPAGE="http://processors.wiki.ti.com/index.php/Category:IPC"
3
4LICENSE = "BSD"
5LIC_FILES_CHKSUM = "file://${S}/ipc-linux.mak;beginline=1;endline=30;md5=7b327f9b710fd7c95e545b91cec79255"
6
7BRANCH = "ipc-next"
8
9SRC_URI = "git://git.ti.com/ipc/ipcdev.git;protocol=git;branch=${BRANCH}"
10
11#Corresponds to 3.41.00.03_eng
12SRCREV = "354db7d3b6aa397e6ab4b86fdbd312746fd46a07"
13
14S = "${WORKDIR}/git"
15PV = "3.41.00.03"
16INC_PR = "r0"
17
18PACKAGE_ARCH = "${MACHINE_ARCH}"
19
20PLATFORM = "UNKNOWN"
21PLATFORM_omap5-evm = "OMAP54XX"
22PLATFORM_dra7xx = "DRA7XX"
23PLATFORM_k2hk-evm = "TCI6638"
24PLATFORM_k2l-evm = "TCI6630"
25PLATFORM_k2e-evm = "66AK2E"
26PLATFORM_k2g-evm = "66AK2G"
diff --git a/recipes-ti/ipc/ti-ipc_git.bb b/recipes-ti/ipc/ti-ipc_git.bb
index a6b6a90d..f98df66d 100644
--- a/recipes-ti/ipc/ti-ipc_git.bb
+++ b/recipes-ti/ipc/ti-ipc_git.bb
@@ -1,32 +1,15 @@
1DESCRIPTION = "TI Inter Process Communication (IPC) Mechanisms (for Uni- and Multi- Processor Configurations)" 1DESCRIPTION = "TI Inter Process Communication (IPC) Mechanisms (for Uni- and Multi- Processor Configurations)"
2HOMEPAGE="http://processors.wiki.ti.com/index.php/Category:IPC" 2HOMEPAGE="http://processors.wiki.ti.com/index.php/Category:IPC"
3 3
4LICENSE = "BSD" 4require ti-ipc.inc
5LIC_FILES_CHKSUM = "file://${S}/ipc-linux.mak;beginline=1;endline=30;md5=7b327f9b710fd7c95e545b91cec79255"
6 5
7DEPENDS += "virtual/kernel" 6PR = "${INC_PR}.0"
8 7
9PV = "3.41.00.02" 8DEPENDS += "virtual/kernel"
10 9
11BRANCH = "ipc-next" 10SRC_URI += "file://tiipclad-daemon.sh \
12SRC_URI = "git://git.ti.com/ipc/ipcdev.git;protocol=git;branch=${BRANCH} \ 11 file://0001-Add-kernel-build-dir.patch \
13 file://tiipclad-daemon.sh \
14 file://0001-Add-kernel-build-dir.patch \
15 " 12 "
16# Commit corresponds to 3.41.00.02-eng
17SRCREV = "b34c8ada4ed243cd52e504bf2c6fb3451dc730f8"
18
19S = "${WORKDIR}/git"
20
21PACKAGE_ARCH = "${MACHINE_ARCH}"
22
23PLATFORM = "UNKNOWN"
24PLATFORM_omap5-evm = "OMAP54XX"
25PLATFORM_dra7xx = "DRA7XX"
26PLATFORM_k2hk-evm = "TCI6638"
27PLATFORM_k2l-evm = "TCI6630"
28PLATFORM_k2e-evm = "66AK2E"
29PLATFORM_k2g-evm = "66AK2E"
30 13
31DAEMON = "UNKNOWN" 14DAEMON = "UNKNOWN"
32DAEMON_omap5-evm = "lad_omap54xx_smp" 15DAEMON_omap5-evm = "lad_omap54xx_smp"
@@ -34,7 +17,7 @@ DAEMON_dra7xx = "lad_dra7xx"
34DAEMON_k2hk-evm = "lad_tci6638" 17DAEMON_k2hk-evm = "lad_tci6638"
35DAEMON_k2l-evm = "lad_tci6630" 18DAEMON_k2l-evm = "lad_tci6630"
36DAEMON_k2e-evm = "lad_66ak2e" 19DAEMON_k2e-evm = "lad_66ak2e"
37DAEMON_k2g-evm = "lad_66ak2e" 20DAEMON_k2g-evm = "lad_66ak2g"
38 21
39inherit autotools-brokensep pkgconfig update-rc.d 22inherit autotools-brokensep pkgconfig update-rc.d
40 23