summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--recipes-bsp/pruss-lld/pruss-lld-test_git.bb14
1 files changed, 11 insertions, 3 deletions
diff --git a/recipes-bsp/pruss-lld/pruss-lld-test_git.bb b/recipes-bsp/pruss-lld/pruss-lld-test_git.bb
index 7fdbfb6f..90764d15 100644
--- a/recipes-bsp/pruss-lld/pruss-lld-test_git.bb
+++ b/recipes-bsp/pruss-lld/pruss-lld-test_git.bb
@@ -4,18 +4,26 @@ DEPENDS="common-csl-ip pruss-lld osal"
4 4
5include pruss-lld.inc 5include pruss-lld.inc
6 6
7PR = "${INC_PR}.1" 7PR = "${INC_PR}.2"
8 8
9S = "${WORKDIR}/${PRUSS_LLD_GIT_DESTSUFFIX}" 9S = "${WORKDIR}/${PRUSS_LLD_GIT_DESTSUFFIX}"
10 10
11EXTRA_OEMAKE += "-f makefile_armv7 PDK_INSTALL_PATH=${STAGING_INCDIR} PRUSS_SRC_DIR=${S}" 11EXTRA_OEMAKE += "-f makefile_armv7 PDK_INSTALL_PATH=${STAGING_INCDIR} PRUSS_SRC_DIR=${S}"
12 12
13DEVICE_LIST ?= "${TI_PDK_LIMIT_SOCS}"
14
13do_compile () { 15do_compile () {
14# Build the tests 16# Build the tests
15 oe_runmake tests 17 for device in ${DEVICE_LIST}
18 do
19 oe_runmake tests DEVICE="$device"
20 done
16} 21}
17 22
18do_install () { 23do_install () {
19# Install the binary 24# Install the binary
20 oe_runmake installbin INSTALL_BIN_BASE_DIR=${D}${bindir} 25 for device in ${DEVICE_LIST}
26 do
27 oe_runmake installbin INSTALL_BIN_BASE_DIR=${D}${bindir} DEVICE="$device"
28 done
21} 29}