summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--recipes-bsp/ti-sci-fw/ti-sci-fw_git.bb18
-rw-r--r--recipes-bsp/trusted-firmware-a/trusted-firmware-a_%.bbappend8
-rw-r--r--recipes-bsp/u-boot/u-boot-ti.inc6
-rw-r--r--recipes-security/optee/optee-os_%.bbappend4
4 files changed, 36 insertions, 0 deletions
diff --git a/recipes-bsp/ti-sci-fw/ti-sci-fw_git.bb b/recipes-bsp/ti-sci-fw/ti-sci-fw_git.bb
index 9c70120c..4f1dd145 100644
--- a/recipes-bsp/ti-sci-fw/ti-sci-fw_git.bb
+++ b/recipes-bsp/ti-sci-fw/ti-sci-fw_git.bb
@@ -2,6 +2,7 @@ require recipes-bsp/ti-linux-fw/ti-linux-fw.inc
2 2
3DEPENDS = "openssl-native u-boot-mkimage-native dtc-native" 3DEPENDS = "openssl-native u-boot-mkimage-native dtc-native"
4DEPENDS_append_j7200-evm-k3r5 = " virtual/bootloader" 4DEPENDS_append_j7200-evm-k3r5 = " virtual/bootloader"
5DEPENDS_append_j7200-hs-evm-k3r5 = " virtual/bootloader"
5DEPENDS_append_am64xx-evm-k3r5 = " virtual/bootloader" 6DEPENDS_append_am64xx-evm-k3r5 = " virtual/bootloader"
6DEPENDS_append_am64xx-hs-evm-k3r5 = " virtual/bootloader" 7DEPENDS_append_am64xx-hs-evm-k3r5 = " virtual/bootloader"
7 8
@@ -24,6 +25,7 @@ SYSFW_PREFIX = "ti-sci-firmware"
24SYSFW_PREFIX_j7-evm-k3r5 = "ti-fs-firmware" 25SYSFW_PREFIX_j7-evm-k3r5 = "ti-fs-firmware"
25SYSFW_PREFIX_j7200-evm-k3r5 = "ti-fs-firmware" 26SYSFW_PREFIX_j7200-evm-k3r5 = "ti-fs-firmware"
26SYSFW_PREFIX_j7-hs-evm-k3r5 = "ti-fs-firmware" 27SYSFW_PREFIX_j7-hs-evm-k3r5 = "ti-fs-firmware"
28SYSFW_PREFIX_j7200-hs-evm-k3r5 = "ti-fs-firmware"
27 29
28SYSFW_SUFFIX ?= "unknown" 30SYSFW_SUFFIX ?= "unknown"
29 31
@@ -54,6 +56,7 @@ EXTRA_OEMAKE_HS = " \
54EXTRA_OEMAKE_append = "${@['',' ${EXTRA_OEMAKE_HS}']['${SYSFW_SUFFIX}' == 'hs']}" 56EXTRA_OEMAKE_append = "${@['',' ${EXTRA_OEMAKE_HS}']['${SYSFW_SUFFIX}' == 'hs']}"
55 57
56EXTRA_OEMAKE_append_j7200-evm-k3r5 = " SBL="${STAGING_DIR_HOST}/boot/u-boot-spl.bin"" 58EXTRA_OEMAKE_append_j7200-evm-k3r5 = " SBL="${STAGING_DIR_HOST}/boot/u-boot-spl.bin""
59EXTRA_OEMAKE_append_j7200-hs-evm-k3r5 = " SBL="${STAGING_DIR_HOST}/boot/u-boot-spl.bin""
57EXTRA_OEMAKE_append_am64xx-evm-k3r5 = " SBL="${STAGING_DIR_HOST}/boot/u-boot-spl.bin"" 60EXTRA_OEMAKE_append_am64xx-evm-k3r5 = " SBL="${STAGING_DIR_HOST}/boot/u-boot-spl.bin""
58EXTRA_OEMAKE_append_am64xx-hs-evm-k3r5 = " SBL="${STAGING_DIR_HOST}/boot/u-boot-spl.bin"" 61EXTRA_OEMAKE_append_am64xx-hs-evm-k3r5 = " SBL="${STAGING_DIR_HOST}/boot/u-boot-spl.bin""
59 62
@@ -103,6 +106,21 @@ do_deploy_j7200-evm-k3r5() {
103 install -m 644 ${SYSFW_TISCI} ${DEPLOYDIR}/ 106 install -m 644 ${SYSFW_TISCI} ${DEPLOYDIR}/
104} 107}
105 108
109do_install_j7200-hs-evm-k3r5() {
110 install -d ${D}/boot
111 install -m 644 ${WORKDIR}/imggen/${UBOOT_BINARY} ${D}/boot/${UBOOT_IMAGE}
112 ln -sf ${UBOOT_IMAGE} ${D}/boot/${UBOOT_SYMLINK}
113 ln -sf ${UBOOT_IMAGE} ${D}/boot/${UBOOT_BINARY}
114}
115
116do_deploy_j7200-hs-evm-k3r5() {
117 install -d ${DEPLOYDIR}
118 install -m 644 ${WORKDIR}/imggen/${UBOOT_BINARY} ${DEPLOYDIR}/${UBOOT_IMAGE}
119 ln -sf ${UBOOT_IMAGE} ${DEPLOYDIR}/${UBOOT_SYMLINK}
120 ln -sf ${UBOOT_IMAGE} ${DEPLOYDIR}/${UBOOT_BINARY}
121 install -m 644 ${SYSFW_TISCI} ${DEPLOYDIR}/
122}
123
106do_install_am64xx-evm-k3r5() { 124do_install_am64xx-evm-k3r5() {
107 install -d ${D}/boot 125 install -d ${D}/boot
108 install -m 644 ${WORKDIR}/imggen/${UBOOT_BINARY} ${D}/boot/${UBOOT_IMAGE} 126 install -m 644 ${WORKDIR}/imggen/${UBOOT_BINARY} ${D}/boot/${UBOOT_IMAGE}
diff --git a/recipes-bsp/trusted-firmware-a/trusted-firmware-a_%.bbappend b/recipes-bsp/trusted-firmware-a/trusted-firmware-a_%.bbappend
index 90fa0333..2a8f41ee 100644
--- a/recipes-bsp/trusted-firmware-a/trusted-firmware-a_%.bbappend
+++ b/recipes-bsp/trusted-firmware-a/trusted-firmware-a_%.bbappend
@@ -31,3 +31,11 @@ do_compile_append_j7-hs-evm() {
31 ${TI_SECURE_DEV_PKG}/scripts/secure-binary-image.sh bl31.bin.unsigned bl31.bin; \ 31 ${TI_SECURE_DEV_PKG}/scripts/secure-binary-image.sh bl31.bin.unsigned bl31.bin; \
32 ) 32 )
33} 33}
34
35do_compile_append_j7200-hs-evm() {
36 export TI_SECURE_DEV_PKG=${TI_SECURE_DEV_PKG}
37 ( cd ${B}/${BUILD_DIR}/release/; \
38 mv bl31.bin bl31.bin.unsigned; \
39 ${TI_SECURE_DEV_PKG}/scripts/secure-binary-image.sh bl31.bin.unsigned bl31.bin; \
40 )
41}
diff --git a/recipes-bsp/u-boot/u-boot-ti.inc b/recipes-bsp/u-boot/u-boot-ti.inc
index 131c03e8..f9cbb074 100644
--- a/recipes-bsp/u-boot/u-boot-ti.inc
+++ b/recipes-bsp/u-boot/u-boot-ti.inc
@@ -65,6 +65,7 @@ SPL_UART_BINARY_keystone = ""
65SPL_UART_BINARY_k3r5 = "" 65SPL_UART_BINARY_k3r5 = ""
66SPL_UART_BINARY_lego-ev3 = "" 66SPL_UART_BINARY_lego-ev3 = ""
67SPL_UART_BINARY_j7200-evm-k3r5 = "u-boot-spl.bin" 67SPL_UART_BINARY_j7200-evm-k3r5 = "u-boot-spl.bin"
68SPL_UART_BINARY_j7200-hs-evm-k3r5 = "u-boot-spl.bin"
68SPL_UART_BINARY_am64xx-evm-k3r5 = "u-boot-spl.bin" 69SPL_UART_BINARY_am64xx-evm-k3r5 = "u-boot-spl.bin"
69SPL_UART_BINARY_am64xx-hs-evm-k3r5 = "u-boot-spl.bin" 70SPL_UART_BINARY_am64xx-hs-evm-k3r5 = "u-boot-spl.bin"
70 71
@@ -397,6 +398,11 @@ do_deploy_append_j7200-evm-k3r5 () {
397 mv ${DEPLOYDIR}/u-boot-spl.bin ${DEPLOYDIR}/u-boot-spl-r5spl.bin || true 398 mv ${DEPLOYDIR}/u-boot-spl.bin ${DEPLOYDIR}/u-boot-spl-r5spl.bin || true
398} 399}
399 400
401do_deploy_append_j7200-hs-evm-k3r5 () {
402 mv ${DEPLOYDIR}/tiboot3.bin ${DEPLOYDIR}/tiboot3-r5spl.bin || true
403 mv ${DEPLOYDIR}/u-boot-spl.bin ${DEPLOYDIR}/u-boot-spl-r5spl.bin || true
404}
405
400do_deploy_append_am64xx-evm-k3r5 () { 406do_deploy_append_am64xx-evm-k3r5 () {
401 mv ${DEPLOYDIR}/tiboot3.bin ${DEPLOYDIR}/tiboot3-r5spl.bin || true 407 mv ${DEPLOYDIR}/tiboot3.bin ${DEPLOYDIR}/tiboot3-r5spl.bin || true
402 mv ${DEPLOYDIR}/u-boot-spl.bin ${DEPLOYDIR}/u-boot-spl-r5spl.bin || true 408 mv ${DEPLOYDIR}/u-boot-spl.bin ${DEPLOYDIR}/u-boot-spl-r5spl.bin || true
diff --git a/recipes-security/optee/optee-os_%.bbappend b/recipes-security/optee/optee-os_%.bbappend
index 401ac534..9bd0b933 100644
--- a/recipes-security/optee/optee-os_%.bbappend
+++ b/recipes-security/optee/optee-os_%.bbappend
@@ -69,6 +69,10 @@ do_compile_append_j7-hs-evm() {
69 optee_sign_k3hs 69 optee_sign_k3hs
70} 70}
71 71
72do_compile_append_j7200-hs-evm() {
73 optee_sign_k3hs
74}
75
72do_install_append_ti-soc() { 76do_install_append_ti-soc() {
73 install -m 644 ${B}/*.optee ${D}${nonarch_base_libdir}/firmware/ || true 77 install -m 644 ${B}/*.optee ${D}${nonarch_base_libdir}/firmware/ || true
74 install -m 644 ${B}/bl32.bin ${D}${nonarch_base_libdir}/firmware/ || true 78 install -m 644 ${B}/bl32.bin ${D}${nonarch_base_libdir}/firmware/ || true