diff options
-rw-r--r-- | recipes-ti/ipc/ti-ipc-common.inc | 5 | ||||
-rw-r--r-- | recipes-ti/ipc/ti-ipc-rtos.inc | 20 | ||||
-rw-r--r-- | recipes-ti/ipc/ti-ipc.inc | 6 | ||||
-rw-r--r-- | recipes-ti/ipc/ti-ipc_git.bb | 1 |
4 files changed, 22 insertions, 10 deletions
diff --git a/recipes-ti/ipc/ti-ipc-common.inc b/recipes-ti/ipc/ti-ipc-common.inc index c5f28e7c..d0f3aa51 100644 --- a/recipes-ti/ipc/ti-ipc-common.inc +++ b/recipes-ti/ipc/ti-ipc-common.inc | |||
@@ -1,5 +1,5 @@ | |||
1 | PV = "3.45.00.00" | 1 | PV = "3.46.00.01" |
2 | INC_PR = "r1" | 2 | INC_PR = "r0" |
3 | 3 | ||
4 | PACKAGE_ARCH = "${MACHINE_ARCH}" | 4 | PACKAGE_ARCH = "${MACHINE_ARCH}" |
5 | 5 | ||
@@ -10,5 +10,6 @@ PLATFORM_k2hk-evm = "TCI6638" | |||
10 | PLATFORM_k2l-evm = "TCI6630" | 10 | PLATFORM_k2l-evm = "TCI6630" |
11 | PLATFORM_k2e = "66AK2E" | 11 | PLATFORM_k2e = "66AK2E" |
12 | PLATFORM_k2g = "66AK2G" | 12 | PLATFORM_k2g = "66AK2G" |
13 | PLATFORM_omapl138 = "OMAPL138" | ||
13 | 14 | ||
14 | ALT_PLATFORM_k2hk-evm = "TCI6636" | 15 | ALT_PLATFORM_k2hk-evm = "TCI6636" |
diff --git a/recipes-ti/ipc/ti-ipc-rtos.inc b/recipes-ti/ipc/ti-ipc-rtos.inc index b29e984a..0d7e0e6b 100644 --- a/recipes-ti/ipc/ti-ipc-rtos.inc +++ b/recipes-ti/ipc/ti-ipc-rtos.inc | |||
@@ -28,16 +28,16 @@ name=${TI_IPC_METADATA_NAME}" | |||
28 | # Corresponds to tag: 3.45.00.00 | 28 | # Corresponds to tag: 3.45.00.00 |
29 | SRCREV_ipc-examples = "3a8ee1841ec36117a9bcd3d45bb2781bbd53ecf8" | 29 | SRCREV_ipc-examples = "3a8ee1841ec36117a9bcd3d45bb2781bbd53ecf8" |
30 | 30 | ||
31 | # Corresponds to tag: 3.45.00.00 | 31 | # Corresponds to tag: 3.46.00.01_eng |
32 | SRCREV_ipc-metadata = "30b83f09be1877f86b22c971d978cb478fc7dd6e" | 32 | SRCREV_ipc-metadata = "a04b677e9c55bbffd4bd7071ab7dfb6dde3eb97f" |
33 | 33 | ||
34 | S_ipc-examples = "${WORKDIR}/git/ipc-examples" | 34 | S_ipc-examples = "${WORKDIR}/git/ipc-examples" |
35 | S_ipc-metadata = "${WORKDIR}/git/ipc-metadata" | 35 | S_ipc-metadata = "${WORKDIR}/git/ipc-metadata" |
36 | 36 | ||
37 | RELEASE_TYPE = "GA" | 37 | RELEASE_TYPE = "ENG" |
38 | RELEASE_SUFFIX = "" | 38 | RELEASE_SUFFIX = "_eng" |
39 | 39 | ||
40 | PR = "${INC_PR}.3" | 40 | PR = "${INC_PR}.r0" |
41 | 41 | ||
42 | DEPENDS_append_keystone = " ti-cgt6x-native \ | 42 | DEPENDS_append_keystone = " ti-cgt6x-native \ |
43 | gcc-arm-none-eabi-native \ | 43 | gcc-arm-none-eabi-native \ |
@@ -46,7 +46,12 @@ DEPENDS_append_omap-a15 = " ti-cgt6x-native \ | |||
46 | ti-ccsv6-native \ | 46 | ti-ccsv6-native \ |
47 | gcc-arm-none-eabi-native \ | 47 | gcc-arm-none-eabi-native \ |
48 | " | 48 | " |
49 | DEPENDS_append_omapl138 = " ti-cgt6x-native \ | ||
50 | gcc-arm-none-eabi-native \ | ||
51 | " | ||
52 | |||
49 | IPC_TARGETS = "" | 53 | IPC_TARGETS = "" |
54 | |||
50 | IPC_TARGETS_omap-a15 = "\ | 55 | IPC_TARGETS_omap-a15 = "\ |
51 | gnu.targets.arm.A15F="${GCC_ARM_NONE_TOOLCHAIN}" \ | 56 | gnu.targets.arm.A15F="${GCC_ARM_NONE_TOOLCHAIN}" \ |
52 | ti.targets.elf.C66="${STAGING_DIR_NATIVE}/usr/share/ti/cgt-c6x" \ | 57 | ti.targets.elf.C66="${STAGING_DIR_NATIVE}/usr/share/ti/cgt-c6x" \ |
@@ -54,6 +59,11 @@ IPC_TARGETS_omap-a15 = "\ | |||
54 | ti.targets.arm.elf.M4="${M4_TOOLCHAIN_INSTALL_DIR}" \ | 59 | ti.targets.arm.elf.M4="${M4_TOOLCHAIN_INSTALL_DIR}" \ |
55 | " | 60 | " |
56 | 61 | ||
62 | IPC_TARGETS_omapl138 = "\ | ||
63 | gnu.targets.arm.A15F="${GCC_ARM_NONE_TOOLCHAIN}" \ | ||
64 | ti.targets.elf.C674="${STAGING_DIR_NATIVE}/usr/share/ti/cgt-c6x" \ | ||
65 | " | ||
66 | |||
57 | IPC_TARGETS_keystone = " \ | 67 | IPC_TARGETS_keystone = " \ |
58 | gnu.targets.arm.A15F="${GCC_ARM_NONE_TOOLCHAIN}" \ | 68 | gnu.targets.arm.A15F="${GCC_ARM_NONE_TOOLCHAIN}" \ |
59 | ti.targets.elf.C66="${STAGING_DIR_NATIVE}/usr/share/ti/cgt-c6x" \ | 69 | ti.targets.elf.C66="${STAGING_DIR_NATIVE}/usr/share/ti/cgt-c6x" \ |
diff --git a/recipes-ti/ipc/ti-ipc.inc b/recipes-ti/ipc/ti-ipc.inc index ea256d24..e2a91cf1 100644 --- a/recipes-ti/ipc/ti-ipc.inc +++ b/recipes-ti/ipc/ti-ipc.inc | |||
@@ -6,10 +6,10 @@ LIC_FILES_CHKSUM = "file://${S}/ipc-linux.mak;beginline=1;endline=30;md5=7b327f9 | |||
6 | 6 | ||
7 | TI_IPC_GIT_URI = "git://git.ti.com/ipc/ipcdev.git" | 7 | TI_IPC_GIT_URI = "git://git.ti.com/ipc/ipcdev.git" |
8 | TI_IPC_GIT_PROTOCOL = "git" | 8 | TI_IPC_GIT_PROTOCOL = "git" |
9 | TI_IPC_GIT_BRANCH = "master" | 9 | TI_IPC_GIT_BRANCH = "3.46" |
10 | 10 | ||
11 | #Corresponds to 3.45.00.00 | 11 | #Corresponds to 3.46.00.01_eng |
12 | TI_IPC_SRCREV = "1584985938884bf6cb1d839779578354b1865ea4" | 12 | TI_IPC_SRCREV = "a404d6aac840b6170cf4e9d819738842ec91746e" |
13 | 13 | ||
14 | BRANCH = "${TI_IPC_GIT_BRANCH}" | 14 | BRANCH = "${TI_IPC_GIT_BRANCH}" |
15 | SRC_URI = "${TI_IPC_GIT_URI};protocol=${TI_IPC_GIT_PROTOCOL};branch=${BRANCH};name=ipcdev" | 15 | SRC_URI = "${TI_IPC_GIT_URI};protocol=${TI_IPC_GIT_PROTOCOL};branch=${BRANCH};name=ipcdev" |
diff --git a/recipes-ti/ipc/ti-ipc_git.bb b/recipes-ti/ipc/ti-ipc_git.bb index 05b4d85d..ce2eee0a 100644 --- a/recipes-ti/ipc/ti-ipc_git.bb +++ b/recipes-ti/ipc/ti-ipc_git.bb | |||
@@ -20,6 +20,7 @@ DAEMON_k2hk-evm = "lad_tci6638" | |||
20 | DAEMON_k2l-evm = "lad_tci6630" | 20 | DAEMON_k2l-evm = "lad_tci6630" |
21 | DAEMON_k2e = "lad_66ak2e" | 21 | DAEMON_k2e = "lad_66ak2e" |
22 | DAEMON_k2g = "lad_66ak2g" | 22 | DAEMON_k2g = "lad_66ak2g" |
23 | DAEMON_omapl138 = "lad_omapl138" | ||
23 | 24 | ||
24 | inherit autotools-brokensep pkgconfig update-rc.d | 25 | inherit autotools-brokensep pkgconfig update-rc.d |
25 | 26 | ||