summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta-ti-bsp/recipes-ti/ti-rtos-bin/ti-rtos-firmware.bb12
1 files changed, 12 insertions, 0 deletions
diff --git a/meta-ti-bsp/recipes-ti/ti-rtos-bin/ti-rtos-firmware.bb b/meta-ti-bsp/recipes-ti/ti-rtos-bin/ti-rtos-firmware.bb
index 93429570..317ff4c4 100644
--- a/meta-ti-bsp/recipes-ti/ti-rtos-bin/ti-rtos-firmware.bb
+++ b/meta-ti-bsp/recipes-ti/ti-rtos-bin/ti-rtos-firmware.bb
@@ -167,6 +167,16 @@ do_install:am62xx() {
167 install -m 0644 ${RTOS_DM_FW_DIR}/ipc_echo_testb_mcu1_0_release_strip.xer5f ${LEGACY_DM_FW_DIR} 167 install -m 0644 ${RTOS_DM_FW_DIR}/ipc_echo_testb_mcu1_0_release_strip.xer5f ${LEGACY_DM_FW_DIR}
168} 168}
169 169
170
171do_deploy() {
172 install -d ${DEPLOYDIR}
173}
174
175do_deploy:am62xx() {
176 install -d ${DEPLOYDIR}
177 install -m 0644 ${RTOS_DM_FW_DIR}/ipc_echo_testb_mcu1_0_release_strip.xer5f ${DEPLOYDIR}
178}
179
170# Set up names for the firmwares 180# Set up names for the firmwares
171ALTERNATIVE:${PN}:am65xx = "\ 181ALTERNATIVE:${PN}:am65xx = "\
172 am65x-mcu-r5f0_0-fw \ 182 am65x-mcu-r5f0_0-fw \
@@ -355,3 +365,5 @@ INSANE_SKIP:${PN} += "arch"
355# we don't want to configure and build the source code 365# we don't want to configure and build the source code
356do_compile[noexec] = "1" 366do_compile[noexec] = "1"
357do_configure[noexec] = "1" 367do_configure[noexec] = "1"
368
369addtask deploy after do_install