diff options
-rw-r--r-- | recipes-kernel/linux/linux-ti33x-psp-3.1/0031-am335x-evm-add-pdata-for-all-cape-EEPROM-permutation.patch | 63 | ||||
-rw-r--r-- | recipes-kernel/linux/linux-ti33x-psp_3.1.bb | 3 |
2 files changed, 65 insertions, 1 deletions
diff --git a/recipes-kernel/linux/linux-ti33x-psp-3.1/0031-am335x-evm-add-pdata-for-all-cape-EEPROM-permutation.patch b/recipes-kernel/linux/linux-ti33x-psp-3.1/0031-am335x-evm-add-pdata-for-all-cape-EEPROM-permutation.patch new file mode 100644 index 00000000..b4d16088 --- /dev/null +++ b/recipes-kernel/linux/linux-ti33x-psp-3.1/0031-am335x-evm-add-pdata-for-all-cape-EEPROM-permutation.patch | |||
@@ -0,0 +1,63 @@ | |||
1 | From 9365085cbe7061760f8ca4916b88b3c9c625f265 Mon Sep 17 00:00:00 2001 | ||
2 | From: Koen Kooi <koen@dominion.thruhere.net> | ||
3 | Date: Tue, 27 Dec 2011 20:17:36 +0100 | ||
4 | Subject: [PATCH 31/34] am335x-evm: add pdata for all cape EEPROM permutations | ||
5 | |||
6 | Signed-off-by: Koen Kooi <koen@dominion.thruhere.net> | ||
7 | --- | ||
8 | arch/arm/mach-omap2/board-am335xevm.c | 35 +++++++++++++++++++++++++++++--- | ||
9 | 1 files changed, 31 insertions(+), 4 deletions(-) | ||
10 | |||
11 | diff --git a/arch/arm/mach-omap2/board-am335xevm.c b/arch/arm/mach-omap2/board-am335xevm.c | ||
12 | index 8e1521c..116089f 100644 | ||
13 | --- a/arch/arm/mach-omap2/board-am335xevm.c | ||
14 | +++ b/arch/arm/mach-omap2/board-am335xevm.c | ||
15 | @@ -1148,14 +1148,41 @@ static struct i2c_board_info beaglebone_i2c_boardinfo2[] = { | ||
16 | }, | ||
17 | }; | ||
18 | |||
19 | +static struct at24_platform_data cape_eeprom_info = { | ||
20 | + .byte_len = (256*1024) / 8, | ||
21 | + .page_size = 64, | ||
22 | + .flags = AT24_FLAG_ADDR16, | ||
23 | + .context = (void *)NULL, | ||
24 | +}; | ||
25 | + | ||
26 | +static struct i2c_board_info __initdata cape_i2c_boardinfo[] = { | ||
27 | + { | ||
28 | + I2C_BOARD_INFO("24c256", 0x54), | ||
29 | + .platform_data = &cape_eeprom_info, | ||
30 | + }, | ||
31 | + { | ||
32 | + I2C_BOARD_INFO("24c256", 0x55), | ||
33 | + .platform_data = &cape_eeprom_info, | ||
34 | + }, | ||
35 | + { | ||
36 | + I2C_BOARD_INFO("24c256", 0x56), | ||
37 | + .platform_data = &cape_eeprom_info, | ||
38 | + }, | ||
39 | + { | ||
40 | + I2C_BOARD_INFO("24c256", 0x57), | ||
41 | + .platform_data = &cape_eeprom_info, | ||
42 | + }, | ||
43 | +}; | ||
44 | + | ||
45 | static void i2c2_init(int evm_id, int profile) | ||
46 | { | ||
47 | - setup_pin_mux(i2c2_pin_mux); | ||
48 | - omap_register_i2c_bus(3, 100, beaglebone_i2c_boardinfo2, | ||
49 | - ARRAY_SIZE(beaglebone_i2c_boardinfo2)); | ||
50 | - return; | ||
51 | + setup_pin_mux(i2c2_pin_mux); | ||
52 | + omap_register_i2c_bus(3, 100, cape_i2c_boardinfo, | ||
53 | + ARRAY_SIZE(cape_i2c_boardinfo)); | ||
54 | + return; | ||
55 | } | ||
56 | |||
57 | + | ||
58 | /* Setup McASP 1 */ | ||
59 | static void mcasp1_init(int evm_id, int profile) | ||
60 | { | ||
61 | -- | ||
62 | 1.7.7.4 | ||
63 | |||
diff --git a/recipes-kernel/linux/linux-ti33x-psp_3.1.bb b/recipes-kernel/linux/linux-ti33x-psp_3.1.bb index f7ec2f80..c48435bf 100644 --- a/recipes-kernel/linux/linux-ti33x-psp_3.1.bb +++ b/recipes-kernel/linux/linux-ti33x-psp_3.1.bb | |||
@@ -11,7 +11,7 @@ MULTI_CONFIG_BASE_SUFFIX = "" | |||
11 | 11 | ||
12 | BRANCH = "v3.1-meta-ti-r1r+gitr1d84d8853fa30cf3db2571a5aec572accca4e29d" | 12 | BRANCH = "v3.1-meta-ti-r1r+gitr1d84d8853fa30cf3db2571a5aec572accca4e29d" |
13 | SRCREV = "1d84d8853fa30cf3db2571a5aec572accca4e29d" | 13 | SRCREV = "1d84d8853fa30cf3db2571a5aec572accca4e29d" |
14 | MACHINE_KERNEL_PR_append = "g+gitr${SRCREV}" | 14 | MACHINE_KERNEL_PR_append = "h+gitr${SRCREV}" |
15 | 15 | ||
16 | COMPATIBLE_MACHINE = "(ti33x)" | 16 | COMPATIBLE_MACHINE = "(ti33x)" |
17 | 17 | ||
@@ -55,6 +55,7 @@ PATCHES_OVER_PSP = " \ | |||
55 | file://adc/0009-meta-ti-Remove-debug-messages-for-meta-ti.patch \ | 55 | file://adc/0009-meta-ti-Remove-debug-messages-for-meta-ti.patch \ |
56 | file://adc/0010-tscadc-switch-to-polling-instead-of-interrupts.patch \ | 56 | file://adc/0010-tscadc-switch-to-polling-instead-of-interrupts.patch \ |
57 | file://st7735fb/0001-st7735fb-WIP-framebuffer-driver-supporting-Adafruit-.patch \ | 57 | file://st7735fb/0001-st7735fb-WIP-framebuffer-driver-supporting-Adafruit-.patch \ |
58 | file://0031-am335x-evm-add-pdata-for-all-cape-EEPROM-permutation.patch \ | ||
58 | " | 59 | " |
59 | 60 | ||
60 | SRC_URI += "${@base_contains('DISTRO_FEATURES', 'tipspkernel', "", "${PATCHES_OVER_PSP}", d)}" | 61 | SRC_URI += "${@base_contains('DISTRO_FEATURES', 'tipspkernel', "", "${PATCHES_OVER_PSP}", d)}" |