diff options
-rw-r--r-- | recipes-bsp/common-csl-ip/common-csl-ip-rtos_git.bb | 33 |
1 files changed, 33 insertions, 0 deletions
diff --git a/recipes-bsp/common-csl-ip/common-csl-ip-rtos_git.bb b/recipes-bsp/common-csl-ip/common-csl-ip-rtos_git.bb new file mode 100644 index 00000000..5d4a552a --- /dev/null +++ b/recipes-bsp/common-csl-ip/common-csl-ip-rtos_git.bb | |||
@@ -0,0 +1,33 @@ | |||
1 | require common-csl-ip.inc | ||
2 | |||
3 | require recipes-ti/includes/ti-paths.inc | ||
4 | require recipes-ti/includes/ti-staging.inc | ||
5 | |||
6 | DEPENDS = "ti-xdctools ti-cgt6x-native ti-sysbios" | ||
7 | |||
8 | S = "${WORKDIR}/ti/csl" | ||
9 | |||
10 | export C6X_GEN_INSTALL_PATH="${STAGING_DIR_NATIVE}/usr" | ||
11 | export XDCCGROOT="${STAGING_DIR_NATIVE}/usr/share/ti/cgt-c6x" | ||
12 | export XDCPATH="${XDCCGROOT}/include;${XDC_INSTALL_DIR}/packages;${SYSBIOS_INSTALL_DIR}/packages" | ||
13 | |||
14 | do_configure() { | ||
15 | sed -i "s/\ \"\.\\\\\\\\\"\ +//" src/Module.xs | ||
16 | find -name "*.xs" -exec sed -i "s/ofd6x\.exe/ofd6x/" {} \; | ||
17 | find -name "*.xs" -exec sed -i "s/sectti\.exe/sectti/" {} \; | ||
18 | find -name "*.xs" -exec sed -i "/\.chm/d" {} \; | ||
19 | find -name "*.xs" -exec sed -i "s/pasm\_dos/pasm\_linux/" {} \; | ||
20 | } | ||
21 | |||
22 | do_compile() { | ||
23 | ${XDC_INSTALL_DIR}/xdc .make | ||
24 | ${XDC_INSTALL_DIR}/xdc clean | ||
25 | ${XDC_INSTALL_DIR}/xdc release | ||
26 | } | ||
27 | |||
28 | do_install () { | ||
29 | install -d ${D}${PDK_INSTALL_DIR_RECIPE}/packages | ||
30 | find -name "*.tar" -exec tar xf {} -C ${D}${PDK_INSTALL_DIR_RECIPE}/packages \; | ||
31 | } | ||
32 | |||
33 | FILES_${PN} += "${PDK_INSTALL_DIR_RECIPE}/packages" | ||