diff options
-rw-r--r-- | recipes-bsp/ti-display-sharing-fw/ti-display-sharing-fw_git.bb | 48 |
1 files changed, 0 insertions, 48 deletions
diff --git a/recipes-bsp/ti-display-sharing-fw/ti-display-sharing-fw_git.bb b/recipes-bsp/ti-display-sharing-fw/ti-display-sharing-fw_git.bb deleted file mode 100644 index 9115b6b4..00000000 --- a/recipes-bsp/ti-display-sharing-fw/ti-display-sharing-fw_git.bb +++ /dev/null | |||
@@ -1,48 +0,0 @@ | |||
1 | SUMMARY = "TI Display Sharing Firmware" | ||
2 | |||
3 | LICENSE = "TI-TFL" | ||
4 | LIC_FILES_CHKSUM = "file://LICENSE.ti;md5=b5aebf0668bdf95621259288c4a46d76" | ||
5 | |||
6 | PV = "06.01.00.00+git${SRCPV}" | ||
7 | PACKAGE_ARCH = "${MACHINE_ARCH}" | ||
8 | |||
9 | inherit deploy | ||
10 | inherit update-alternatives | ||
11 | |||
12 | PROTOCOL = "git" | ||
13 | BRANCH = "ti-linux-firmware" | ||
14 | SRCREV = "e7be1ab85266c47236330e2909997d20fc62e312" | ||
15 | |||
16 | SRC_URI = "git://git.ti.com/processor-firmware/ti-linux-firmware.git;protocol=${PROTOCOL};branch=${BRANCH}" | ||
17 | |||
18 | S = "${WORKDIR}/git" | ||
19 | |||
20 | TI_DISP_SHARE_FW_DIR = "${S}/ti-display-sharing/" | ||
21 | TI_DISP_SHARE_FW_FILENAME = "ti-display-sharing-j721e.bin" | ||
22 | |||
23 | # make sure that lib/firmware, and all its contents are part of the package | ||
24 | FILES_${PN} += "${base_libdir}/firmware" | ||
25 | |||
26 | do_install() { | ||
27 | install -d ${D}${base_libdir}/firmware | ||
28 | install -m 0755 ${TI_DISP_SHARE_FW_DIR}/${TI_DISP_SHARE_FW_FILENAME} ${D}${base_libdir}/firmware | ||
29 | } | ||
30 | |||
31 | TARGET_MAIN_R5FSS0_1 = "j7-main-r5f0_1-fw" | ||
32 | ALTERNATIVE_${PN} = "j7-main-r5f0_1-fw" | ||
33 | ALTERNATIVE_LINK_NAME[j7-main-r5f0_1-fw] = "${base_libdir}/firmware/${TARGET_MAIN_R5FSS0_1}" | ||
34 | ALTERNATIVE_TARGET[j7-main-r5f0_1-fw] = "${base_libdir}/firmware/${TI_DISP_SHARE_FW_FILENAME}" | ||
35 | ALTERNATIVE_PRIORITY = "9" | ||
36 | |||
37 | # This is used to prevent the build system to strip the executables | ||
38 | INHIBIT_PACKAGE_STRIP = "1" | ||
39 | INHIBIT_SYSROOT_STRIP = "1" | ||
40 | |||
41 | # This is used to prevent the build system to split the debug info in a separate file | ||
42 | INHIBIT_PACKAGE_DEBUG_SPLIT = "1" | ||
43 | # As it likely to be a different arch from the Yocto build, disable checking by adding "arch" to INSANE_SKIP | ||
44 | INSANE_SKIP_${PN} += "arch" | ||
45 | |||
46 | # we don't want to configure and build the source code | ||
47 | do_compile[noexec] = "1" | ||
48 | do_configure[noexec] = "1" | ||