summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--recipes-bsp/uio-module-drv/uio-module-drv.inc6
-rw-r--r--recipes-bsp/uio-module-drv/uio-module-drv_git.bb7
2 files changed, 9 insertions, 4 deletions
diff --git a/recipes-bsp/uio-module-drv/uio-module-drv.inc b/recipes-bsp/uio-module-drv/uio-module-drv.inc
index 567f7f65..ed34a8ab 100644
--- a/recipes-bsp/uio-module-drv/uio-module-drv.inc
+++ b/recipes-bsp/uio-module-drv/uio-module-drv.inc
@@ -1,9 +1,9 @@
1LICENSE = "BSD" 1LICENSE = "BSD"
2LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=2b7c96eb2aed7b0f6f922214dbde9016" 2LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=2b7c96eb2aed7b0f6f922214dbde9016"
3 3
4BRANCH = "master" 4BRANCH = "linux4.1"
5# This corresponds to version 01.00.02.03 5# This corresponds to version 02.00.00.00_eng
6SRCREV = "634a0c64763c5cd7840e2d439d0ee900455584c8" 6SRCREV = "6a7eda36e390658593a5b8d87b0f00beb3997240"
7 7
8SRC_URI = "git://git.ti.com/keystone-linux/uio-module-drv.git;protocol=git;branch=${BRANCH}" 8SRC_URI = "git://git.ti.com/keystone-linux/uio-module-drv.git;protocol=git;branch=${BRANCH}"
9 9
diff --git a/recipes-bsp/uio-module-drv/uio-module-drv_git.bb b/recipes-bsp/uio-module-drv/uio-module-drv_git.bb
index d75fda2c..445dc1c6 100644
--- a/recipes-bsp/uio-module-drv/uio-module-drv_git.bb
+++ b/recipes-bsp/uio-module-drv/uio-module-drv_git.bb
@@ -1,7 +1,7 @@
1DESCRIPTION="User space IO (UIO) driver for on-chip modules" 1DESCRIPTION="User space IO (UIO) driver for on-chip modules"
2 2
3include uio-module-drv.inc 3include uio-module-drv.inc
4PV = "1.0.2.3+git${SRCPV}" 4PV = "2.0.0.0+git${SRCPV}"
5 5
6# This package builds a kernel module, use kernel PR as base and append a local 6# This package builds a kernel module, use kernel PR as base and append a local
7MACHINE_KERNEL_PR_append = "b" 7MACHINE_KERNEL_PR_append = "b"
@@ -10,3 +10,8 @@ PR = "${MACHINE_KERNEL_PR}"
10module_auto_load_uio-module-drv = "uio-module-drv" 10module_auto_load_uio-module-drv = "uio-module-drv"
11 11
12inherit module 12inherit module
13
14do_install_append () {
15 install -d ${D}${includedir}
16 cp *.h ${D}${includedir}
17}