summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--recipes-ti/devtools/ti-cgt-arm_18.12.1.bb (renamed from recipes-ti/devtools/ti-cgt-arm-native_18.12.1.bb)7
1 files changed, 6 insertions, 1 deletions
diff --git a/recipes-ti/devtools/ti-cgt-arm-native_18.12.1.bb b/recipes-ti/devtools/ti-cgt-arm_18.12.1.bb
index 5d724069..eecde58f 100644
--- a/recipes-ti/devtools/ti-cgt-arm-native_18.12.1.bb
+++ b/recipes-ti/devtools/ti-cgt-arm_18.12.1.bb
@@ -4,7 +4,6 @@ LICENSE = "(TI-TSPA & Thai-Open-Source-Software-Center) & BSD-3-Clause & BSL-1.0
4 4
5LIC_FILES_CHKSUM = "file://ti-cgt-arm_${PV}.LTS/README.txt;md5=ab7a61241e90fcd144a756d88294cf30" 5LIC_FILES_CHKSUM = "file://ti-cgt-arm_${PV}.LTS/README.txt;md5=ab7a61241e90fcd144a756d88294cf30"
6 6
7inherit native
8require recipes-ti/includes/ti-unpack.inc 7require recipes-ti/includes/ti-unpack.inc
9require recipes-ti/includes/ti-staging.inc 8require recipes-ti/includes/ti-staging.inc
10require recipes-ti/includes/ti-paths.inc 9require recipes-ti/includes/ti-paths.inc
@@ -19,6 +18,10 @@ BINFILE = "ti_cgt_tms470_${PV}.LTS_linux_installer_x86.bin"
19TI_BIN_UNPK_ARGS = "--prefix ${S}" 18TI_BIN_UNPK_ARGS = "--prefix ${S}"
20TI_BIN_UNPK_CMDS = "" 19TI_BIN_UNPK_CMDS = ""
21 20
21# only x86_64 is supported
22COMPATIBLE_HOST = "x86_64.*-linux"
23COMPATIBLE_HOST_class-target = "null"
24
22do_install() { 25do_install() {
23 install -d ${D}${M4_TOOLCHAIN_INSTALL_DIR_RECIPE} 26 install -d ${D}${M4_TOOLCHAIN_INSTALL_DIR_RECIPE}
24 cp -r ${S}/ti-cgt-arm*/. ${D}${M4_TOOLCHAIN_INSTALL_DIR_RECIPE} 27 cp -r ${S}/ti-cgt-arm*/. ${D}${M4_TOOLCHAIN_INSTALL_DIR_RECIPE}
@@ -36,3 +39,5 @@ INHIBIT_SYSROOT_STRIP = "1"
36INHIBIT_PACKAGE_DEBUG_SPLIT = "1" 39INHIBIT_PACKAGE_DEBUG_SPLIT = "1"
37 40
38INSANE_SKIP_${PN} += "arch staticdev" 41INSANE_SKIP_${PN} += "arch staticdev"
42
43BBCLASSEXTEND = "native nativesdk"