summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--recipes-bsp/iqn2-lld/iqn2-lld.inc13
-rw-r--r--recipes-bsp/iqn2-lld/iqn2-lld_git.bb16
2 files changed, 29 insertions, 0 deletions
diff --git a/recipes-bsp/iqn2-lld/iqn2-lld.inc b/recipes-bsp/iqn2-lld/iqn2-lld.inc
new file mode 100644
index 00000000..c5b15116
--- /dev/null
+++ b/recipes-bsp/iqn2-lld/iqn2-lld.inc
@@ -0,0 +1,13 @@
1LIC_FILES_CHKSUM = "file://COPYING.txt;md5=5bdceac872dffdec915b819654ee23ea"
2LICENSE = "BSD-3-Clause"
3
4BRANCH = "master"
5SRC_URI = "git://git.ti.com/keystone-rtos/iqn2-lld.git;destsuffix=git/ti/drv/iqn2;protocol=git;branch=${BRANCH}"
6# Following commit corresponds to DEV.IQN_LLD.01.00.00.05B
7SRCREV = "ca35079f41d06259be39f992f55a9f815d305ef5"
8
9PV = "1.0.0.5"
10
11COMPATIBLE_MACHINE = "k2l-evm"
12
13S = "${WORKDIR}/git/ti/drv/iqn2"
diff --git a/recipes-bsp/iqn2-lld/iqn2-lld_git.bb b/recipes-bsp/iqn2-lld/iqn2-lld_git.bb
new file mode 100644
index 00000000..19ffc053
--- /dev/null
+++ b/recipes-bsp/iqn2-lld/iqn2-lld_git.bb
@@ -0,0 +1,16 @@
1DESCRIPTION = "TI IQN2 peripheral module low level driver"
2
3DEPENDS = "common-csl-ip"
4
5include iqn2-lld.inc
6
7EXTRA_OEMAKE = "-f makefile_armv7 PDK_INSTALL_PATH=${STAGING_INCDIR}"
8
9do_compile () {
10 oe_runmake clean
11 oe_runmake lib
12}
13
14do_install () {
15 oe_runmake install INSTALL_INC_BASE_DIR=${D}/${includedir} INSTALL_LIB_BASE_DIR=${D}${libdir}
16}