diff options
-rw-r--r-- | recipes-kernel/linux/kernel-rdepends.inc | 40 | ||||
-rw-r--r-- | recipes-kernel/linux/linux-ti-staging_5.4.bb | 45 | ||||
-rw-r--r-- | recipes-kernel/linux/setup-defconfig.inc | 2 |
3 files changed, 44 insertions, 43 deletions
diff --git a/recipes-kernel/linux/kernel-rdepends.inc b/recipes-kernel/linux/kernel-rdepends.inc new file mode 100644 index 00000000..56dfe4b2 --- /dev/null +++ b/recipes-kernel/linux/kernel-rdepends.inc | |||
@@ -0,0 +1,40 @@ | |||
1 | # Pull in the devicetree files into the rootfs | ||
2 | RDEPENDS_${KERNEL_PACKAGE_NAME}-base += "kernel-devicetree" | ||
3 | |||
4 | # Add run-time dependency for PM firmware to the rootfs | ||
5 | RDEPENDS_${KERNEL_PACKAGE_NAME}-base_append_ti33x = " amx3-cm3" | ||
6 | RDEPENDS_${KERNEL_PACKAGE_NAME}-base_append_ti43x = " amx3-cm3" | ||
7 | |||
8 | # Add run-time dependency for VPE VPDMA firmware to the rootfs | ||
9 | RDEPENDS_${KERNEL_PACKAGE_NAME}-base_append_dra7xx = " vpdma-fw" | ||
10 | |||
11 | # Add run-time dependency for Goodix firmware to the rootfs | ||
12 | RDEPENDS_${KERNEL_PACKAGE_NAME}-base_append_dra7xx = " goodix-fw" | ||
13 | |||
14 | # Install boot-monitor skern file into /boot dir of rootfs | ||
15 | RDEPENDS_${KERNEL_PACKAGE_NAME}-base_append_keystone = " boot-monitor" | ||
16 | |||
17 | # Install ti-sci-fw into /boot dir of rootfs | ||
18 | RDEPENDS_${KERNEL_PACKAGE_NAME}-base_append_k2g = " ti-sci-fw" | ||
19 | |||
20 | # Add run-time dependency for SerDes firmware to the rootfs | ||
21 | RDEPENDS_${KERNEL_PACKAGE_NAME}-base_append_keystone = " serdes-fw" | ||
22 | |||
23 | # Add run-time dependency for QMSS PDSP firmware to the rootfs | ||
24 | RDEPENDS_${KERNEL_PACKAGE_NAME}-base_append_keystone = " qmss-pdsp-fw" | ||
25 | |||
26 | # Add run-time dependency for NETCP PA firmware to the rootfs | ||
27 | RDEPENDS_${KERNEL_PACKAGE_NAME}-base_append_k2hk = " netcp-pa-fw" | ||
28 | RDEPENDS_${KERNEL_PACKAGE_NAME}-base_append_k2e = " netcp-pa-fw" | ||
29 | RDEPENDS_${KERNEL_PACKAGE_NAME}-base_append_k2l = " netcp-pa-fw" | ||
30 | |||
31 | # Add run-time dependency for PRU Ethernet firmware to the rootfs | ||
32 | RDEPENDS_${KERNEL_PACKAGE_NAME}-base_append_am57xx-evm = " prueth-fw prusw-fw pruhsr-fw pruprp-fw" | ||
33 | RDEPENDS_${KERNEL_PACKAGE_NAME}-base_append_am57xx-hs-evm = " prueth-fw prusw-fw pruhsr-fw pruprp-fw" | ||
34 | RDEPENDS_${KERNEL_PACKAGE_NAME}-base_append_ti43x = " prueth-fw pruhsr-fw pruprp-fw" | ||
35 | RDEPENDS_${KERNEL_PACKAGE_NAME}-base_append_ti33x = " prueth-fw pruhsr-fw pruprp-fw" | ||
36 | RDEPENDS_${KERNEL_PACKAGE_NAME}-base_append_am65xx = " prueth-fw-am65x" | ||
37 | RDEPENDS_${KERNEL_PACKAGE_NAME}-base_append_am65xx-evm = " prueth-fw-am65x-sr2" | ||
38 | |||
39 | # Add run-time dependency for Cadence MHDP firmware to the rootfs | ||
40 | RDEPENDS_${KERNEL_PACKAGE_NAME}-base_append_j7 = " cadence-mhdp-fw" | ||
diff --git a/recipes-kernel/linux/linux-ti-staging_5.4.bb b/recipes-kernel/linux/linux-ti-staging_5.4.bb index 2b4557d9..eaf40388 100644 --- a/recipes-kernel/linux/linux-ti-staging_5.4.bb +++ b/recipes-kernel/linux/linux-ti-staging_5.4.bb | |||
@@ -1,59 +1,20 @@ | |||
1 | SECTION = "kernel" | 1 | SECTION = "kernel" |
2 | DESCRIPTION = "Linux kernel for TI devices" | 2 | SUMMARY = "Linux kernel for TI devices" |
3 | LICENSE = "GPLv2" | 3 | LICENSE = "GPLv2" |
4 | LIC_FILES_CHKSUM = "file://COPYING;md5=bbea815ee2795b2f4230826c0c6b8814" | 4 | LIC_FILES_CHKSUM = "file://COPYING;md5=bbea815ee2795b2f4230826c0c6b8814" |
5 | 5 | ||
6 | inherit kernel | 6 | inherit kernel |
7 | 7 | ||
8 | DEFCONFIG_BUILDER = "${S}/ti_config_fragments/defconfig_builder.sh" | ||
8 | require recipes-kernel/linux/setup-defconfig.inc | 9 | require recipes-kernel/linux/setup-defconfig.inc |
9 | require recipes-kernel/linux/cmem.inc | 10 | require recipes-kernel/linux/cmem.inc |
10 | require recipes-kernel/linux/ti-uio.inc | 11 | require recipes-kernel/linux/ti-uio.inc |
11 | require recipes-kernel/linux/bundle-devicetree.inc | 12 | require recipes-kernel/linux/bundle-devicetree.inc |
13 | require recipes-kernel/linux/kernel-rdepends.inc | ||
12 | 14 | ||
13 | # Look in the generic major.minor directory for files | 15 | # Look in the generic major.minor directory for files |
14 | FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}-5.4:" | 16 | FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}-5.4:" |
15 | 17 | ||
16 | # Pull in the devicetree files into the rootfs | ||
17 | RDEPENDS_${KERNEL_PACKAGE_NAME}-base += "kernel-devicetree" | ||
18 | |||
19 | # Add run-time dependency for PM firmware to the rootfs | ||
20 | RDEPENDS_${KERNEL_PACKAGE_NAME}-base_append_ti33x = " amx3-cm3" | ||
21 | RDEPENDS_${KERNEL_PACKAGE_NAME}-base_append_ti43x = " amx3-cm3" | ||
22 | |||
23 | # Add run-time dependency for VPE VPDMA firmware to the rootfs | ||
24 | RDEPENDS_${KERNEL_PACKAGE_NAME}-base_append_dra7xx = " vpdma-fw" | ||
25 | |||
26 | # Add run-time dependency for Goodix firmware to the rootfs | ||
27 | RDEPENDS_${KERNEL_PACKAGE_NAME}-base_append_dra7xx = " goodix-fw" | ||
28 | |||
29 | # Install boot-monitor skern file into /boot dir of rootfs | ||
30 | RDEPENDS_${KERNEL_PACKAGE_NAME}-base_append_keystone = " boot-monitor" | ||
31 | |||
32 | # Install ti-sci-fw into /boot dir of rootfs | ||
33 | RDEPENDS_${KERNEL_PACKAGE_NAME}-base_append_k2g = " ti-sci-fw" | ||
34 | |||
35 | # Add run-time dependency for SerDes firmware to the rootfs | ||
36 | RDEPENDS_${KERNEL_PACKAGE_NAME}-base_append_keystone = " serdes-fw" | ||
37 | |||
38 | # Add run-time dependency for QMSS PDSP firmware to the rootfs | ||
39 | RDEPENDS_${KERNEL_PACKAGE_NAME}-base_append_keystone = " qmss-pdsp-fw" | ||
40 | |||
41 | # Add run-time dependency for NETCP PA firmware to the rootfs | ||
42 | RDEPENDS_${KERNEL_PACKAGE_NAME}-base_append_k2hk = " netcp-pa-fw" | ||
43 | RDEPENDS_${KERNEL_PACKAGE_NAME}-base_append_k2e = " netcp-pa-fw" | ||
44 | RDEPENDS_${KERNEL_PACKAGE_NAME}-base_append_k2l = " netcp-pa-fw" | ||
45 | |||
46 | # Add run-time dependency for PRU Ethernet firmware to the rootfs | ||
47 | RDEPENDS_${KERNEL_PACKAGE_NAME}-base_append_am57xx-evm = " prueth-fw prusw-fw pruhsr-fw pruprp-fw" | ||
48 | RDEPENDS_${KERNEL_PACKAGE_NAME}-base_append_am57xx-hs-evm = " prueth-fw prusw-fw pruhsr-fw pruprp-fw" | ||
49 | RDEPENDS_${KERNEL_PACKAGE_NAME}-base_append_ti43x = " prueth-fw pruhsr-fw pruprp-fw" | ||
50 | RDEPENDS_${KERNEL_PACKAGE_NAME}-base_append_ti33x = " prueth-fw pruhsr-fw pruprp-fw" | ||
51 | RDEPENDS_${KERNEL_PACKAGE_NAME}-base_append_am65xx = " prueth-fw-am65x" | ||
52 | RDEPENDS_${KERNEL_PACKAGE_NAME}-base_append_am65xx-evm = " prueth-fw-am65x-sr2" | ||
53 | |||
54 | # Add run-time dependency for Cadence MHDP firmware to the rootfs | ||
55 | RDEPENDS_${KERNEL_PACKAGE_NAME}-base_append_j7 = " cadence-mhdp-fw" | ||
56 | |||
57 | KERNEL_EXTRA_ARGS += "LOADADDR=${UBOOT_ENTRYPOINT}" | 18 | KERNEL_EXTRA_ARGS += "LOADADDR=${UBOOT_ENTRYPOINT}" |
58 | 19 | ||
59 | S = "${WORKDIR}/git" | 20 | S = "${WORKDIR}/git" |
diff --git a/recipes-kernel/linux/setup-defconfig.inc b/recipes-kernel/linux/setup-defconfig.inc index dcf2adae..850a1dd8 100644 --- a/recipes-kernel/linux/setup-defconfig.inc +++ b/recipes-kernel/linux/setup-defconfig.inc | |||
@@ -28,7 +28,7 @@ do_configure() { | |||
28 | config=`cat ${B}/.config | grep use-tisdk-config | cut -d= -f2` | 28 | config=`cat ${B}/.config | grep use-tisdk-config | cut -d= -f2` |
29 | if [ -n "$config" ] | 29 | if [ -n "$config" ] |
30 | then | 30 | then |
31 | ${S}/ti_config_fragments/defconfig_builder.sh -w ${S} -t $config | 31 | ${DEFCONFIG_BUILDER} -w ${S} -t $config |
32 | oe_runmake -C ${S} O=${B} "$config"_defconfig | 32 | oe_runmake -C ${S} O=${B} "$config"_defconfig |
33 | else | 33 | else |
34 | # First, check if pointing to a combined config with config fragments | 34 | # First, check if pointing to a combined config with config fragments |