summaryrefslogtreecommitdiffstats
path: root/recipes-ti
diff options
context:
space:
mode:
authorKoen Kooi <koen@dominion.thruhere.net>2012-01-31 16:34:00 +0100
committerKoen Kooi <koen@dominion.thruhere.net>2012-02-07 17:36:46 +0100
commitf244d42300e290fac43bedf875c199fa0e8ad2f5 (patch)
tree36f6ac554603ad9644b85679aed176403dc036c1 /recipes-ti
parent4a759de7bb1529bffbeea2c2a28eff076c29b6e5 (diff)
downloadmeta-ti-f244d42300e290fac43bedf875c199fa0e8ad2f5.tar.gz
gadget-init: adjust for kernel 3.2 based sysfs layout
Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
Diffstat (limited to 'recipes-ti')
-rw-r--r--recipes-ti/beagleboard/gadget-init.bb10
-rw-r--r--recipes-ti/beagleboard/gadget-init/99-hokey-pokey.rules2
-rwxr-xr-xrecipes-ti/beagleboard/gadget-init/g-ether-start-service.sh4
-rwxr-xr-xrecipes-ti/beagleboard/gadget-init/hokey-pokey.sh7
4 files changed, 7 insertions, 16 deletions
diff --git a/recipes-ti/beagleboard/gadget-init.bb b/recipes-ti/beagleboard/gadget-init.bb
index d016c099..150ff8eb 100644
--- a/recipes-ti/beagleboard/gadget-init.bb
+++ b/recipes-ti/beagleboard/gadget-init.bb
@@ -1,6 +1,6 @@
1DESCRIPTION = "Units to initialize usb gadgets" 1DESCRIPTION = "Units to initialize usb gadgets"
2 2
3PR = "r13" 3PR = "r16"
4 4
5LICENSE = "MIT" 5LICENSE = "MIT"
6LIC_FILES_CHKSUM = "file://${COREBASE}/LICENSE;md5=3f40d7994397109285ec7b81fdeb3b58" 6LIC_FILES_CHKSUM = "file://${COREBASE}/LICENSE;md5=3f40d7994397109285ec7b81fdeb3b58"
@@ -12,8 +12,6 @@ SRC_URI = "file://storage-gadget-init.service \
12 file://network-gadget-init.service \ 12 file://network-gadget-init.service \
13 file://udhcpd.service \ 13 file://udhcpd.service \
14 file://udhcpd.conf \ 14 file://udhcpd.conf \
15 file://99-hokey-pokey.rules \
16 file://hokey-pokey.sh \
17 file://bone-gmass-eject.rules \ 15 file://bone-gmass-eject.rules \
18 file://udhcpd.rules \ 16 file://udhcpd.rules \
19 file://g-storage-reinsert.sh \ 17 file://g-storage-reinsert.sh \
@@ -37,12 +35,14 @@ do_install() {
37 35
38 install -d ${D}${bindir} 36 install -d ${D}${bindir}
39 install -m 0755 ${WORKDIR}/*.sh ${D}${bindir} 37 install -m 0755 ${WORKDIR}/*.sh ${D}${bindir}
38
39 install -d ${D}${sysconfdir}/tmpfiles.d
40 echo "w /sys/class/pwm/ehrpwm.1:0/polarity - - - - 1" > ${D}${sysconfdir}/tmpfiles.d/lcd7.conf
40} 41}
41 42
42PACKAGES =+ "${PN}-storage ${PN}-network ${PN}-udhcpd" 43PACKAGES =+ "${PN}-storage ${PN}-network ${PN}-udhcpd"
43 44
44FILES_${PN} = "${sysconfdir}/udev/rules.d/99-hokey-pokey.rules \ 45FILES_${PN} = "${sysconfdir}/tmpfiles.d"
45 ${bindir}/hokey-pokey.sh \"
46 46
47FILES_${PN}-storage = "${base_libdir}/systemd/system/storage-gadget-init.service \ 47FILES_${PN}-storage = "${base_libdir}/systemd/system/storage-gadget-init.service \
48 ${base_libdir}/systemd/system/basic.target.wants/storage-gadget-init.service \ 48 ${base_libdir}/systemd/system/basic.target.wants/storage-gadget-init.service \
diff --git a/recipes-ti/beagleboard/gadget-init/99-hokey-pokey.rules b/recipes-ti/beagleboard/gadget-init/99-hokey-pokey.rules
deleted file mode 100644
index bb3c8d34..00000000
--- a/recipes-ti/beagleboard/gadget-init/99-hokey-pokey.rules
+++ /dev/null
@@ -1,2 +0,0 @@
1ACTION=="remove", DEVPATH=="/devices/platform/omap/ti81xx-usbss/musb-hdrc.1/usb1/1-1", RUN+="/usr/bin/hokey-pokey.sh"
2
diff --git a/recipes-ti/beagleboard/gadget-init/g-ether-start-service.sh b/recipes-ti/beagleboard/gadget-init/g-ether-start-service.sh
index 076a5fe8..6e73b155 100755
--- a/recipes-ti/beagleboard/gadget-init/g-ether-start-service.sh
+++ b/recipes-ti/beagleboard/gadget-init/g-ether-start-service.sh
@@ -1,7 +1,7 @@
1#!/bin/sh 1#!/bin/sh
2if [ -a /sys/devices/platform/omap/ti81xx-usbss/musb-hdrc.0/gadget/lun0/file ] 2if [ -a /sys/devices/platform/omap/musb-ti81xx/musb-hdrc.0/gadget/lun0/file ]
3then 3then
4 x=$(cat /sys/devices/platform/omap/ti81xx-usbss/musb-hdrc.0/gadget/lun0/file) 4 x=$(cat /sys/devices/platform/omap/musb-ti81xx/musb-hdrc.0/gadget/lun0/file)
5 if [ -z "$x" ] 5 if [ -z "$x" ]
6 then 6 then
7 /bin/systemctl stop storage-gadget-init.service 7 /bin/systemctl stop storage-gadget-init.service
diff --git a/recipes-ti/beagleboard/gadget-init/hokey-pokey.sh b/recipes-ti/beagleboard/gadget-init/hokey-pokey.sh
deleted file mode 100755
index 2139eb02..00000000
--- a/recipes-ti/beagleboard/gadget-init/hokey-pokey.sh
+++ /dev/null
@@ -1,7 +0,0 @@
1#!/bin/sh
2
3sleep 1
4echo F > /proc/driver/musb_hdrc.1
5sleep 1
6echo F > /proc/driver/musb_hdrc.1
7