diff options
author | Denys Dmytriyenko <denys@ti.com> | 2018-04-24 01:53:50 +0000 |
---|---|---|
committer | Denys Dmytriyenko <denys@ti.com> | 2018-04-24 16:00:50 -0400 |
commit | 268548b2c808afaa7bd9b7404b63f6036d7c5963 (patch) | |
tree | 9e47449560e1f85edd10ac71a5fc67254eca12c4 /recipes-ti | |
parent | 789979a559c2759e5073c444636e7e9d3bd4299b (diff) | |
download | meta-ti-268548b2c808afaa7bd9b7404b63f6036d7c5963.tar.gz |
multiprocmgr: don't hardcode "uapi" kernel location
This way keystone_remoteproc.h can also be found in sysroots, when available.
Otherwise it can fall back to using kernel sources directly.
Signed-off-by: Denys Dmytriyenko <denys@ti.com>
Diffstat (limited to 'recipes-ti')
-rw-r--r-- | recipes-ti/multiprocmgr/multiprocmgr/0001-mpmdlif.c-don-t-hardcode-kernel-s-uapi-location-keys.patch | 27 | ||||
-rw-r--r-- | recipes-ti/multiprocmgr/multiprocmgr_git.bb | 9 |
2 files changed, 33 insertions, 3 deletions
diff --git a/recipes-ti/multiprocmgr/multiprocmgr/0001-mpmdlif.c-don-t-hardcode-kernel-s-uapi-location-keys.patch b/recipes-ti/multiprocmgr/multiprocmgr/0001-mpmdlif.c-don-t-hardcode-kernel-s-uapi-location-keys.patch new file mode 100644 index 00000000..25deedcc --- /dev/null +++ b/recipes-ti/multiprocmgr/multiprocmgr/0001-mpmdlif.c-don-t-hardcode-kernel-s-uapi-location-keys.patch | |||
@@ -0,0 +1,27 @@ | |||
1 | From 17c307ff6e67af43f243366baa2ccc01f89cdddd Mon Sep 17 00:00:00 2001 | ||
2 | From: Denys Dmytriyenko <denys@ti.com> | ||
3 | Date: Mon, 23 Apr 2018 15:35:44 -0400 | ||
4 | Subject: [PATCH] mpmdlif.c: don't hardcode kernel's "uapi" location | ||
5 | keystone_remoteproc.h | ||
6 | |||
7 | Signed-off-by: Denys Dmytriyenko <denys@ti.com> | ||
8 | --- | ||
9 | src/daemon/mpmdlif.c | 2 +- | ||
10 | 1 file changed, 1 insertion(+), 1 deletion(-) | ||
11 | |||
12 | diff --git a/src/daemon/mpmdlif.c b/src/daemon/mpmdlif.c | ||
13 | index 0c31604..d287bbc 100644 | ||
14 | --- a/src/daemon/mpmdlif.c | ||
15 | +++ b/src/daemon/mpmdlif.c | ||
16 | @@ -47,7 +47,7 @@ | ||
17 | #include <stdint.h> | ||
18 | |||
19 | #define _LINUX_TYPES_H | ||
20 | -#include "uapi/linux/keystone_remoteproc.h" | ||
21 | +#include "linux/keystone_remoteproc.h" | ||
22 | #include "internal/rsc_types.h" | ||
23 | //#include <elf.h> | ||
24 | // #define LOADER_DEBUG | ||
25 | -- | ||
26 | 2.7.4 | ||
27 | |||
diff --git a/recipes-ti/multiprocmgr/multiprocmgr_git.bb b/recipes-ti/multiprocmgr/multiprocmgr_git.bb index 053a04e5..f37b97e3 100644 --- a/recipes-ti/multiprocmgr/multiprocmgr_git.bb +++ b/recipes-ti/multiprocmgr/multiprocmgr_git.bb | |||
@@ -3,15 +3,18 @@ SUMMARY = "Provides download, debug and other utilities for other cores in the S | |||
3 | 3 | ||
4 | include multiprocmgr.inc | 4 | include multiprocmgr.inc |
5 | 5 | ||
6 | SRC_URI_append = " file://mpmsrv-daemon.service" | 6 | SRC_URI += " \ |
7 | file://mpmsrv-daemon.service \ | ||
8 | file://0001-mpmdlif.c-don-t-hardcode-kernel-s-uapi-location-keys.patch \ | ||
9 | " | ||
7 | 10 | ||
8 | PR = "${INC_PR}.1" | 11 | PR = "${INC_PR}.2" |
9 | 12 | ||
10 | DEPENDS = "mpm-transport libdaemon virtual/kernel cmem" | 13 | DEPENDS = "mpm-transport libdaemon virtual/kernel cmem" |
11 | 14 | ||
12 | PACKAGE_ARCH = "${MACHINE_ARCH}" | 15 | PACKAGE_ARCH = "${MACHINE_ARCH}" |
13 | 16 | ||
14 | CC += "-I${STAGING_KERNEL_DIR}/include" | 17 | CC += "-I${STAGING_KERNEL_DIR}/include -I${STAGING_KERNEL_DIR}/include/uapi" |
15 | 18 | ||
16 | INITSCRIPT_NAME = "mpmsrv-daemon.sh" | 19 | INITSCRIPT_NAME = "mpmsrv-daemon.sh" |
17 | INITSCRIPT_PARAMS = "defaults 10" | 20 | INITSCRIPT_PARAMS = "defaults 10" |