summaryrefslogtreecommitdiffstats
path: root/recipes-ti
diff options
context:
space:
mode:
authorMrinmayee Hingolikar <mrinmayee@ti.com>2014-05-20 01:19:43 +0000
committerDenys Dmytriyenko <denys@ti.com>2014-05-21 15:37:46 -0400
commitd7f791b65448375151698e681c2ed13a1cd6b73e (patch)
tree6f42843b64fb255ca9822f7c357cffdddf3e1740 /recipes-ti
parente36f2c3b78b5abffb36f1e82cf3dfe3953b0abba (diff)
downloadmeta-ti-d7f791b65448375151698e681c2ed13a1cd6b73e.tar.gz
ipumm-fw: Add MM accelerator firmware recipe
* Based on recipes from meta-ti-glsdk and preserved authorship for Mrinmayee * Modified for upstreaming: * Combined the dra7xx-evm and omap5-evm versions into a shared recipe. This changes the recipe name to just ipumm-fw. Signed-off-by: Chase Maupin <Chase.Maupin@ti.com> Signed-off-by: Denys Dmytriyenko <denys@ti.com>
Diffstat (limited to 'recipes-ti')
-rw-r--r--recipes-ti/ipumm-fw/ipumm-fw_3.00.04.02.bb30
1 files changed, 30 insertions, 0 deletions
diff --git a/recipes-ti/ipumm-fw/ipumm-fw_3.00.04.02.bb b/recipes-ti/ipumm-fw/ipumm-fw_3.00.04.02.bb
new file mode 100644
index 00000000..c3017fed
--- /dev/null
+++ b/recipes-ti/ipumm-fw/ipumm-fw_3.00.04.02.bb
@@ -0,0 +1,30 @@
1DESCRIPTION = "Firmware for IPU "
2
3LICENSE = "TI-TSPA"
4LIC_FILES_CHKSUM_dra7xx-evm = "file://MMIP-${PV}-Manifest.doc;md5=64ca6f9d7e5243b8a4084eb918a543bc"
5LIC_FILES_CHKSUM_omap5-evm = "file://MMIP-${PV}-Manifest.doc;md5=39a593dd8fc2a9654c74f679ed329c45"
6
7COMPATIBLE_MACHINE = "omap-a15"
8PACKAGE_ARCH = "${MACHINE_ARCH}"
9
10SRC_URI = "http://downloads.ti.com/dsps/dsps_public_sw/glsdk/ipumm/3_00_04_02/exports/ipumm-${MACHINE}-3.00.04.02.tar.gz;protocol=http;name=${MACHINE}"
11
12# DRA7xx checksums
13SRC_URI[dra7xx-evm.md5sum] = "da04c03b0fd57901e8283afa80f81379"
14SRC_URI[dra7xx-evm.sha256sum] = "0b26fd13f9c318b52c18b9bff56862ef1f58a768b19285b87c035e65bc828ddc"
15
16# OMAP5 checksums
17SRC_URI[omap5-evm.md5sum] = "1572073ebd4f6d127c4e8cf47d270b6a"
18SRC_URI[omap5-evm.sha256sum] = "2fdb469f19e3c9984854f5bc82444fca4d7da869f5e645da22ec0d5beaa5cc65"
19
20S = "${WORKDIR}/ipumm-${MACHINE}-${PV}"
21
22TARGET_dra7xx-evm = "dra7-ipu2-fw.xem4"
23TARGET_omap5-evm = "ducati-m3-core0.xem3"
24
25do_install() {
26 mkdir -p ${D}${base_libdir}/firmware
27 cp ${S}/firmware/${TARGET} ${D}${base_libdir}/firmware/${TARGET}
28}
29
30FILES_${PN} += "${base_libdir}/firmware/${TARGET}"