diff options
author | Jacob Stiffler <j-stiffler@ti.com> | 2019-07-29 23:37:26 +0000 |
---|---|---|
committer | Denys Dmytriyenko <denys@ti.com> | 2019-07-31 19:28:16 +0000 |
commit | 5b1f2650e9e2150716b5258d355234bad9c7d736 (patch) | |
tree | 15e56639f6f61fa8a6f8b6c61c670cfe026e1716 /recipes-ti | |
parent | 3d2ff2e2079347e6ee3d820b77c46e0321bb305f (diff) | |
download | meta-ti-5b1f2650e9e2150716b5258d355234bad9c7d736.tar.gz |
ti-cgt-arm: consolidate into single file
Signed-off-by: Jacob Stiffler <j-stiffler@ti.com>
Signed-off-by: Denys Dmytriyenko <denys@ti.com>
Diffstat (limited to 'recipes-ti')
-rw-r--r-- | recipes-ti/devtools/ti-cgt-arm-native_18.12.1.bb | 38 | ||||
-rw-r--r-- | recipes-ti/devtools/ti-cgt-arm.inc | 36 |
2 files changed, 35 insertions, 39 deletions
diff --git a/recipes-ti/devtools/ti-cgt-arm-native_18.12.1.bb b/recipes-ti/devtools/ti-cgt-arm-native_18.12.1.bb index 7df9660c..5d724069 100644 --- a/recipes-ti/devtools/ti-cgt-arm-native_18.12.1.bb +++ b/recipes-ti/devtools/ti-cgt-arm-native_18.12.1.bb | |||
@@ -1,6 +1,38 @@ | |||
1 | include ti-cgt-arm.inc | 1 | SUMMARY = "TI ARM Code Generation Tools" |
2 | HOMEPAGE = "https://www-a.ti.com/downloads/sds_support/TICodegenerationTools/download.htm" | ||
3 | LICENSE = "(TI-TSPA & Thai-Open-Source-Software-Center) & BSD-3-Clause & BSL-1.0 & Hewlett-Packard & Patrick-Powell & AFL-3.0 & MIT & BSD-2-Clause & PD & BSD-4-Clause" | ||
2 | 4 | ||
3 | LIC_FILES_CHKSUM = "file://ti-cgt-arm_${PV}.LTS/README.txt;md5=ab7a61241e90fcd144a756d88294cf30" | 5 | LIC_FILES_CHKSUM = "file://ti-cgt-arm_${PV}.LTS/README.txt;md5=ab7a61241e90fcd144a756d88294cf30" |
4 | 6 | ||
5 | BINFILE_MD5 = "af2378cf8d5d6f200ef3329f5a065529" | 7 | inherit native |
6 | BINFILE_SHA256 = "d90ae2360cd5b22912715ae7898d99352da1b97fd655f9a55d0d19a2a46bab0e" | 8 | require recipes-ti/includes/ti-unpack.inc |
9 | require recipes-ti/includes/ti-staging.inc | ||
10 | require recipes-ti/includes/ti-paths.inc | ||
11 | |||
12 | S = "${WORKDIR}/ti-cgt-arm-${PV}" | ||
13 | |||
14 | PR = "r0" | ||
15 | |||
16 | SRC_URI = "http://software-dl.ti.com/codegen/esd/cgt_public_sw/TMS470/${PV}.LTS/${BINFILE};name=${BINFILE_NAME}" | ||
17 | |||
18 | BINFILE = "ti_cgt_tms470_${PV}.LTS_linux_installer_x86.bin" | ||
19 | TI_BIN_UNPK_ARGS = "--prefix ${S}" | ||
20 | TI_BIN_UNPK_CMDS = "" | ||
21 | |||
22 | do_install() { | ||
23 | install -d ${D}${M4_TOOLCHAIN_INSTALL_DIR_RECIPE} | ||
24 | cp -r ${S}/ti-cgt-arm*/. ${D}${M4_TOOLCHAIN_INSTALL_DIR_RECIPE} | ||
25 | } | ||
26 | |||
27 | SRC_URI[cgt_arm_installer.md5sum] = "af2378cf8d5d6f200ef3329f5a065529" | ||
28 | SRC_URI[cgt_arm_installer.sha256sum] = "d90ae2360cd5b22912715ae7898d99352da1b97fd655f9a55d0d19a2a46bab0e" | ||
29 | |||
30 | BINFILE_NAME = "cgt_arm_installer" | ||
31 | |||
32 | FILES_${PN} += "${M4_TOOLCHAIN_INSTALL_DIR_RECIPE}" | ||
33 | |||
34 | INHIBIT_PACKAGE_STRIP = "1" | ||
35 | INHIBIT_SYSROOT_STRIP = "1" | ||
36 | INHIBIT_PACKAGE_DEBUG_SPLIT = "1" | ||
37 | |||
38 | INSANE_SKIP_${PN} += "arch staticdev" | ||
diff --git a/recipes-ti/devtools/ti-cgt-arm.inc b/recipes-ti/devtools/ti-cgt-arm.inc deleted file mode 100644 index d2d768ce..00000000 --- a/recipes-ti/devtools/ti-cgt-arm.inc +++ /dev/null | |||
@@ -1,36 +0,0 @@ | |||
1 | SUMMARY = "TI ARM Code Generation Tools" | ||
2 | HOMEPAGE = "https://www-a.ti.com/downloads/sds_support/TICodegenerationTools/download.htm" | ||
3 | LICENSE = "(TI-TSPA & Thai-Open-Source-Software-Center) & BSD-3-Clause & BSL-1.0 & Hewlett-Packard & Patrick-Powell & AFL-3.0 & MIT & BSD-2-Clause & PD & BSD-4-Clause" | ||
4 | |||
5 | inherit native | ||
6 | require recipes-ti/includes/ti-unpack.inc | ||
7 | require recipes-ti/includes/ti-staging.inc | ||
8 | require recipes-ti/includes/ti-paths.inc | ||
9 | |||
10 | S = "${WORKDIR}/ti-cgt-arm-${PV}" | ||
11 | |||
12 | PR = "r0" | ||
13 | |||
14 | SRC_URI = "http://software-dl.ti.com/codegen/esd/cgt_public_sw/TMS470/${PV}.LTS/${BINFILE};name=${BINFILE_NAME}" | ||
15 | |||
16 | BINFILE = "ti_cgt_tms470_${PV}.LTS_linux_installer_x86.bin" | ||
17 | TI_BIN_UNPK_ARGS = "--prefix ${S}" | ||
18 | TI_BIN_UNPK_CMDS = "" | ||
19 | |||
20 | do_install() { | ||
21 | install -d ${D}${M4_TOOLCHAIN_INSTALL_DIR_RECIPE} | ||
22 | cp -r ${S}/ti-cgt-arm*/. ${D}${M4_TOOLCHAIN_INSTALL_DIR_RECIPE} | ||
23 | } | ||
24 | |||
25 | SRC_URI[cgt_arm_installer.md5sum] = "${BINFILE_MD5}" | ||
26 | SRC_URI[cgt_arm_installer.sha256sum] = "${BINFILE_SHA256}" | ||
27 | |||
28 | BINFILE_NAME = "cgt_arm_installer" | ||
29 | |||
30 | FILES_${PN} += "${M4_TOOLCHAIN_INSTALL_DIR_RECIPE}" | ||
31 | |||
32 | INHIBIT_PACKAGE_STRIP = "1" | ||
33 | INHIBIT_SYSROOT_STRIP = "1" | ||
34 | INHIBIT_PACKAGE_DEBUG_SPLIT = "1" | ||
35 | |||
36 | INSANE_SKIP_${PN} += "arch staticdev" | ||