summaryrefslogtreecommitdiffstats
path: root/recipes-ti
diff options
context:
space:
mode:
authorSam Nelson <sam.nelson@ti.com>2018-08-22 23:34:24 +0000
committerDenys Dmytriyenko <denys@ti.com>2018-08-24 20:08:41 +0000
commite57b50524062105fdc61ce0558a6db51a9488599 (patch)
tree99373a74b12d03dd7417af6c3acbf81152673a9e /recipes-ti
parent1fca60ef933fb8107cf5bd6f6f1a35b4e234f5a8 (diff)
downloadmeta-ti-e57b50524062105fdc61ce0558a6db51a9488599.tar.gz
ti-ipc: Update to new version 3.50
Add AM65XX platform support Signed-off-by: Sam Nelson <sam.nelson@ti.com> Signed-off-by: Denys Dmytriyenko <denys@ti.com>
Diffstat (limited to 'recipes-ti')
-rw-r--r--recipes-ti/ipc/ti-ipc-common.inc3
-rw-r--r--recipes-ti/ipc/ti-ipc-examples.inc2
-rw-r--r--recipes-ti/ipc/ti-ipc-rtos.inc16
-rw-r--r--recipes-ti/ipc/ti-ipc-rtos_git.bb8
-rw-r--r--recipes-ti/ipc/ti-ipc.inc6
5 files changed, 26 insertions, 9 deletions
diff --git a/recipes-ti/ipc/ti-ipc-common.inc b/recipes-ti/ipc/ti-ipc-common.inc
index 7f938428..6aea8e64 100644
--- a/recipes-ti/ipc/ti-ipc-common.inc
+++ b/recipes-ti/ipc/ti-ipc-common.inc
@@ -1,4 +1,4 @@
1PV = "3.47.02.00" 1PV = "3.50.01.00"
2INC_PR = "r0" 2INC_PR = "r0"
3 3
4PACKAGE_ARCH = "${MACHINE_ARCH}" 4PACKAGE_ARCH = "${MACHINE_ARCH}"
@@ -13,6 +13,7 @@ PLATFORM_k2g = "66AK2G"
13PLATFORM_omapl138 = "OMAPL138" 13PLATFORM_omapl138 = "OMAPL138"
14PLATFORM_c667x-evm = "C6678" 14PLATFORM_c667x-evm = "C6678"
15PLATFORM_c665x-evm = "C6678" 15PLATFORM_c665x-evm = "C6678"
16PLATFORM_am65xx-evm = "AM65XX"
16 17
17ALT_PLATFORM_k2hk = "TCI6636" 18ALT_PLATFORM_k2hk = "TCI6636"
18ALT_PLATFORM_am57xx-evm = "AM572X AM571X" 19ALT_PLATFORM_am57xx-evm = "AM572X AM571X"
diff --git a/recipes-ti/ipc/ti-ipc-examples.inc b/recipes-ti/ipc/ti-ipc-examples.inc
index cd2240cd..022b13f0 100644
--- a/recipes-ti/ipc/ti-ipc-examples.inc
+++ b/recipes-ti/ipc/ti-ipc-examples.inc
@@ -3,7 +3,7 @@ require ti-ipc-common.inc
3require ti-ipc-rtos.inc 3require ti-ipc-rtos.inc
4 4
5LICENSE = "BSD" 5LICENSE = "BSD"
6LIC_FILES_CHKSUM = "file://${S_ipc-examples}/src/makefile;beginline=1;endline=30;md5=fb83580b16bce88e8ed568a6005c8f02" 6LIC_FILES_CHKSUM = "file://${S_ipc-examples}/src/makefile;beginline=1;endline=30;md5=a52324bd5033bb49ea07bade1244ac9a"
7 7
8INSANE_SKIP_${PN} += "arch" 8INSANE_SKIP_${PN} += "arch"
9 9
diff --git a/recipes-ti/ipc/ti-ipc-rtos.inc b/recipes-ti/ipc/ti-ipc-rtos.inc
index 868743e6..13b19146 100644
--- a/recipes-ti/ipc/ti-ipc-rtos.inc
+++ b/recipes-ti/ipc/ti-ipc-rtos.inc
@@ -24,11 +24,11 @@ protocol=${TI_IPC_METADATA_GIT_PROTOCOL};\
24branch=${TI_IPC_METADATA_GIT_BRANCH};\ 24branch=${TI_IPC_METADATA_GIT_BRANCH};\
25name=${TI_IPC_METADATA_NAME}" 25name=${TI_IPC_METADATA_NAME}"
26 26
27# Corresponds to tag: 3.47.02.00 27# Corresponds to tag: 3.50.01.00
28SRCREV_ipc-metadata = "e8aff83111b8a0d64d7a77413b6f66d3106084d8" 28SRCREV_ipc-metadata = "19a8e70cf6ca4fe0984987e25d937c61a62c7658"
29 29
30# Corresponds to tag: 3.47.02.00 30# Corresponds to tag: 3.50.01.00
31SRCREV_ipc-examples = "351e9a6d94c68f7ff64b2c002ee6750242ece6d9" 31SRCREV_ipc-examples = "1975687076426b587be8d2530df56c24425ca53a"
32 32
33S_ipc-examples = "${WORKDIR}/git/ipc-examples" 33S_ipc-examples = "${WORKDIR}/git/ipc-examples"
34S_ipc-metadata = "${WORKDIR}/git/ipc-metadata" 34S_ipc-metadata = "${WORKDIR}/git/ipc-metadata"
@@ -50,6 +50,9 @@ DEPENDS_append_omapl138 = " ti-cgt6x-native \
50DEPENDS_append_c66x = " ti-cgt6x-native \ 50DEPENDS_append_c66x = " ti-cgt6x-native \
51" 51"
52 52
53DEPENDS_append_am65xx-evm = " ti-cgt-arm-native \
54 gcc-linaro-baremetal-aarch64-native"
55
53IPC_TARGETS = "" 56IPC_TARGETS = ""
54 57
55IPC_TARGETS_omap-a15 = "\ 58IPC_TARGETS_omap-a15 = "\
@@ -73,6 +76,11 @@ IPC_TARGETS_c66x = " \
73 ti.targets.elf.C66_big_endian="${STAGING_DIR_NATIVE}/usr/share/ti/cgt-c6x" \ 76 ti.targets.elf.C66_big_endian="${STAGING_DIR_NATIVE}/usr/share/ti/cgt-c6x" \
74" 77"
75 78
79IPC_TARGETS_am65xx-evm = "\
80 gnu.targets.arm.A53F="${GCC_LINARO_BAREMETAL_AARCH64_TOOLCHAIN}" \
81 ti.targets.arm.elf.R5F="${M4_TOOLCHAIN_INSTALL_DIR}" \
82"
83
76EXTRA_OEMAKE = "\ 84EXTRA_OEMAKE = "\
77 PLATFORM=${PLATFORM} \ 85 PLATFORM=${PLATFORM} \
78 XDC_INSTALL_DIR="${XDC_INSTALL_DIR}" \ 86 XDC_INSTALL_DIR="${XDC_INSTALL_DIR}" \
diff --git a/recipes-ti/ipc/ti-ipc-rtos_git.bb b/recipes-ti/ipc/ti-ipc-rtos_git.bb
index b292d677..c374bb1f 100644
--- a/recipes-ti/ipc/ti-ipc-rtos_git.bb
+++ b/recipes-ti/ipc/ti-ipc-rtos_git.bb
@@ -122,3 +122,11 @@ pkg_postinst_${PN}-fw_omapl138 () {
122pkg_postrm_${PN}-fw_omapl138 () { 122pkg_postrm_${PN}-fw_omapl138 () {
123 update-alternatives --remove rproc-dsp-fw ipc/ti_platforms_evmOMAPL138_DSP/messageq_single.xe674 123 update-alternatives --remove rproc-dsp-fw ipc/ti_platforms_evmOMAPL138_DSP/messageq_single.xe674
124} 124}
125
126pkg_postinst_${PN}-fw_am65xx-evm () {
127 update-alternatives --install /lib/firmware/am65x-mcu-r5f0-fw am65x-mcu-r5f0-fw ipc/ti_platforms_cortexR_AM65X/messageq_single.xer5f ${ALTERNATIVE_PRIORITY}
128}
129
130pkg_postrm_${PN}-fw_am65xx-evm () {
131 update-alternatives --remove am65x-mcu-r5f0-fw ipc/ti_platforms_cortexR_AM65X/messageq_single.xe674
132}
diff --git a/recipes-ti/ipc/ti-ipc.inc b/recipes-ti/ipc/ti-ipc.inc
index e8038a56..b10e242a 100644
--- a/recipes-ti/ipc/ti-ipc.inc
+++ b/recipes-ti/ipc/ti-ipc.inc
@@ -6,10 +6,10 @@ LIC_FILES_CHKSUM = "file://${S}/ipc-linux.mak;beginline=1;endline=30;md5=7b327f9
6 6
7TI_IPC_GIT_URI = "git://git.ti.com/ipc/ipcdev.git" 7TI_IPC_GIT_URI = "git://git.ti.com/ipc/ipcdev.git"
8TI_IPC_GIT_PROTOCOL = "git" 8TI_IPC_GIT_PROTOCOL = "git"
9TI_IPC_GIT_BRANCH = "3.47" 9TI_IPC_GIT_BRANCH = "3.50"
10 10
11#Corresponds to 3.47.02.00 11#Corresponds to 3.50.01.00C
12TI_IPC_SRCREV = "24c36385d096613af123d1e1696fb2fee652ef36" 12TI_IPC_SRCREV = "32294eb80e9889ba12d0c008b21acab4545713af"
13 13
14BRANCH = "${TI_IPC_GIT_BRANCH}" 14BRANCH = "${TI_IPC_GIT_BRANCH}"
15SRC_URI = "${TI_IPC_GIT_URI};protocol=${TI_IPC_GIT_PROTOCOL};branch=${BRANCH};name=ipcdev" 15SRC_URI = "${TI_IPC_GIT_URI};protocol=${TI_IPC_GIT_PROTOCOL};branch=${BRANCH};name=ipcdev"