diff options
author | Jacob Stiffler <j-stiffler@ti.com> | 2015-10-24 01:56:46 +0000 |
---|---|---|
committer | Denys Dmytriyenko <denys@ti.com> | 2015-10-28 16:05:57 -0400 |
commit | 6a022be98ffc62b8908b60fcf1f16300eb2a0f84 (patch) | |
tree | d11cd6d7ca4a96a8b46944c0f48b41564a64b166 /recipes-ti | |
parent | 51f0cdc888ad5725b08e5d623b39309029f85c3e (diff) | |
download | meta-ti-6a022be98ffc62b8908b60fcf1f16300eb2a0f84.tar.gz |
gcc-arm-none-eabi-native: Add GCC baremetal toolchain
Signed-off-by: Jacob Stiffler <j-stiffler@ti.com>
Signed-off-by: Denys Dmytriyenko <denys@ti.com>
Diffstat (limited to 'recipes-ti')
-rw-r--r-- | recipes-ti/devtools/gcc-arm-none-eabi-native_4.8.2014q3.bb | 21 | ||||
-rw-r--r-- | recipes-ti/includes/ti-paths.inc | 2 |
2 files changed, 23 insertions, 0 deletions
diff --git a/recipes-ti/devtools/gcc-arm-none-eabi-native_4.8.2014q3.bb b/recipes-ti/devtools/gcc-arm-none-eabi-native_4.8.2014q3.bb new file mode 100644 index 00000000..971ae489 --- /dev/null +++ b/recipes-ti/devtools/gcc-arm-none-eabi-native_4.8.2014q3.bb | |||
@@ -0,0 +1,21 @@ | |||
1 | DESCRIPTION = "Baremetal GCC for ARM" | ||
2 | LICENSE = "GPL-3.0-with-GCC-exception & GPLv3" | ||
3 | |||
4 | LIC_FILES_CHKSUM = "file://share/doc/gcc-arm-none-eabi/license.txt;md5=cba77c7fde3ed13e866b04a2f3d93918" | ||
5 | |||
6 | inherit native | ||
7 | require recipes-ti/includes/ti-paths.inc | ||
8 | |||
9 | SRC_URI = "https://launchpad.net/gcc-arm-embedded/4.8/4.8-2014-q3-update/+download/gcc-arm-none-eabi-4_8-2014q3-20140805-linux.tar.bz2;name=gcc-arm-none" | ||
10 | |||
11 | SRC_URI[gcc-arm-none.md5sum] = "acc8c8ff45f8801e2155934214309a87" | ||
12 | SRC_URI[gcc-arm-none.sha256sum] = "e33d7546de1e02844239c72b3ef5563f472fcd6b4637419d513770ae13f551c0" | ||
13 | |||
14 | S = "${WORKDIR}/gcc-arm-none-eabi-4_8-2014q3" | ||
15 | |||
16 | do_install() { | ||
17 | install -d ${D}${GCC_ARM_NONE_TOOLCHAIN_RECIPE} | ||
18 | cp -r ${S}/. ${D}${GCC_ARM_NONE_TOOLCHAIN_RECIPE} | ||
19 | } | ||
20 | |||
21 | FILES_${PN} = "${GCC_ARM_NONE_TOOLCHAIN_RECIPE}/*" | ||
diff --git a/recipes-ti/includes/ti-paths.inc b/recipes-ti/includes/ti-paths.inc index d4bbe9ec..88805916 100644 --- a/recipes-ti/includes/ti-paths.inc +++ b/recipes-ti/includes/ti-paths.inc | |||
@@ -47,6 +47,7 @@ export PDK_INSTALL_DIR_RECIPE = "${installdir}/ti-pdk-tree" | |||
47 | export OSAL_INSTALL_DIR_RECIPE = "${installdir}/ti-osal-tree" | 47 | export OSAL_INSTALL_DIR_RECIPE = "${installdir}/ti-osal-tree" |
48 | export M4_TOOLCHAIN_INSTALL_DIR_RECIPE = "${installdir}/ti-cgt-arm" | 48 | export M4_TOOLCHAIN_INSTALL_DIR_RECIPE = "${installdir}/ti-cgt-arm" |
49 | export CCSV6_INSTALL_DIR_RECIPE = "${installdir}/ccsv6" | 49 | export CCSV6_INSTALL_DIR_RECIPE = "${installdir}/ccsv6" |
50 | export GCC_ARM_NONE_TOOLCHAIN_RECIPE = "${installdir}/gcc-arm-none-eabi" | ||
50 | 51 | ||
51 | # This is where the tools will end up in sysroot | 52 | # This is where the tools will end up in sysroot |
52 | export BIOS_INSTALL_DIR = "${STAGING_DIR_TARGET}${BIOS_INSTALL_DIR_RECIPE}" | 53 | export BIOS_INSTALL_DIR = "${STAGING_DIR_TARGET}${BIOS_INSTALL_DIR_RECIPE}" |
@@ -84,6 +85,7 @@ export PDK_INSTALL_DIR = "${STAGING_DIR_TARGET}${PDK_INSTALL_DIR_RECIPE}" | |||
84 | export OSAL_INSTALL_DIR = "${STAGING_DIR_TARGET}${OSAL_INSTALL_DIR_RECIPE}" | 85 | export OSAL_INSTALL_DIR = "${STAGING_DIR_TARGET}${OSAL_INSTALL_DIR_RECIPE}" |
85 | export M4_TOOLCHAIN_INSTALL_DIR = "${STAGING_DIR_NATIVE}${M4_TOOLCHAIN_INSTALL_DIR_RECIPE}" | 86 | export M4_TOOLCHAIN_INSTALL_DIR = "${STAGING_DIR_NATIVE}${M4_TOOLCHAIN_INSTALL_DIR_RECIPE}" |
86 | export CCSV6_INSTALL_DIR = "${STAGING_DIR_NATIVE}${CCSV6_INSTALL_DIR_RECIPE}" | 87 | export CCSV6_INSTALL_DIR = "${STAGING_DIR_NATIVE}${CCSV6_INSTALL_DIR_RECIPE}" |
88 | export GCC_ARM_NONE_TOOLCHAIN = "${STAGING_DIR_NATIVE}${GCC_ARM_NONE_TOOLCHAIN_RECIPE}" | ||
87 | 89 | ||
88 | DSPSUFFIX_omapl137 = "x674" | 90 | DSPSUFFIX_omapl137 = "x674" |
89 | DSPSUFFIX_omapl138 = "x674" | 91 | DSPSUFFIX_omapl138 = "x674" |