summaryrefslogtreecommitdiffstats
path: root/recipes-ti
diff options
context:
space:
mode:
authorSam Nelson <sam.nelson@ti.com>2015-01-30 08:59:26 +0000
committerDenys Dmytriyenko <denys@ti.com>2015-02-02 15:15:30 -0500
commitcd303368294f9b31edb241ddc4487aa2034a5859 (patch)
tree2afa9c6f3a6724b2a0d9253195373dc178b425c4 /recipes-ti
parent02faeb98837ac068ff056f8480a5c8e86eb4041b (diff)
downloadmeta-ti-cd303368294f9b31edb241ddc4487aa2034a5859.tar.gz
udma: Add recipe for user space library for udma kernel driver
- Provides zero copy access from user-space to packet dma channels via udma kernel driver Signed-off-by: Sam Nelson <sam.nelson@ti.com> Signed-off-by: Denys Dmytriyenko <denys@ti.com>
Diffstat (limited to 'recipes-ti')
-rw-r--r--recipes-ti/udma/udma_git.bb28
1 files changed, 28 insertions, 0 deletions
diff --git a/recipes-ti/udma/udma_git.bb b/recipes-ti/udma/udma_git.bb
new file mode 100644
index 00000000..0374d37f
--- /dev/null
+++ b/recipes-ti/udma/udma_git.bb
@@ -0,0 +1,28 @@
1DESCRIPTION = "Provides zero copy access from user-space to packet dma channels via udma kernel driver"
2LICENSE = "BSD-3-Clause"
3
4COMPATIBLE_MACHINE = "keystone"
5LIC_FILES_CHKSUM = "file://include/udma.h;startline=1;endline=39;md5=ba3c7f91f970afe073b759ced61d0f27"
6
7BRANCH = "master"
8SRC_URI = "git://git.ti.com/keystone-linux/udma.git;protocol=git;branch=${BRANCH}"
9S = "${WORKDIR}/git"
10# Commit corresponds to UDMA.01.00.00.00
11SRCREV = "53d09fb0bc98c41c5eb43623097e363c497d6fd8"
12
13PACKAGES =+ "${PN}-test"
14
15FILES_${PN}-test = "${bindir}/udma_test"
16
17do_install_append() {
18 install -d ${D}${bindir}/
19 install -d ${D}${libdir}/
20 install -d ${D}${includedir}/
21 install -c -m 755 ${S}/udma_test ${D}${bindir}/
22 install -c -m 755 ${S}/libudma.a ${D}${libdir}/
23 install -c -m 755 ${S}/libudma.so ${D}${libdir}/libudma.so.1.0.0
24 cd ${D}${libdir}/
25 ln -sf libudma.so.1.0.0 libudma.so.1
26 ln -sf libudma.so.1.0.0 libudma.so
27 install -c -m 755 ${S}/include/* ${D}${includedir}/
28}