diff options
author | Jianzhong Xu <xuj@ti.com> | 2018-09-24 20:59:33 +0000 |
---|---|---|
committer | Denys Dmytriyenko <denys@ti.com> | 2018-09-24 16:34:45 +0000 |
commit | 6a854e93404a9b190ed7b80fd18bb5e849da47f5 (patch) | |
tree | 5287ec2d0e401825c658abb8f17d29c2448f1be0 /recipes-ti | |
parent | 103a0c10388ab7dbd5ce5181bc5bcbca6e118c23 (diff) | |
download | meta-ti-6a854e93404a9b190ed7b80fd18bb5e849da47f5.tar.gz |
swtools: common tools for xdc-based component build
Add SWTOOLS which is needed to build xdc-based processor libs such as
DSPLIB, MATHLIB, etc from source.
Signed-off-by: Jianzhong Xu <xuj@ti.com>
Signed-off-by: Jacob Stiffler <j-stiffler@ti.com>
Signed-off-by: Denys Dmytriyenko <denys@ti.com>
Diffstat (limited to 'recipes-ti')
-rw-r--r-- | recipes-ti/includes/ti-paths.inc | 2 | ||||
-rw-r--r-- | recipes-ti/swtools/swtools_git.bb | 44 |
2 files changed, 46 insertions, 0 deletions
diff --git a/recipes-ti/includes/ti-paths.inc b/recipes-ti/includes/ti-paths.inc index a401264a..f797a2d2 100644 --- a/recipes-ti/includes/ti-paths.inc +++ b/recipes-ti/includes/ti-paths.inc | |||
@@ -39,6 +39,7 @@ export OSAL_INSTALL_DIR_RECIPE = "${installdir}/ti-osal-tree" | |||
39 | export RTFS_INSTALL_DIR_RECIPE = "${installdir}/ti-rtfs-tree" | 39 | export RTFS_INSTALL_DIR_RECIPE = "${installdir}/ti-rtfs-tree" |
40 | export SYSBIOS_INSTALL_DIR_RECIPE = "${installdir}/ti-sysbios-tree" | 40 | export SYSBIOS_INSTALL_DIR_RECIPE = "${installdir}/ti-sysbios-tree" |
41 | export SYSLINK_INSTALL_DIR_RECIPE = "${installdir}/ti-syslink-tree" | 41 | export SYSLINK_INSTALL_DIR_RECIPE = "${installdir}/ti-syslink-tree" |
42 | export SWTOOLS_INSTALL_DIR_RECIPE = "${installdir}/ti-swtools-tree" | ||
42 | export UIA_INSTALL_DIR_RECIPE = "${installdir}/ti-uia-tree" | 43 | export UIA_INSTALL_DIR_RECIPE = "${installdir}/ti-uia-tree" |
43 | export VICPLIB_INSTALL_DIR_RECIPE = "${installdir}/ti-vicplib-tree" | 44 | export VICPLIB_INSTALL_DIR_RECIPE = "${installdir}/ti-vicplib-tree" |
44 | export XDAIS_INSTALL_DIR_RECIPE = "${installdir}/ti-xdais-tree" | 45 | export XDAIS_INSTALL_DIR_RECIPE = "${installdir}/ti-xdais-tree" |
@@ -97,6 +98,7 @@ export OSAL_INSTALL_DIR = "${STAGING_DIR_TARGET}${OSAL_INSTALL_DIR_RECIPE} | |||
97 | export M4_TOOLCHAIN_INSTALL_DIR = "${STAGING_DIR_NATIVE}${M4_TOOLCHAIN_INSTALL_DIR_RECIPE}" | 98 | export M4_TOOLCHAIN_INSTALL_DIR = "${STAGING_DIR_NATIVE}${M4_TOOLCHAIN_INSTALL_DIR_RECIPE}" |
98 | export GCC_ARM_NONE_TOOLCHAIN = "${STAGING_DIR_NATIVE}${GCC_ARM_NONE_TOOLCHAIN_RECIPE}" | 99 | export GCC_ARM_NONE_TOOLCHAIN = "${STAGING_DIR_NATIVE}${GCC_ARM_NONE_TOOLCHAIN_RECIPE}" |
99 | export TI_CGT_PRU_INSTALL_DIR = "${STAGING_DIR_NATIVE}${TI_CGT_PRU_INSTALL_DIR_RECIPE}" | 100 | export TI_CGT_PRU_INSTALL_DIR = "${STAGING_DIR_NATIVE}${TI_CGT_PRU_INSTALL_DIR_RECIPE}" |
101 | export SWTOOLS_INSTALL_DIR = "${STAGING_DIR_TARGET}${SWTOOLS_INSTALL_DIR_RECIPE}" | ||
100 | export DSPLIB_C66_INSTALL_DIR = "${STAGING_DIR_TARGET}${DSPLIB_C66_INSTALL_DIR_RECIPE}" | 102 | export DSPLIB_C66_INSTALL_DIR = "${STAGING_DIR_TARGET}${DSPLIB_C66_INSTALL_DIR_RECIPE}" |
101 | export MATHLIB_C66_INSTALL_DIR = "${STAGING_DIR_TARGET}${MATHLIB_C66_INSTALL_DIR_RECIPE}" | 103 | export MATHLIB_C66_INSTALL_DIR = "${STAGING_DIR_TARGET}${MATHLIB_C66_INSTALL_DIR_RECIPE}" |
102 | export IMGLIB_C66_INSTALL_DIR = "${STAGING_DIR_TARGET}${IMGLIB_C66_INSTALL_DIR_RECIPE}" | 104 | export IMGLIB_C66_INSTALL_DIR = "${STAGING_DIR_TARGET}${IMGLIB_C66_INSTALL_DIR_RECIPE}" |
diff --git a/recipes-ti/swtools/swtools_git.bb b/recipes-ti/swtools/swtools_git.bb new file mode 100644 index 00000000..425a0690 --- /dev/null +++ b/recipes-ti/swtools/swtools_git.bb | |||
@@ -0,0 +1,44 @@ | |||
1 | SUMMARY = "TI Software Tools" | ||
2 | HOMEPAGE = "https://git.ti.com/ep-processor-libraries/swtools" | ||
3 | SECTION = "devel" | ||
4 | LICENSE = "BSD" | ||
5 | LIC_FILES_CHKSUM = "file://ti/mas/swtools/copyright.txt;md5=b1f52a1435051fdb18f8885b0384147d" | ||
6 | |||
7 | require ../includes/ti-paths.inc | ||
8 | |||
9 | DEPENDS = "ti-cgt6x-native \ | ||
10 | ti-sysbios \ | ||
11 | ti-xdctools-native" | ||
12 | |||
13 | PV = "5_0_8" | ||
14 | PR = "r0" | ||
15 | S = "${WORKDIR}/git" | ||
16 | BRANCH = "master" | ||
17 | SRC_URI = "git://git.ti.com/ep-processor-libraries/swtools.git;protocol=git;branch=${BRANCH}" | ||
18 | SRCREV = "881267836907de650edadc56b8e57ab45428021d" | ||
19 | |||
20 | export C64PCODEGENTOOL = "${CGTOOLS_INSTALL_DIR}" | ||
21 | export C674CODEGENTOOL = "${CGTOOLS_INSTALL_DIR}" | ||
22 | export C66CODEGENTOOL = "${CGTOOLS_INSTALL_DIR}" | ||
23 | |||
24 | PATH_append = ":${XDC_INSTALL_DIR}" | ||
25 | |||
26 | XDCPATH .= "${XDCCGROOT}/include;${XDC_INSTALL_DIR}/packages;${SYSBIOS_INSTALL_DIR}/packages;" | ||
27 | |||
28 | export XDCPATH | ||
29 | |||
30 | do_compile() { | ||
31 | cd ${S}/ti/mas/swtools | ||
32 | xdc | ||
33 | } | ||
34 | |||
35 | do_install() { | ||
36 | CP_ARGS="-Prf --preserve=mode,timestamps --no-preserve=ownership" | ||
37 | install -d ${D}${SWTOOLS_INSTALL_DIR_RECIPE} | ||
38 | cp -pPrf ${S}/* ${D}${SWTOOLS_INSTALL_DIR_RECIPE} | ||
39 | } | ||
40 | |||
41 | FILES_${PN}-dev += "${SWTOOLS_INSTALL_DIR_RECIPE}" | ||
42 | |||
43 | INSANE_SKIP_${PN}-dev = "arch staticdev" | ||
44 | ALLOW_EMPTY_${PN} = "1" | ||