diff options
author | Mahesh Radhakrishnan <m-radhakrishnan2@ti.com> | 2017-09-19 02:27:57 +0000 |
---|---|---|
committer | Denys Dmytriyenko <denys@ti.com> | 2017-10-02 16:18:31 -0400 |
commit | 237669570640fda49a9c3a1565437e402275d99d (patch) | |
tree | b9217a27b8943fc56347927abddea847a4b4256c /recipes-ti | |
parent | 511b167f6683b76ea8f3853e3b8ea0199b0fa25d (diff) | |
download | meta-ti-237669570640fda49a9c3a1565437e402275d99d.tar.gz |
ti-ndk: Adding recipe for ti-ndk
Recipe for TI RTOS Networking development kit
Signed-off-by: Mahesh Radhakrishnan <m-radhakrishnan2@ti.com>
Signed-off-by: Denys Dmytriyenko <denys@ti.com>
Diffstat (limited to 'recipes-ti')
-rw-r--r-- | recipes-ti/ndk/ti-ndk.inc | 21 | ||||
-rw-r--r-- | recipes-ti/ndk/ti-ndk_2.25.01.11.bb | 13 |
2 files changed, 34 insertions, 0 deletions
diff --git a/recipes-ti/ndk/ti-ndk.inc b/recipes-ti/ndk/ti-ndk.inc new file mode 100644 index 00000000..09d9ea0c --- /dev/null +++ b/recipes-ti/ndk/ti-ndk.inc | |||
@@ -0,0 +1,21 @@ | |||
1 | SUMMARY = "TI RTOS_Networking" | ||
2 | HOMEPAGE = "http://software-dl.ti.com/dsps/dsps_public_sw/sdo_sb/targetcontent/ndk/index.html" | ||
3 | SECTION = "devel" | ||
4 | LICENSE = "BSD" | ||
5 | |||
6 | require recipes-ti/includes/ti-paths.inc | ||
7 | |||
8 | S = "${WORKDIR}/ndk_${PV}" | ||
9 | |||
10 | SRC_URI = "http://software-dl.ti.com/dsps/dsps_public_sw/sdo_sb/targetcontent/ndk/${PV}/exports/ndk_${PV}.zip;name=ndkzip" | ||
11 | |||
12 | do_install() { | ||
13 | CP_ARGS="-Prf --preserve=mode,timestamps --no-preserve=ownership" | ||
14 | install -d ${D}${NDK_INSTALL_DIR_RECIPE} | ||
15 | cp ${CP_ARGS} ${S}/* ${D}${NDK_INSTALL_DIR_RECIPE} | ||
16 | } | ||
17 | |||
18 | ALLOW_EMPTY_${PN} = "1" | ||
19 | FILES_${PN}-dev += "${NDK_INSTALL_DIR_RECIPE}" | ||
20 | |||
21 | INSANE_SKIP_${PN}-dev = "arch ldflags staticdev" | ||
diff --git a/recipes-ti/ndk/ti-ndk_2.25.01.11.bb b/recipes-ti/ndk/ti-ndk_2.25.01.11.bb new file mode 100644 index 00000000..d5d926b6 --- /dev/null +++ b/recipes-ti/ndk/ti-ndk_2.25.01.11.bb | |||
@@ -0,0 +1,13 @@ | |||
1 | require ti-ndk.inc | ||
2 | |||
3 | PV = "2_25_01_11" | ||
4 | PR = "r0" | ||
5 | |||
6 | LIC_FILES_CHKSUM = "file://ndk_${PV}_manifest.html;md5=80a8d9b76cf700929d3f5b6df09052d6" | ||
7 | |||
8 | SRC_URI[ndkzip.md5sum] = "e42bfcc8c3a6d183d60f26ec01ccc79b" | ||
9 | SRC_URI[ndkzip.sha256sum] = "a15bc9b570dc0628dd8b8c3665037a162610a6f86c5f17ebb6a329d3db60f071" | ||
10 | |||
11 | INHIBIT_PACKAGE_STRIP = "1" | ||
12 | INHIBIT_PACKAGE_DEBUG_SPLIT = "1" | ||
13 | INHIBIT_SYSROOT_STRIP = "1" | ||