diff options
author | Jacob Stiffler <j-stiffler@ti.com> | 2015-07-01 21:19:54 +0000 |
---|---|---|
committer | Denys Dmytriyenko <denys@ti.com> | 2015-07-02 19:12:05 -0400 |
commit | 1dd7db9681ca78aada641339cae88602ff333a2a (patch) | |
tree | 49502eec155d876f147a8cbc19d0d28dbdb2e70f /recipes-ti | |
parent | 99a12978abca870406b12aef4f36b05f2b38fcd5 (diff) | |
download | meta-ti-1dd7db9681ca78aada641339cae88602ff333a2a.tar.gz |
ti-softhsmv2: Stop recipe from using headers from host build machine.
* Without the "--with-zlib" configure option, the zlib header will be
obtained from the build machines "/usr/include" directory if the
header exists there.
* From ${S}/m4/acx_zlib.m4:
AC_DEFUN([ACX_ZLIB],[
AC_ARG_WITH(zlib,
AC_HELP_STRING([--with-zlib=PATH],[Specify prefix of path of zlib]),
[
ZLIB_PATH="$withval"
],
[
ZLIB_PATH="/usr"
])
AC_MSG_CHECKING(what are the zlib includes)
ZLIB_INCLUDES="-I$ZLIB_PATH/include"
...
* Therefore add configure option to point to staging sysroot for zlib
header and add dependency on zlib.
Signed-off-by: Jacob Stiffler <j-stiffler@ti.com>
Signed-off-by: Denys Dmytriyenko <denys@ti.com>
Diffstat (limited to 'recipes-ti')
-rw-r--r-- | recipes-ti/ti-softhsmv2/ti-softhsmv2_git.bb | 5 |
1 files changed, 4 insertions, 1 deletions
diff --git a/recipes-ti/ti-softhsmv2/ti-softhsmv2_git.bb b/recipes-ti/ti-softhsmv2/ti-softhsmv2_git.bb index 518508c3..329fbaa6 100644 --- a/recipes-ti/ti-softhsmv2/ti-softhsmv2_git.bb +++ b/recipes-ti/ti-softhsmv2/ti-softhsmv2_git.bb | |||
@@ -7,7 +7,7 @@ mntdir = "/mnt" | |||
7 | 7 | ||
8 | inherit autotools pkgconfig | 8 | inherit autotools pkgconfig |
9 | 9 | ||
10 | DEPENDS = "openssl libdaemon" | 10 | DEPENDS = "openssl libdaemon zlib" |
11 | COMPATIBLE_MACHINE = "(tci6614-evm|keystone)" | 11 | COMPATIBLE_MACHINE = "(tci6614-evm|keystone)" |
12 | 12 | ||
13 | BRANCH="master" | 13 | BRANCH="master" |
@@ -15,12 +15,15 @@ SRC_URI = "git://git.ti.com/keystone-linux/ti-softhsmv2.git;protocol=git;branch= | |||
15 | #Following commit corresponds to tag DEV.SOFTHSM-01.03.00.01 | 15 | #Following commit corresponds to tag DEV.SOFTHSM-01.03.00.01 |
16 | SRCREV = "c79d93ac2a326567a7245dda1b903ef340b5650c" | 16 | SRCREV = "c79d93ac2a326567a7245dda1b903ef340b5650c" |
17 | PV = "1.3.0.1" | 17 | PV = "1.3.0.1" |
18 | PR = "r1" | ||
18 | 19 | ||
19 | S = "${WORKDIR}/git" | 20 | S = "${WORKDIR}/git" |
20 | 21 | ||
21 | CFLAGS += " -mno-unaligned-access" | 22 | CFLAGS += " -mno-unaligned-access" |
22 | CPPFLAGS += " -mno-unaligned-access" | 23 | CPPFLAGS += " -mno-unaligned-access" |
23 | 24 | ||
25 | EXTRA_OECONF += "--with-zlib=${STAGING_DIR_HOST}/usr" | ||
26 | |||
24 | INITSCRIPT_NAME = "softhsm-daemon.sh" | 27 | INITSCRIPT_NAME = "softhsm-daemon.sh" |
25 | INITSCRIPT_PARAMS = "defaults 10" | 28 | INITSCRIPT_PARAMS = "defaults 10" |
26 | 29 | ||