summaryrefslogtreecommitdiffstats
path: root/recipes-ti
diff options
context:
space:
mode:
authorSam Nelson <sam.nelson@ti.com>2017-02-09 03:27:59 +0000
committerDenys Dmytriyenko <denys@ti.com>2017-02-09 21:09:07 -0500
commit952a788d17e08031848d9cea07f689c4a14b3a8a (patch)
tree4ca2fd667447ceb9adbff70554c1e7e1be72dad7 /recipes-ti
parent880ca7f51c7d40a1fed7f79ad8b39f0b597f4c81 (diff)
downloadmeta-ti-952a788d17e08031848d9cea07f689c4a14b3a8a.tar.gz
multiprocmgr-test: Add test c66x images, sources and scripts to package
multiprocmgr-test installs source files, host binaries and associated scripts (ti/examples/mpm/test) multiprocmgr-rtos-test installs the C66x test images in the same directory structure. Other updates include - Use of oe_runmake instead of make - Added runtime dependency of multiprocmgr-rtos-test & bash Signed-off-by: Sam Nelson <sam.nelson@ti.com> Signed-off-by: Denys Dmytriyenko <denys@ti.com>
Diffstat (limited to 'recipes-ti')
-rw-r--r--recipes-ti/multiprocmgr/multiprocmgr-rtos_git.bb24
-rw-r--r--recipes-ti/multiprocmgr/multiprocmgr-test_git.bb21
2 files changed, 35 insertions, 10 deletions
diff --git a/recipes-ti/multiprocmgr/multiprocmgr-rtos_git.bb b/recipes-ti/multiprocmgr/multiprocmgr-rtos_git.bb
index 061790b2..c88f0d7f 100644
--- a/recipes-ti/multiprocmgr/multiprocmgr-rtos_git.bb
+++ b/recipes-ti/multiprocmgr/multiprocmgr-rtos_git.bb
@@ -6,22 +6,36 @@ require recipes-ti/multiprocmgr/multiprocmgr.inc
6 6
7DEPENDS = "ti-cgt6x-native" 7DEPENDS = "ti-cgt6x-native"
8 8
9PR = "${INC_PR}.0" 9PR = "${INC_PR}.1"
10 10
11export LOCAL_SYSROOT="${STAGING_DIR_TARGET}" 11PACKAGES =+ "${PN}-test"
12export C6X_GEN_INSTALL_PATH="${STAGING_DIR_NATIVE}/usr/share/ti/cgt-c6x" 12FILES_${PN}-test = "${datadir}/ti/examples/mpm/test/filetestdemo/c66x/demo_loopback/build/bin/*.out \
13 ${datadir}/ti/examples/mpm/test/sync_test/c66x/bin/*.out"
14
15EXTRA_OEMAKE = "LOCAL_SYSROOT="${STAGING_DIR_TARGET}" \
16 C6X_GEN_INSTALL_PATH="${STAGING_DIR_NATIVE}/usr/share/ti/cgt-c6x" \
17 "
13 18
14do_compile() { 19do_compile() {
15 make c66x 20 oe_runmake c66x
16 make test_c66x 21 oe_runmake test_c66x
17} 22}
18 23
19do_install() { 24do_install() {
20 install -d ${D}${MPM_INSTALL_DIR_RECIPE} 25 install -d ${D}${MPM_INSTALL_DIR_RECIPE}
21 cp -pPrf ${S}/* ${D}${MPM_INSTALL_DIR_RECIPE} 26 cp -pPrf ${S}/* ${D}${MPM_INSTALL_DIR_RECIPE}
27
28 # Copy C66x binaries
29 install -d ${D}${datadir}/ti/examples/mpm/test/filetestdemo/c66x/demo_loopback/build/bin
30 cp ${S}/test/filetestdemo/c66x/demo_loopback/build/bin/*.out \
31 ${D}${datadir}/ti/examples/mpm/test/filetestdemo/c66x/demo_loopback/build/bin/
32 install -d ${D}${datadir}/ti/examples/mpm/test/sync_test/c66x/bin
33 cp ${S}/test/sync_test/c66x/bin/*.out \
34 ${D}${datadir}/ti/examples/mpm/test/sync_test/c66x/bin/
22} 35}
23 36
24FILES_${PN}-dev += "${MPM_INSTALL_DIR_RECIPE}" 37FILES_${PN}-dev += "${MPM_INSTALL_DIR_RECIPE}"
25INSANE_SKIP_${PN}-dev = "arch" 38INSANE_SKIP_${PN}-dev = "arch"
39INSANE_SKIP_${PN}-test = "arch"
26 40
27ALLOW_EMPTY_${PN} = "1" 41ALLOW_EMPTY_${PN} = "1"
diff --git a/recipes-ti/multiprocmgr/multiprocmgr-test_git.bb b/recipes-ti/multiprocmgr/multiprocmgr-test_git.bb
index 7ec8796e..f01d6513 100644
--- a/recipes-ti/multiprocmgr/multiprocmgr-test_git.bb
+++ b/recipes-ti/multiprocmgr/multiprocmgr-test_git.bb
@@ -2,22 +2,33 @@ DESCRIPTION = "TI Multiproc Manager test code"
2 2
3include multiprocmgr.inc 3include multiprocmgr.inc
4 4
5PR = "${INC_PR}.1" 5PR = "${INC_PR}.2"
6 6
7DEPENDS = "multiprocmgr cmem" 7DEPENDS = "multiprocmgr cmem"
8RDEPENDS_${PN} = "multiprocmgr mpm-transport cmem" 8RDEPENDS_${PN} = "multiprocmgr mpm-transport cmem"
9RDEPENDS_${PN} += "multiprocmgr-rtos-test bash"
9 10
10CC += "-I${STAGING_KERNEL_DIR}/include" 11CC += "-I${STAGING_KERNEL_DIR}/include"
11 12
12# Assuming the multiprocmgr kernel API is safe 13# Assuming the multiprocmgr kernel API is safe
13CC[vardepsexclude] = "STAGING_KERNEL_DIR" 14CC[vardepsexclude] = "STAGING_KERNEL_DIR"
14 15
16FILES_${PN} += "\
17 ${datadir}/ti/examples/mpm \
18"
19
20FILES_${PN}-dbg += "\
21 ${datadir}/ti/examples/mpm/*/.debug \
22"
23
15do_compile() { 24do_compile() {
16 make -C ${S} test 25 oe_runmake -C ${S} test
17} 26}
18 27
19do_install() { 28do_install() {
20 install -d ${D}${bindir}/ 29 # Copy Sources and binary
21 install -c -m 755 ${S}/test/filetestdemo/host/bin/demo_filetest ${D}${bindir}/mpm_demo_filetest 30 install -d ${D}${datadir}/ti/examples/mpm/src
22 install -c -m 755 ${S}/test/sync_test/host/bin/sync_test ${D}${bindir}/mpm_sync_test 31 cp -r ${S}/src/mailbox ${D}${datadir}/ti/examples/mpm/src
32 cp -r ${S}/src/sync ${D}${datadir}/ti/examples/mpm/src
33 cp -r ${S}/test ${D}${datadir}/ti/examples/mpm
23} 34}