summaryrefslogtreecommitdiffstats
path: root/recipes-ti
diff options
context:
space:
mode:
authorSam Nelson <sam.nelson@ti.com>2015-04-13 23:52:53 +0000
committerDenys Dmytriyenko <denys@ti.com>2015-04-22 12:03:53 -0400
commitef3632215004f4697c46b166c475cc66afabb257 (patch)
tree29ae122255acd49a3d8a88d7f23055793b2c627d /recipes-ti
parent2c19121bb5166743d82cd4c46746b596a4a4340c (diff)
downloadmeta-ti-ef3632215004f4697c46b166c475cc66afabb257.tar.gz
ipc-transport-qmss: Add recipe for ipc qmss transport and test code
- Provides ipc transport layer using qmss module - Supports k2h, k2k, k2e, k2l devices Signed-off-by: Sam Nelson <sam.nelson@ti.com> Signed-off-by: Denys Dmytriyenko <denys@ti.com>
Diffstat (limited to 'recipes-ti')
-rw-r--r--recipes-ti/ipc/ipc-transport-qmss-test_git.bb31
-rw-r--r--recipes-ti/ipc/ipc-transport-qmss.inc16
-rw-r--r--recipes-ti/ipc/ipc-transport-qmss_git.bb14
3 files changed, 61 insertions, 0 deletions
diff --git a/recipes-ti/ipc/ipc-transport-qmss-test_git.bb b/recipes-ti/ipc/ipc-transport-qmss-test_git.bb
new file mode 100644
index 00000000..34d37086
--- /dev/null
+++ b/recipes-ti/ipc/ipc-transport-qmss-test_git.bb
@@ -0,0 +1,31 @@
1include ipc-transport-qmss.inc
2
3DEPENDS = "ipc-transport-qmss ti-ipc"
4
5#FILES_${PN}-test = "${bindir}/multiProcessTest_*.out"
6
7CHOICELIST = "yes no"
8
9DEVICELIST = "k2h k2k k2e k2l"
10
11do_compile () {
12# Now build the test code
13 for device in ${DEVICELIST}
14 do
15 for choice in ${CHOICELIST}
16 do
17 oe_runmake tests \
18 IPC_DEVKIT_INSTALL_PATH=${STAGING_INCDIR} \
19 USEDYNAMIC_LIB="$choice" DEVICE="$device"
20 done
21 done
22}
23
24do_install () {
25 for device in ${DEVICELIST}
26 do
27 oe_runmake installbin \
28 INSTALL_BIN_BASE_DIR=${D}${bindir} DEVICE="$device"
29 done
30
31}
diff --git a/recipes-ti/ipc/ipc-transport-qmss.inc b/recipes-ti/ipc/ipc-transport-qmss.inc
new file mode 100644
index 00000000..35c2111b
--- /dev/null
+++ b/recipes-ti/ipc/ipc-transport-qmss.inc
@@ -0,0 +1,16 @@
1DESCRIPTION = "TI QMSS-Based IPC MessageQ Transport"
2LICENSE = "BSD-3-Clause"
3
4LIC_FILES_CHKSUM = "file://COPYING.txt;md5=27bb0deb260c60120a8d7b91da7c3b02"
5
6BRANCH="master"
7SRC_URI = "git://git.ti.com/keystone-linux/ipc-transport.git;protocol=git;branch=${BRANCH}"
8# Below commit ID corresponds to DEV.IPC-TRANSPORT.01.00.00.00
9SRCREV = "b3077467126c84b5d583dc29e13ab221064b687b"
10PV = "01.00.00.00"
11
12COMPATIBLE_MACHINE = "keystone"
13
14S = "${WORKDIR}/git/linux/qmss"
15
16EXTRA_OEMAKE += "PDK_INSTALL_PATH=${STAGING_INCDIR} TRANS_QMSS_SRC_DIR=${S}"
diff --git a/recipes-ti/ipc/ipc-transport-qmss_git.bb b/recipes-ti/ipc/ipc-transport-qmss_git.bb
new file mode 100644
index 00000000..cb77a12a
--- /dev/null
+++ b/recipes-ti/ipc/ipc-transport-qmss_git.bb
@@ -0,0 +1,14 @@
1include ipc-transport-qmss.inc
2
3DEPENDS = "ti-ipc mpm-transport"
4
5do_compile () {
6# Now build the transport
7 oe_runmake clean
8 oe_runmake lib
9}
10
11do_install () {
12 oe_runmake install INSTALL_INC_BASE_DIR=${D}${includedir} \
13 INSTALL_LIB_BASE_DIR=${D}${libdir}
14}