diff options
author | Sam Nelson <sam.nelson@ti.com> | 2015-04-13 23:57:48 +0000 |
---|---|---|
committer | Denys Dmytriyenko <denys@ti.com> | 2015-04-22 12:03:56 -0400 |
commit | b60c3babdaf0959cda2f2470e77342f43d1084c5 (patch) | |
tree | c3e9963578493e2bfc2f78b766f49fbbff952a5e /recipes-ti | |
parent | ef3632215004f4697c46b166c475cc66afabb257 (diff) | |
download | meta-ti-b60c3babdaf0959cda2f2470e77342f43d1084c5.tar.gz |
ipc-transport-srio: Add recipe for ipc transport using srio interface
- Adds ipc transport layer using srio interface
- Supports k2h & k2k devices
- test recipe provides test code using srio transport
Signed-off-by: Sam Nelson <sam.nelson@ti.com>
Signed-off-by: Denys Dmytriyenko <denys@ti.com>
Diffstat (limited to 'recipes-ti')
-rw-r--r-- | recipes-ti/ipc/ipc-transport-srio-test_git.bb | 30 | ||||
-rw-r--r-- | recipes-ti/ipc/ipc-transport-srio.inc | 16 | ||||
-rw-r--r-- | recipes-ti/ipc/ipc-transport-srio_git.bb | 14 |
3 files changed, 60 insertions, 0 deletions
diff --git a/recipes-ti/ipc/ipc-transport-srio-test_git.bb b/recipes-ti/ipc/ipc-transport-srio-test_git.bb new file mode 100644 index 00000000..866fc35c --- /dev/null +++ b/recipes-ti/ipc/ipc-transport-srio-test_git.bb | |||
@@ -0,0 +1,30 @@ | |||
1 | include ipc-transport-srio.inc | ||
2 | |||
3 | DEPENDS = "ipc-transport-srio ipc-transport-qmss ti-ipc" | ||
4 | |||
5 | DEVICELIST = "k2h k2k" | ||
6 | |||
7 | CHOICELIST = "yes no" | ||
8 | |||
9 | do_compile () { | ||
10 | # Now build the test code | ||
11 | for device in ${DEVICELIST} | ||
12 | do | ||
13 | for choice in ${CHOICELIST} | ||
14 | do | ||
15 | oe_runmake tests \ | ||
16 | IPC_DEVKIT_INSTALL_PATH=${STAGING_INCDIR} \ | ||
17 | USEDYNAMIC_LIB="$choice" DEVICE="$device" | ||
18 | done | ||
19 | done | ||
20 | } | ||
21 | |||
22 | do_install () { | ||
23 | |||
24 | for device in ${DEVICELIST} | ||
25 | do | ||
26 | oe_runmake installbin \ | ||
27 | INSTALL_BIN_BASE_DIR=${D}${bindir} DEVICE="$device" | ||
28 | done | ||
29 | |||
30 | } | ||
diff --git a/recipes-ti/ipc/ipc-transport-srio.inc b/recipes-ti/ipc/ipc-transport-srio.inc new file mode 100644 index 00000000..e286421f --- /dev/null +++ b/recipes-ti/ipc/ipc-transport-srio.inc | |||
@@ -0,0 +1,16 @@ | |||
1 | DESCRIPTION = "TI SRIO-Based IPC MessageQ Transport" | ||
2 | LICENSE = "BSD-3-Clause" | ||
3 | |||
4 | LIC_FILES_CHKSUM = "file://COPYING.txt;md5=27bb0deb260c60120a8d7b91da7c3b02" | ||
5 | |||
6 | BRANCH="master" | ||
7 | SRC_URI = "git://git.ti.com/keystone-linux/ipc-transport.git;protocol=git;branch=${BRANCH}" | ||
8 | # Below commit ID corresponds to DEV.IPC-TRANSPORT.01.00.00.00 | ||
9 | SRCREV = "b3077467126c84b5d583dc29e13ab221064b687b" | ||
10 | PV = "01.00.00.00" | ||
11 | |||
12 | COMPATIBLE_MACHINE = "keystone" | ||
13 | |||
14 | S = "${WORKDIR}/git/linux/srio" | ||
15 | |||
16 | EXTRA_OEMAKE += "PDK_INSTALL_PATH=${STAGING_INCDIR} TRANS_SRIO_SRC_DIR=${S}" | ||
diff --git a/recipes-ti/ipc/ipc-transport-srio_git.bb b/recipes-ti/ipc/ipc-transport-srio_git.bb new file mode 100644 index 00000000..266aa4e2 --- /dev/null +++ b/recipes-ti/ipc/ipc-transport-srio_git.bb | |||
@@ -0,0 +1,14 @@ | |||
1 | include ipc-transport-srio.inc | ||
2 | |||
3 | DEPENDS = "ti-ipc mpm-transport" | ||
4 | |||
5 | do_compile () { | ||
6 | # Now build the transport | ||
7 | oe_runmake clean | ||
8 | oe_runmake lib | ||
9 | } | ||
10 | |||
11 | do_install () { | ||
12 | oe_runmake install INSTALL_INC_BASE_DIR=${D}${includedir} \ | ||
13 | INSTALL_LIB_BASE_DIR=${D}${libdir} | ||
14 | } | ||