summaryrefslogtreecommitdiffstats
path: root/recipes-ti
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2018-10-13 01:50:00 +0000
committerDenys Dmytriyenko <denys@ti.com>2018-10-16 18:40:10 +0000
commit0175348dfeb074c7734e09afd4a4b7f21d31a5e0 (patch)
treecaa437a73b04f34eeb0978ab8210c9474f359e57 /recipes-ti
parent18aca378994d7c6f8cf834d4fe9086b81db794cc (diff)
downloadmeta-ti-0175348dfeb074c7734e09afd4a4b7f21d31a5e0.tar.gz
beaglebone-getting-started: Use cp options to not alter file mode
Fixes do_package_qa warnings <FILE> is owned by uid 1000, which is the same as the user running bitbake. This may be due to host contamination Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Denys Dmytriyenko <denys@ti.com>
Diffstat (limited to 'recipes-ti')
-rw-r--r--recipes-ti/beagleboard/beaglebone-getting-started.bb2
1 files changed, 1 insertions, 1 deletions
diff --git a/recipes-ti/beagleboard/beaglebone-getting-started.bb b/recipes-ti/beagleboard/beaglebone-getting-started.bb
index 603a01a7..6c61a4e9 100644
--- a/recipes-ti/beagleboard/beaglebone-getting-started.bb
+++ b/recipes-ti/beagleboard/beaglebone-getting-started.bb
@@ -14,7 +14,7 @@ S = "${WORKDIR}/git"
14 14
15do_install() { 15do_install() {
16 install -d ${D}${datadir}/${PN} 16 install -d ${D}${datadir}/${PN}
17 cp -a ${S}/* ${D}${datadir}/${PN} 17 cp -R --no-dereference --preserve=mode,links ${S}/* ${D}${datadir}/${PN}
18} 18}
19 19
20FILES_${PN} += "${datadir}/${PN}" 20FILES_${PN} += "${datadir}/${PN}"