summaryrefslogtreecommitdiffstats
path: root/recipes-ti
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denys@ti.com>2013-10-13 18:25:19 -0400
committerDenys Dmytriyenko <denys@ti.com>2013-10-14 12:32:52 -0400
commitb3df09902da0d2469a02e9975d404e26c4c5ec0e (patch)
tree48364a64fc8a5804659a373c378a7624cc086cd3 /recipes-ti
parent466575a7e7312b57c4b43241d16894dea8692049 (diff)
downloadmeta-ti-b3df09902da0d2469a02e9975d404e26c4c5ec0e.tar.gz
recipes: cruft removal and seasonal cleanup
* Eliminate need for BBMASK - remove images requiring systemd/angstrom dependency * Move ti-test packagegroup to proper location and update from latest Arago * Move BoneScript and Bone GSG recipes to recipes-ti/beagleboard * README in recipes-ti warns about unsupported nature of those packages Signed-off-by: Denys Dmytriyenko <denys@ti.com>
Diffstat (limited to 'recipes-ti')
-rw-r--r--recipes-ti/README1
-rw-r--r--recipes-ti/beagleboard/beaglebone-getting-started.bb20
-rw-r--r--recipes-ti/beagleboard/bonescript.bb38
-rw-r--r--recipes-ti/beagleboard/bonescript/bone101.service11
-rw-r--r--recipes-ti/beagleboard/bonescript/bonescript-git11
-rw-r--r--recipes-ti/matrix/README5
-rw-r--r--recipes-ti/matrix/files/0001-matrix_gui.pro-add-dbus-to-QT-features-to-fix-linkin.patch31
-rw-r--r--recipes-ti/packagegroup/packagegroup-ti-test.bb24
8 files changed, 81 insertions, 60 deletions
diff --git a/recipes-ti/README b/recipes-ti/README
new file mode 100644
index 00000000..9907901a
--- /dev/null
+++ b/recipes-ti/README
@@ -0,0 +1 @@
Note: many of the packages in this area are not actively maintained.
diff --git a/recipes-ti/beagleboard/beaglebone-getting-started.bb b/recipes-ti/beagleboard/beaglebone-getting-started.bb
new file mode 100644
index 00000000..603a01a7
--- /dev/null
+++ b/recipes-ti/beagleboard/beaglebone-getting-started.bb
@@ -0,0 +1,20 @@
1DESCRIPTION = "BeagleBone Getting Started Guide"
2
3PR = "r21"
4
5inherit allarch
6
7LICENSE = "GPLv2+ & MIT & PD & others"
8LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=603591dea023c3c75b48e07cb47ce639"
9
10SRCREV = "6c548a307c948b28a99d48fd17d9790b56182196"
11SRC_URI = "git://github.com/jadonk/beaglebone-getting-started.git"
12
13S = "${WORKDIR}/git"
14
15do_install() {
16 install -d ${D}${datadir}/${PN}
17 cp -a ${S}/* ${D}${datadir}/${PN}
18}
19
20FILES_${PN} += "${datadir}/${PN}"
diff --git a/recipes-ti/beagleboard/bonescript.bb b/recipes-ti/beagleboard/bonescript.bb
new file mode 100644
index 00000000..b9dfbe63
--- /dev/null
+++ b/recipes-ti/beagleboard/bonescript.bb
@@ -0,0 +1,38 @@
1DESCRIPTION = "Scripting tools for the BeagleBoard and BeagleBone"
2
3PR = "r15"
4
5inherit systemd
6
7LICENSE = "MIT"
8LIC_FILES_CHKSUM = "file://LICENSE;md5=659ee0c98db2664403c769d6b9ab50eb"
9
10SRC_URI = "http://dominion.thruhere.net/koen/angstrom/beaglebone/bonescript-6af82b41178c37644399b19039ea7e80c1dbf8ee.tar.bz2 \
11 file://bonescript-git \
12 file://bone101.service \
13 "
14SRC_URI[md5sum] = "e5e214857afbd2e59b52171e60810be2"
15SRC_URI[sha256sum] = "e703416a63406c8b6c89fb1079406833ce6a9eb0ae1ba0a55fe3802b83186c50"
16
17S = "${WORKDIR}/bonescript"
18
19do_install() {
20 install -d ${D}${localstatedir}/lib/cloud9/
21 cp -a ${S}/* ${D}${localstatedir}/lib/cloud9/
22 cp -a ${S}/.git ${D}${localstatedir}/lib/cloud9/
23
24 install -d ${D}${base_libdir}/systemd/system
25 install -m 0644 ${WORKDIR}/bone101.service ${D}${base_libdir}/systemd/system
26
27 rm -f ${D}${localstatedir}/lib/cloud9/node_modules/binary/node_modules/put/test/c/itof
28 rm -f ${D}${localstatedir}/lib/cloud9/node_modules/binary/node_modules/put/test/c/ftoi
29}
30
31NATIVE_SYSTEMD_SUPPORT = "1"
32SYSTEMD_PACKAGES = "${PN}"
33SYSTEMD_SERVICE_${PN} = "bone101.service"
34
35FILES_${PN} += "${localstatedir} ${base_libdir}/systemd/system"
36CONFFILES_${PN} += "${localstatedir}/lib/cloud9/.git/config"
37RDEPENDS_${PN} = "nodejs cloud9"
38RRECOMMENDS_${PN} = "git"
diff --git a/recipes-ti/beagleboard/bonescript/bone101.service b/recipes-ti/beagleboard/bonescript/bone101.service
new file mode 100644
index 00000000..49562ba4
--- /dev/null
+++ b/recipes-ti/beagleboard/bonescript/bone101.service
@@ -0,0 +1,11 @@
1[Unit]
2Description=Beaglebone 101 presentation
3ConditionPathExists=|/var/lib/cloud9
4
5[Service]
6WorkingDirectory=/var/lib/cloud9
7ExecStart=/usr/bin/node bone101.js
8
9[Install]
10WantedBy=multi-user.target
11
diff --git a/recipes-ti/beagleboard/bonescript/bonescript-git b/recipes-ti/beagleboard/bonescript/bonescript-git
new file mode 100644
index 00000000..d9e66cfb
--- /dev/null
+++ b/recipes-ti/beagleboard/bonescript/bonescript-git
@@ -0,0 +1,11 @@
1[core]
2 repositoryformatversion = 0
3 filemode = true
4 bare = false
5 logallrefupdates = true
6[remote "origin"]
7 fetch = +refs/heads/*:refs/remotes/origin/*
8 url = git://github.com/jadonk/bonescript.git
9[branch "master"]
10 remote = origin
11 merge = refs/heads/master
diff --git a/recipes-ti/matrix/README b/recipes-ti/matrix/README
deleted file mode 100644
index ed775960..00000000
--- a/recipes-ti/matrix/README
+++ /dev/null
@@ -1,5 +0,0 @@
1Matrix app has been moved to meta-arago-extras layer of the meta-arago repo:
2git://arago-project.org/git/meta-arago.git
3
4This meta-arago-extras layer is distro-agnostic and not Arago-specific, so
5it can be used with any OE-Core based distribution.
diff --git a/recipes-ti/matrix/files/0001-matrix_gui.pro-add-dbus-to-QT-features-to-fix-linkin.patch b/recipes-ti/matrix/files/0001-matrix_gui.pro-add-dbus-to-QT-features-to-fix-linkin.patch
deleted file mode 100644
index 324f9808..00000000
--- a/recipes-ti/matrix/files/0001-matrix_gui.pro-add-dbus-to-QT-features-to-fix-linkin.patch
+++ /dev/null
@@ -1,31 +0,0 @@
1From 420cadec0f7a6048a0fafccf4c658d543b7dbf19 Mon Sep 17 00:00:00 2001
2From: Koen Kooi <k-kooi@ti.com>
3Date: Tue, 26 Jul 2011 14:25:39 +0200
4Subject: [PATCH] matrix_gui.pro: add dbus to QT features to fix linking with -Wl,--as-needed
5
6This fixes:
7
8| ccache arm-angstrom-linux-gnueabi-g++ -march=armv7-a -mtune=cortex-a8 -mfpu=neon -mfloat-abi=softfp -fno-tree-vectorize -mthumb-interwork -mno-thumb --sysroot=/home/koen/angstrom-core/build/tmp-angstrom_2010_x-eglibc/sysroots/beagleboard -Wl,-O1 -Wl,--hash-style=gnu -Wl,--as-needed -Wl,-rpath-link,/home/koen/angstrom-core/build/tmp-angstrom_2010_x-eglibc/sysroots/beagleboard/usr/lib -o matrix_gui main.o mainwindow.o buttonfactory.o buttonlaunch.o customstyle.o menupage.o osdmanager.o matrixcontrol.o moc_mainwindow.o moc_buttonfactory.o moc_buttonlaunch.o moc_customstyle.o moc_menupage.o moc_osdmanager.o moc_matrixcontrol.o -L/home/koen/angstrom-core/build/tmp-angstrom_2010_x-eglibc/sysroots/beagleboard/usr/lib -lpng -lfreetype -lz -lgthread-2.0 -lQtWebKit -lQtGui -lQtNetwork -lQtCore -lpthread
9| ux-gnueabi/4.5.4/ld: }: invalid DSO for symbol `QDBusConnection::registerService(QString const&)' definition
10| /home/koen/angstrom-core/build/tmp-angstrom_2010_x-eglibc/sysroots/beagleboard/usr/lib/libQtDBus.so.4: could not read symbols: Bad value
11| collect2: ld returned 1 exit status
12
13Signed-off-by: Koen Kooi <k-kooi@ti.com>
14---
15 matrix_gui.pro | 3 ++-
16 1 files changed, 2 insertions(+), 1 deletions(-)
17
18diff --git a/matrix_gui.pro b/matrix_gui.pro
19index 5463310..908e8a7 100644
20--- a/matrix_gui.pro
21+++ b/matrix_gui.pro
22@@ -1,4 +1,5 @@
23-QT += webkit \
24+QT += dbus \
25+ webkit \
26 network
27 LIBS += -lpng -lfreetype -lz -lgthread-2.0
28 HEADERS = mainwindow.h \
29--
301.7.4.4
31
diff --git a/recipes-ti/packagegroup/packagegroup-ti-test.bb b/recipes-ti/packagegroup/packagegroup-ti-test.bb
deleted file mode 100644
index fc19bc56..00000000
--- a/recipes-ti/packagegroup/packagegroup-ti-test.bb
+++ /dev/null
@@ -1,24 +0,0 @@
1DESCRIPTION = "Extended task to get System Test specific apps"
2LICENSE = "MIT"
3LIC_FILES_CHKSUM = "file://${COREBASE}/LICENSE;md5=3f40d7994397109285ec7b81fdeb3b58"
4
5inherit allarch packagegroup
6
7TEST = "\
8 bonnie++ \
9 hdparm \
10 iozone3 \
11 iperf \
12 lmbench \
13 rt-tests \
14 "
15
16TI_TEST = "\
17 ltp-ddt \
18 "
19
20RDEPENDS_${PN} = "\
21 ${TEST} \
22 ${TI_TEST} \
23 "
24