summaryrefslogtreecommitdiffstats
path: root/recipes-ti
diff options
context:
space:
mode:
authorHao Zhang <hzhang@ti.com>2018-08-14 20:32:19 +0000
committerDenys Dmytriyenko <denys@ti.com>2018-08-23 16:54:25 +0000
commit193d816cac7b79429afb3814292a0de7b9b2e30a (patch)
tree915724a07c7c1211e01d55a2d3004fb2b7da8387 /recipes-ti
parent16af494ca367f471e6341e4ca12ee541f512fcd3 (diff)
downloadmeta-ti-193d816cac7b79429afb3814292a0de7b9b2e30a.tar.gz
recipes-ti: devtools: add GCC Linaro baremetal toolchain 2017.11 v7.2.1
Signed-off-by: Hao Zhang <hzhang@ti.com> Signed-off-by: Denys Dmytriyenko <denys@ti.com>
Diffstat (limited to 'recipes-ti')
-rw-r--r--recipes-ti/devtools/gcc-linaro-baremetal-aarch64-native.bb23
-rw-r--r--recipes-ti/devtools/gcc-linaro-baremetal-native.bb23
-rw-r--r--recipes-ti/devtools/gcc-linaro.inc10
-rw-r--r--recipes-ti/includes/ti-paths.inc5
4 files changed, 61 insertions, 0 deletions
diff --git a/recipes-ti/devtools/gcc-linaro-baremetal-aarch64-native.bb b/recipes-ti/devtools/gcc-linaro-baremetal-aarch64-native.bb
new file mode 100644
index 00000000..97344f90
--- /dev/null
+++ b/recipes-ti/devtools/gcc-linaro-baremetal-aarch64-native.bb
@@ -0,0 +1,23 @@
1include recipes-ti/devtools/gcc-linaro.inc
2
3PACKAGE_DIR = "gcc-linaro-${PV}-${GCC_ARM_YEAR}-x86_64_aarch64-elf"
4S = "${WORKDIR}/${PACKAGE_DIR}"
5
6LIC_CHKSUM = "bc7fad4bba98e7a4cd5ab3042506493c"
7
8inherit native
9require recipes-ti/includes/ti-paths.inc
10
11SRC_URI = "https://releases.linaro.org/components/toolchain/binaries/7.2-${GCC_ARM_YEAR}/aarch64-elf/gcc-linaro-${PV}-${GCC_ARM_YEAR}-x86_64_aarch64-elf.tar.xz;name=gcc-linaro-aarch64"
12
13SRC_URI[gcc-linaro-aarch64.md5sum] = "4972f8943820bdd2f577f498de78964b"
14SRC_URI[gcc-linaro-aarch64.sha256sum] = "30fb7d876bcb982c502057c593d9c1f11b35d5158a26d986718e2b998388c4c8"
15
16do_install() {
17 install -d ${D}${GCC_LINARO_BAREMETAL_AARCH64_TOOLCHAIN_RECIPE}
18 cp -r ${S}/. ${D}${GCC_LINARO_BAREMETAL_AARCH64_TOOLCHAIN_RECIPE}
19}
20
21FILES_${PN} = "${GCC_LINARO_BAREMETAL_AARCH64_TOOLCHAIN_RECIPE}/*"
22
23INSANE_SKIP_${PN} = "already-stripped"
diff --git a/recipes-ti/devtools/gcc-linaro-baremetal-native.bb b/recipes-ti/devtools/gcc-linaro-baremetal-native.bb
new file mode 100644
index 00000000..0268ae3d
--- /dev/null
+++ b/recipes-ti/devtools/gcc-linaro-baremetal-native.bb
@@ -0,0 +1,23 @@
1include recipes-ti/devtools/gcc-linaro.inc
2
3PACKAGE_DIR = "gcc-linaro-${PV}-${GCC_ARM_YEAR}-x86_64_arm-eabi"
4S = "${WORKDIR}/${PACKAGE_DIR}"
5
6LIC_CHKSUM = "bc7fad4bba98e7a4cd5ab3042506493c"
7
8inherit native
9require recipes-ti/includes/ti-paths.inc
10
11SRC_URI = "https://releases.linaro.org/components/toolchain/binaries/7.2-${GCC_ARM_YEAR}/arm-eabi/gcc-linaro-${PV}-${GCC_ARM_YEAR}-x86_64_arm-eabi.tar.xz;name=gcc-linaro"
12
13SRC_URI[gcc-linaro.md5sum] = "9a4a39cfc78c84375b1160aa93587aed"
14SRC_URI[gcc-linaro.sha256sum] = "45fc4f90af2e2e9c3197a275f6005ef5639f7a1889fa3eb24c3125ccd70fcd3d"
15
16do_install() {
17 install -d ${D}${GCC_LINARO_BAREMETAL_TOOLCHAIN_RECIPE}
18 cp -r ${S}/. ${D}${GCC_LINARO_BAREMETAL_TOOLCHAIN_RECIPE}
19}
20
21FILES_${PN} = "${GCC_LINARO_BAREMETAL_TOOLCHAIN_RECIPE}/*"
22
23INSANE_SKIP_${PN} = "already-stripped"
diff --git a/recipes-ti/devtools/gcc-linaro.inc b/recipes-ti/devtools/gcc-linaro.inc
new file mode 100644
index 00000000..19f5a2cf
--- /dev/null
+++ b/recipes-ti/devtools/gcc-linaro.inc
@@ -0,0 +1,10 @@
1DESCRIPTION = "Linaro GCC for ARM"
2HOMEPAGE = "https://launchpad.net/gcc-arm-embedded"
3SECTION = "devel"
4LICENSE = "GPL-3.0-with-GCC-exception & GPLv3"
5LIC_FILES_CHKSUM = "file://share/doc/gcc/GNU-Free-Documentation-License.html;md5=${LIC_CHKSUM}"
6
7PV = "7.2.1"
8PR = "r0"
9
10GCC_ARM_YEAR = "2017.11"
diff --git a/recipes-ti/includes/ti-paths.inc b/recipes-ti/includes/ti-paths.inc
index 4f99d5ef..a401264a 100644
--- a/recipes-ti/includes/ti-paths.inc
+++ b/recipes-ti/includes/ti-paths.inc
@@ -56,6 +56,8 @@ export CG_XML_INSTALL_DIR_RECIPE = "${installdir}/ti-cg-xml-tree"
56export OMP_INSTALL_DIR_RECIPE = "${installdir}/ti-omp-tree" 56export OMP_INSTALL_DIR_RECIPE = "${installdir}/ti-omp-tree"
57export MPM_INSTALL_DIR_RECIPE = "${installdir}/ti-mpm-tree" 57export MPM_INSTALL_DIR_RECIPE = "${installdir}/ti-mpm-tree"
58export TI_CGT6X_7_INSTALL_DIR_RECIPE = "${installdir}/cgt6x-7" 58export TI_CGT6X_7_INSTALL_DIR_RECIPE = "${installdir}/cgt6x-7"
59export GCC_LINARO_BAREMETAL_TOOLCHAIN_RECIPE = "${installdir}/gcc-linaro-baremetal"
60export GCC_LINARO_BAREMETAL_AARCH64_TOOLCHAIN_RECIPE = "${installdir}/gcc-linaro-baremetal-aarch64"
59 61
60# This is where the tools will end up in sysroot 62# This is where the tools will end up in sysroot
61export BIOS_INSTALL_DIR = "${STAGING_DIR_TARGET}${BIOS_INSTALL_DIR_RECIPE}" 63export BIOS_INSTALL_DIR = "${STAGING_DIR_TARGET}${BIOS_INSTALL_DIR_RECIPE}"
@@ -103,6 +105,9 @@ export CG_XML_INSTALL_DIR = "${STAGING_DIR_NATIVE}${CG_XML_INSTALL_DIR_RECIP
103export OMP_INSTALL_DIR = "${STAGING_DIR_TARGET}${OMP_INSTALL_DIR_RECIPE}" 105export OMP_INSTALL_DIR = "${STAGING_DIR_TARGET}${OMP_INSTALL_DIR_RECIPE}"
104export MPM_INSTALL_DIR = "${STAGING_DIR_TARGET}${MPM_INSTALL_DIR_RECIPE}" 106export MPM_INSTALL_DIR = "${STAGING_DIR_TARGET}${MPM_INSTALL_DIR_RECIPE}"
105export TI_CGT6X_7_INSTALL_DIR = "${STAGING_DIR_NATIVE}${TI_CGT6X_7_INSTALL_DIR_RECIPE}" 107export TI_CGT6X_7_INSTALL_DIR = "${STAGING_DIR_NATIVE}${TI_CGT6X_7_INSTALL_DIR_RECIPE}"
108export GCC_LINARO_BAREMETAL_TOOLCHAIN = "${STAGING_DIR_NATIVE}${GCC_LINARO_BAREMETAL_TOOLCHAIN_RECIPE}"
109export GCC_LINARO_BAREMETAL_AARCH64_TOOLCHAIN = "${STAGING_DIR_NATIVE}${GCC_LINARO_BAREMETAL_AARCH64_TOOLCHAIN_RECIPE}"
110
106 111
107DSPSUFFIX_omapl137 = "x674" 112DSPSUFFIX_omapl137 = "x674"
108DSPSUFFIX_omapl138 = "x674" 113DSPSUFFIX_omapl138 = "x674"