diff options
author | Denys Dmytriyenko <denys@ti.com> | 2018-04-21 01:22:12 +0000 |
---|---|---|
committer | Denys Dmytriyenko <denys@ti.com> | 2018-04-24 16:00:13 -0400 |
commit | 4dea2a4b6fb40fbbd33ccba724c97be9ff4c402b (patch) | |
tree | 70e246942b84998e3eb0c4c2c27f68eca6e270b4 /recipes-ti | |
parent | 799cbdf39afa2b8edf46a9befa5b250810ee4197 (diff) | |
download | meta-ti-4dea2a4b6fb40fbbd33ccba724c97be9ff4c402b.tar.gz |
conf, recipes: introduce k2l family and add support for k2l-hs-evm
Signed-off-by: Denys Dmytriyenko <denys@ti.com>
Diffstat (limited to 'recipes-ti')
-rw-r--r-- | recipes-ti/ipc/ipc-transport-common-rtos_git.bb | 2 | ||||
-rw-r--r-- | recipes-ti/ipc/ipc-transport-qmss-rtos_git.bb | 2 | ||||
-rw-r--r-- | recipes-ti/ipc/ipc-transport-qmss-test_git.bb | 2 | ||||
-rw-r--r-- | recipes-ti/ipc/ti-ipc-common.inc | 2 | ||||
-rw-r--r-- | recipes-ti/ipc/ti-ipc-rtos_git.bb | 4 | ||||
-rw-r--r-- | recipes-ti/ipc/ti-ipc_git.bb | 2 | ||||
-rw-r--r-- | recipes-ti/openmp-rtos/openmp-rtos_git.bb | 2 |
7 files changed, 8 insertions, 8 deletions
diff --git a/recipes-ti/ipc/ipc-transport-common-rtos_git.bb b/recipes-ti/ipc/ipc-transport-common-rtos_git.bb index 3b44713b..6fec0f0d 100644 --- a/recipes-ti/ipc/ipc-transport-common-rtos_git.bb +++ b/recipes-ti/ipc/ipc-transport-common-rtos_git.bb | |||
@@ -5,7 +5,7 @@ PR = "${INC_PR}.1" | |||
5 | 5 | ||
6 | LIC_FILES_CHKSUM = "file://common_src/bench_common.h;beginline=1;endline=31;md5=a6ddfb26d2097041d513e3881f40e4e8" | 6 | LIC_FILES_CHKSUM = "file://common_src/bench_common.h;beginline=1;endline=31;md5=a6ddfb26d2097041d513e3881f40e4e8" |
7 | 7 | ||
8 | COMPATIBLE_MACHINE = "k2hk|k2l-evm|k2e" | 8 | COMPATIBLE_MACHINE = "k2hk|k2l|k2e" |
9 | 9 | ||
10 | IPC_TRANSPORT_COMMON_DESTSUFFIX = "git/c66/example" | 10 | IPC_TRANSPORT_COMMON_DESTSUFFIX = "git/c66/example" |
11 | 11 | ||
diff --git a/recipes-ti/ipc/ipc-transport-qmss-rtos_git.bb b/recipes-ti/ipc/ipc-transport-qmss-rtos_git.bb index 5bb0bcf6..6655ab7e 100644 --- a/recipes-ti/ipc/ipc-transport-qmss-rtos_git.bb +++ b/recipes-ti/ipc/ipc-transport-qmss-rtos_git.bb | |||
@@ -5,7 +5,7 @@ PR = "${INC_PR}.4" | |||
5 | 5 | ||
6 | LIC_FILES_CHKSUM = "file://TransportQmss.xdc;beginline=1;endline=35;md5=ad783760d74a4cc5b8d4ad3d8a1f28a2" | 6 | LIC_FILES_CHKSUM = "file://TransportQmss.xdc;beginline=1;endline=35;md5=ad783760d74a4cc5b8d4ad3d8a1f28a2" |
7 | 7 | ||
8 | COMPATIBLE_MACHINE = "k2hk|k2l-evm|k2e" | 8 | COMPATIBLE_MACHINE = "k2hk|k2l|k2e" |
9 | 9 | ||
10 | PACKAGE_ARCH = "${MACHINE_ARCH}" | 10 | PACKAGE_ARCH = "${MACHINE_ARCH}" |
11 | 11 | ||
diff --git a/recipes-ti/ipc/ipc-transport-qmss-test_git.bb b/recipes-ti/ipc/ipc-transport-qmss-test_git.bb index dbf8f169..3561ef95 100644 --- a/recipes-ti/ipc/ipc-transport-qmss-test_git.bb +++ b/recipes-ti/ipc/ipc-transport-qmss-test_git.bb | |||
@@ -12,7 +12,7 @@ CHOICELIST = "yes no" | |||
12 | 12 | ||
13 | DEVICELIST_k2hk = "k2h k2k" | 13 | DEVICELIST_k2hk = "k2h k2k" |
14 | DEVICELIST_k2e = "k2e" | 14 | DEVICELIST_k2e = "k2e" |
15 | DEVICELIST_k2l-evm = "k2l" | 15 | DEVICELIST_k2l = "k2l" |
16 | 16 | ||
17 | do_compile () { | 17 | do_compile () { |
18 | # Now build the test code | 18 | # Now build the test code |
diff --git a/recipes-ti/ipc/ti-ipc-common.inc b/recipes-ti/ipc/ti-ipc-common.inc index f5d2ebd4..00e4e915 100644 --- a/recipes-ti/ipc/ti-ipc-common.inc +++ b/recipes-ti/ipc/ti-ipc-common.inc | |||
@@ -7,7 +7,7 @@ PLATFORM = "UNKNOWN" | |||
7 | PLATFORM_omap5-evm = "OMAP54XX" | 7 | PLATFORM_omap5-evm = "OMAP54XX" |
8 | PLATFORM_dra7xx = "DRA7XX" | 8 | PLATFORM_dra7xx = "DRA7XX" |
9 | PLATFORM_k2hk = "TCI6638" | 9 | PLATFORM_k2hk = "TCI6638" |
10 | PLATFORM_k2l-evm = "TCI6630" | 10 | PLATFORM_k2l = "TCI6630" |
11 | PLATFORM_k2e = "66AK2E" | 11 | PLATFORM_k2e = "66AK2E" |
12 | PLATFORM_k2g = "66AK2G" | 12 | PLATFORM_k2g = "66AK2G" |
13 | PLATFORM_omapl138 = "OMAPL138" | 13 | PLATFORM_omapl138 = "OMAPL138" |
diff --git a/recipes-ti/ipc/ti-ipc-rtos_git.bb b/recipes-ti/ipc/ti-ipc-rtos_git.bb index 4040c4d9..53ab76da 100644 --- a/recipes-ti/ipc/ti-ipc-rtos_git.bb +++ b/recipes-ti/ipc/ti-ipc-rtos_git.bb | |||
@@ -74,12 +74,12 @@ do_install() { | |||
74 | 74 | ||
75 | KFDSPNUM = "0" | 75 | KFDSPNUM = "0" |
76 | KFDSPNUM_k2hk = "8" | 76 | KFDSPNUM_k2hk = "8" |
77 | KFDSPNUM_k2l-evm = "4" | 77 | KFDSPNUM_k2l = "4" |
78 | KFDSPNUM_keystone = "1" | 78 | KFDSPNUM_keystone = "1" |
79 | 79 | ||
80 | KFPLAT = "" | 80 | KFPLAT = "" |
81 | KFPLAT_k2hk = "TCI6638K2K" | 81 | KFPLAT_k2hk = "TCI6638K2K" |
82 | KFPLAT_k2l-evm = "TCI6630K2L" | 82 | KFPLAT_k2l = "TCI6630K2L" |
83 | KFPLAT_k2e = "C66AK2E" | 83 | KFPLAT_k2e = "C66AK2E" |
84 | KFPLAT_k2g = "TCI66AK2G02" | 84 | KFPLAT_k2g = "TCI66AK2G02" |
85 | 85 | ||
diff --git a/recipes-ti/ipc/ti-ipc_git.bb b/recipes-ti/ipc/ti-ipc_git.bb index 0c5088b6..403649ff 100644 --- a/recipes-ti/ipc/ti-ipc_git.bb +++ b/recipes-ti/ipc/ti-ipc_git.bb | |||
@@ -17,7 +17,7 @@ DAEMON = "UNKNOWN" | |||
17 | DAEMON_omap5-evm = "lad_omap54xx_smp" | 17 | DAEMON_omap5-evm = "lad_omap54xx_smp" |
18 | DAEMON_dra7xx = "lad_dra7xx" | 18 | DAEMON_dra7xx = "lad_dra7xx" |
19 | DAEMON_k2hk = "lad_tci6638" | 19 | DAEMON_k2hk = "lad_tci6638" |
20 | DAEMON_k2l-evm = "lad_tci6630" | 20 | DAEMON_k2l = "lad_tci6630" |
21 | DAEMON_k2e = "lad_66ak2e" | 21 | DAEMON_k2e = "lad_66ak2e" |
22 | DAEMON_k2g = "lad_66ak2g" | 22 | DAEMON_k2g = "lad_66ak2g" |
23 | DAEMON_omapl138 = "lad_omapl138" | 23 | DAEMON_omapl138 = "lad_omapl138" |
diff --git a/recipes-ti/openmp-rtos/openmp-rtos_git.bb b/recipes-ti/openmp-rtos/openmp-rtos_git.bb index bd213b86..e9b14e5b 100644 --- a/recipes-ti/openmp-rtos/openmp-rtos_git.bb +++ b/recipes-ti/openmp-rtos/openmp-rtos_git.bb | |||
@@ -21,7 +21,7 @@ LIC_FILES_CHKSUM = "file://docs/license/omp_manifest_template.html;md5=61a697230 | |||
21 | DEPENDS = "common-csl-ip-rtos doxygen-native libulm ti-xdctools-native ti-ipc-rtos ti-sysbios ti-cgt6x-native zip-native" | 21 | DEPENDS = "common-csl-ip-rtos doxygen-native libulm ti-xdctools-native ti-ipc-rtos ti-sysbios ti-cgt6x-native zip-native" |
22 | DEPENDS_append_k2hk = " qmss-lld-rtos cppi-lld-rtos" | 22 | DEPENDS_append_k2hk = " qmss-lld-rtos cppi-lld-rtos" |
23 | DEPENDS_append_k2e = " qmss-lld-rtos cppi-lld-rtos" | 23 | DEPENDS_append_k2e = " qmss-lld-rtos cppi-lld-rtos" |
24 | DEPENDS_append_k2l-evm = " qmss-lld-rtos cppi-lld-rtos" | 24 | DEPENDS_append_k2l = " qmss-lld-rtos cppi-lld-rtos" |
25 | 25 | ||
26 | COMPATIBLE_MACHINE = "keystone|omap-a15" | 26 | COMPATIBLE_MACHINE = "keystone|omap-a15" |
27 | PACKAGE_ARCH = "${MACHINE_ARCH}" | 27 | PACKAGE_ARCH = "${MACHINE_ARCH}" |