diff options
author | Jacob Stiffler <j-stiffler@ti.com> | 2016-02-06 02:19:13 +0000 |
---|---|---|
committer | Denys Dmytriyenko <denys@ti.com> | 2016-02-08 12:29:42 -0500 |
commit | 63903ffd3796719ff06459b2501ddc647cbef037 (patch) | |
tree | 734fe573313fd0747a00ee4a993ffe3f10389f3a /recipes-ti | |
parent | 5b5634f078538fcbe40a36a059627653c8ddb2d1 (diff) | |
download | meta-ti-63903ffd3796719ff06459b2501ddc647cbef037.tar.gz |
ipc-transport: Extract source info to common inc file
* Also use new variables to specify the source info so this can be
easily overridden and applied to each recipe.
Signed-off-by: Jacob Stiffler <j-stiffler@ti.com>
Signed-off-by: Denys Dmytriyenko <denys@ti.com>
Diffstat (limited to 'recipes-ti')
-rw-r--r-- | recipes-ti/ipc/ipc-transport-qmss-test_git.bb | 2 | ||||
-rw-r--r-- | recipes-ti/ipc/ipc-transport-qmss.inc | 8 | ||||
-rw-r--r-- | recipes-ti/ipc/ipc-transport-qmss_git.bb | 2 | ||||
-rw-r--r-- | recipes-ti/ipc/ipc-transport-srio-test_git.bb | 2 | ||||
-rw-r--r-- | recipes-ti/ipc/ipc-transport-srio.inc | 8 | ||||
-rw-r--r-- | recipes-ti/ipc/ipc-transport-srio_git.bb | 2 | ||||
-rw-r--r-- | recipes-ti/ipc/ipc-transport.inc | 15 |
7 files changed, 27 insertions, 12 deletions
diff --git a/recipes-ti/ipc/ipc-transport-qmss-test_git.bb b/recipes-ti/ipc/ipc-transport-qmss-test_git.bb index e7c827ef..bfedaf5b 100644 --- a/recipes-ti/ipc/ipc-transport-qmss-test_git.bb +++ b/recipes-ti/ipc/ipc-transport-qmss-test_git.bb | |||
@@ -1,5 +1,7 @@ | |||
1 | include ipc-transport-qmss.inc | 1 | include ipc-transport-qmss.inc |
2 | 2 | ||
3 | PR = "${INC_PR}.0" | ||
4 | |||
3 | PACKAGE_ARCH = "${MACHINE_ARCH}" | 5 | PACKAGE_ARCH = "${MACHINE_ARCH}" |
4 | 6 | ||
5 | DEPENDS = "ipc-transport-qmss ti-ipc" | 7 | DEPENDS = "ipc-transport-qmss ti-ipc" |
diff --git a/recipes-ti/ipc/ipc-transport-qmss.inc b/recipes-ti/ipc/ipc-transport-qmss.inc index 4b74eec5..a5c8dc40 100644 --- a/recipes-ti/ipc/ipc-transport-qmss.inc +++ b/recipes-ti/ipc/ipc-transport-qmss.inc | |||
@@ -1,13 +1,9 @@ | |||
1 | DESCRIPTION = "TI QMSS-Based IPC MessageQ Transport" | 1 | DESCRIPTION = "TI QMSS-Based IPC MessageQ Transport" |
2 | LICENSE = "BSD-3-Clause" | 2 | LICENSE = "BSD-3-Clause" |
3 | 3 | ||
4 | LIC_FILES_CHKSUM = "file://COPYING.txt;md5=27bb0deb260c60120a8d7b91da7c3b02" | 4 | require ipc-transport.inc |
5 | 5 | ||
6 | BRANCH="master" | 6 | INC_PR_append = ".0" |
7 | SRC_URI = "git://git.ti.com/keystone-linux/ipc-transport.git;protocol=git;branch=${BRANCH}" | ||
8 | # Below commit ID corresponds to DEV.IPC-TRANSPORT.02.00.00.01 | ||
9 | SRCREV = "88ea336c584ccec4b2c281cd7f75df9dff6d4edf" | ||
10 | PV = "02.00.00.01" | ||
11 | 7 | ||
12 | COMPATIBLE_MACHINE = "keystone" | 8 | COMPATIBLE_MACHINE = "keystone" |
13 | 9 | ||
diff --git a/recipes-ti/ipc/ipc-transport-qmss_git.bb b/recipes-ti/ipc/ipc-transport-qmss_git.bb index cb77a12a..09acbf0b 100644 --- a/recipes-ti/ipc/ipc-transport-qmss_git.bb +++ b/recipes-ti/ipc/ipc-transport-qmss_git.bb | |||
@@ -1,5 +1,7 @@ | |||
1 | include ipc-transport-qmss.inc | 1 | include ipc-transport-qmss.inc |
2 | 2 | ||
3 | PR = "${INC_PR}.0" | ||
4 | |||
3 | DEPENDS = "ti-ipc mpm-transport" | 5 | DEPENDS = "ti-ipc mpm-transport" |
4 | 6 | ||
5 | do_compile () { | 7 | do_compile () { |
diff --git a/recipes-ti/ipc/ipc-transport-srio-test_git.bb b/recipes-ti/ipc/ipc-transport-srio-test_git.bb index 866fc35c..4e23fb21 100644 --- a/recipes-ti/ipc/ipc-transport-srio-test_git.bb +++ b/recipes-ti/ipc/ipc-transport-srio-test_git.bb | |||
@@ -1,5 +1,7 @@ | |||
1 | include ipc-transport-srio.inc | 1 | include ipc-transport-srio.inc |
2 | 2 | ||
3 | PR = "${INC_PR}.0" | ||
4 | |||
3 | DEPENDS = "ipc-transport-srio ipc-transport-qmss ti-ipc" | 5 | DEPENDS = "ipc-transport-srio ipc-transport-qmss ti-ipc" |
4 | 6 | ||
5 | DEVICELIST = "k2h k2k" | 7 | DEVICELIST = "k2h k2k" |
diff --git a/recipes-ti/ipc/ipc-transport-srio.inc b/recipes-ti/ipc/ipc-transport-srio.inc index 91e3be14..4b5c3051 100644 --- a/recipes-ti/ipc/ipc-transport-srio.inc +++ b/recipes-ti/ipc/ipc-transport-srio.inc | |||
@@ -1,13 +1,9 @@ | |||
1 | DESCRIPTION = "TI SRIO-Based IPC MessageQ Transport" | 1 | DESCRIPTION = "TI SRIO-Based IPC MessageQ Transport" |
2 | LICENSE = "BSD-3-Clause" | 2 | LICENSE = "BSD-3-Clause" |
3 | 3 | ||
4 | LIC_FILES_CHKSUM = "file://COPYING.txt;md5=27bb0deb260c60120a8d7b91da7c3b02" | 4 | require ipc-transport.inc |
5 | 5 | ||
6 | BRANCH="master" | 6 | INC_PR_append = ".0" |
7 | SRC_URI = "git://git.ti.com/keystone-linux/ipc-transport.git;protocol=git;branch=${BRANCH}" | ||
8 | # Below commit ID corresponds to DEV.IPC-TRANSPORT.02.00.00.01 | ||
9 | SRCREV = "88ea336c584ccec4b2c281cd7f75df9dff6d4edf" | ||
10 | PV = "02.00.00.01" | ||
11 | 7 | ||
12 | COMPATIBLE_MACHINE = "k2hk-evm" | 8 | COMPATIBLE_MACHINE = "k2hk-evm" |
13 | 9 | ||
diff --git a/recipes-ti/ipc/ipc-transport-srio_git.bb b/recipes-ti/ipc/ipc-transport-srio_git.bb index 266aa4e2..f0586d8b 100644 --- a/recipes-ti/ipc/ipc-transport-srio_git.bb +++ b/recipes-ti/ipc/ipc-transport-srio_git.bb | |||
@@ -1,5 +1,7 @@ | |||
1 | include ipc-transport-srio.inc | 1 | include ipc-transport-srio.inc |
2 | 2 | ||
3 | PR = "${INC_PR}.0" | ||
4 | |||
3 | DEPENDS = "ti-ipc mpm-transport" | 5 | DEPENDS = "ti-ipc mpm-transport" |
4 | 6 | ||
5 | do_compile () { | 7 | do_compile () { |
diff --git a/recipes-ti/ipc/ipc-transport.inc b/recipes-ti/ipc/ipc-transport.inc new file mode 100644 index 00000000..4ba3670b --- /dev/null +++ b/recipes-ti/ipc/ipc-transport.inc | |||
@@ -0,0 +1,15 @@ | |||
1 | LIC_FILES_CHKSUM = "file://COPYING.txt;md5=27bb0deb260c60120a8d7b91da7c3b02" | ||
2 | |||
3 | IPC_TRANSPORT_GIT_URI = "git://git.ti.com/keystone-linux/ipc-transport.git" | ||
4 | IPC_TRANSPORT_GIT_BRANCH = "master" | ||
5 | IPC_TRANSPORT_GIT_PROTOCOL = "git" | ||
6 | |||
7 | # Below commit ID corresponds to DEV.IPC-TRANSPORT.02.00.00.01 | ||
8 | IPC_TRANSPORT_SRCREV = "88ea336c584ccec4b2c281cd7f75df9dff6d4edf" | ||
9 | |||
10 | BRANCH="${IPC_TRANSPORT_GIT_BRANCH}" | ||
11 | SRC_URI = "${IPC_TRANSPORT_GIT_URI};protocol=${IPC_TRANSPORT_GIT_PROTOCOL};branch=${BRANCH}" | ||
12 | SRCREV = "${IPC_TRANSPORT_SRCREV}" | ||
13 | PV = "02.00.00.01" | ||
14 | |||
15 | INC_PR = "r1" | ||