diff options
author | Gou, Hongmei <h-gou@ti.com> | 2015-12-04 01:08:27 +0000 |
---|---|---|
committer | Denys Dmytriyenko <denys@ti.com> | 2015-12-04 22:24:13 -0500 |
commit | 05b45d714594ce81b35c6c089a960bbd4e698cf3 (patch) | |
tree | abdac350a7d109fb88c78dca285a8243d6105488 /recipes-ti | |
parent | 2903335d81642ebea78fd2225bacd0896552d053 (diff) | |
download | meta-ti-05b45d714594ce81b35c6c089a960bbd4e698cf3.tar.gz |
mathlib-c66x: add version 3.1.1.0
Signed-off-by: Hongmei Gou <h-gou@ti.com>
Signed-off-by: Denys Dmytriyenko <denys@ti.com>
Diffstat (limited to 'recipes-ti')
-rw-r--r-- | recipes-ti/includes/ti-paths.inc | 2 | ||||
-rw-r--r-- | recipes-ti/mathlib/mathlib-c66x.inc | 28 | ||||
-rw-r--r-- | recipes-ti/mathlib/mathlib-c66x_3.1.1.0.bb | 9 |
3 files changed, 39 insertions, 0 deletions
diff --git a/recipes-ti/includes/ti-paths.inc b/recipes-ti/includes/ti-paths.inc index 37feb939..7d2211aa 100644 --- a/recipes-ti/includes/ti-paths.inc +++ b/recipes-ti/includes/ti-paths.inc | |||
@@ -50,6 +50,7 @@ export CCSV6_INSTALL_DIR_RECIPE = "${installdir}/ccsv6" | |||
50 | export GCC_ARM_NONE_TOOLCHAIN_RECIPE = "${installdir}/gcc-arm-none-eabi" | 50 | export GCC_ARM_NONE_TOOLCHAIN_RECIPE = "${installdir}/gcc-arm-none-eabi" |
51 | export TI_CGT_PRU_INSTALL_DIR_RECIPE = "${installdir}/cgt-pru" | 51 | export TI_CGT_PRU_INSTALL_DIR_RECIPE = "${installdir}/cgt-pru" |
52 | export DSPLIB_C66_INSTALL_DIR_RECIPE = "${installdir}/ti-dsplib-c66x-tree" | 52 | export DSPLIB_C66_INSTALL_DIR_RECIPE = "${installdir}/ti-dsplib-c66x-tree" |
53 | export MATHLIB_C66_INSTALL_DIR_RECIPE = "${installdir}/ti-mathlib-c66x-tree" | ||
53 | 54 | ||
54 | 55 | ||
55 | # This is where the tools will end up in sysroot | 56 | # This is where the tools will end up in sysroot |
@@ -91,6 +92,7 @@ export CCSV6_INSTALL_DIR = "${STAGING_DIR_NATIVE}${CCSV6_INSTALL_DIR_R | |||
91 | export GCC_ARM_NONE_TOOLCHAIN = "${STAGING_DIR_NATIVE}${GCC_ARM_NONE_TOOLCHAIN_RECIPE}" | 92 | export GCC_ARM_NONE_TOOLCHAIN = "${STAGING_DIR_NATIVE}${GCC_ARM_NONE_TOOLCHAIN_RECIPE}" |
92 | export TI_CGT_PRU_INSTALL_DIR = "${STAGING_DIR_NATIVE}${TI_CGT_PRU_INSTALL_DIR_RECIPE}" | 93 | export TI_CGT_PRU_INSTALL_DIR = "${STAGING_DIR_NATIVE}${TI_CGT_PRU_INSTALL_DIR_RECIPE}" |
93 | export DSPLIB_C66_INSTALL_DIR = "${STAGING_DIR_TARGET}${DSPLIB_C66_INSTALL_DIR_RECIPE}" | 94 | export DSPLIB_C66_INSTALL_DIR = "${STAGING_DIR_TARGET}${DSPLIB_C66_INSTALL_DIR_RECIPE}" |
95 | export MATHLIB_C66_INSTALL_DIR = "${STAGING_DIR_TARGET}${MATHLIB_C66_INSTALL_DIR_RECIPE}" | ||
94 | 96 | ||
95 | DSPSUFFIX_omapl137 = "x674" | 97 | DSPSUFFIX_omapl137 = "x674" |
96 | DSPSUFFIX_omapl138 = "x674" | 98 | DSPSUFFIX_omapl138 = "x674" |
diff --git a/recipes-ti/mathlib/mathlib-c66x.inc b/recipes-ti/mathlib/mathlib-c66x.inc new file mode 100644 index 00000000..1511337e --- /dev/null +++ b/recipes-ti/mathlib/mathlib-c66x.inc | |||
@@ -0,0 +1,28 @@ | |||
1 | DESCRIPTION = "MATHLIB contains optimized general-purpose signal-processing routines for TI DSPs" | ||
2 | HOMEPAGE = "http://www.ti.com/tool/mathlib" | ||
3 | SECTION = "devel" | ||
4 | LICENSE = "BSD-3-Clause" | ||
5 | |||
6 | require ../includes/ti-paths.inc | ||
7 | require ../includes/ti-staging.inc | ||
8 | require ../includes/ti-unpack.inc | ||
9 | |||
10 | COMPATIBLE_MACHINE = "omap-a15|keystone" | ||
11 | |||
12 | SRC_URI = "http://software-dl.ti.com/sdoemb/sdoemb_public_sw/mathlib/${PV}/exports/${BINFILE};name=mathlib" | ||
13 | |||
14 | S = "${WORKDIR}/mathlib-c66x-${PV}" | ||
15 | |||
16 | BINFILE = "mathlib_c66x_${PV}_Linux.bin" | ||
17 | TI_BIN_UNPK_ARGS = "--mode silent --prefix ${S}" | ||
18 | TI_BIN_UNPK_CMDS = "" | ||
19 | |||
20 | do_install() { | ||
21 | install -d ${D}${MATHLIB_C66_INSTALL_DIR_RECIPE} | ||
22 | cp -pPrf ${S}/* ${D}${MATHLIB_C66_INSTALL_DIR_RECIPE} | ||
23 | } | ||
24 | |||
25 | ALLOW_EMPTY_${PN} = "1" | ||
26 | FILES_${PN}-dev += "${MATHLIB_C66_INSTALL_DIR_RECIPE}" | ||
27 | |||
28 | INSANE_SKIP_${PN}-dev = "arch" | ||
diff --git a/recipes-ti/mathlib/mathlib-c66x_3.1.1.0.bb b/recipes-ti/mathlib/mathlib-c66x_3.1.1.0.bb new file mode 100644 index 00000000..50746fb9 --- /dev/null +++ b/recipes-ti/mathlib/mathlib-c66x_3.1.1.0.bb | |||
@@ -0,0 +1,9 @@ | |||
1 | require mathlib-c66x.inc | ||
2 | |||
3 | PV = "3_1_1_0" | ||
4 | PR = "r1" | ||
5 | |||
6 | LIC_FILES_CHKSUM = "file://packages/ti/mathlib/mathlib.h;beginline=9;endline=35;md5=954ed7074e987be574989f985f1897db" | ||
7 | |||
8 | SRC_URI[mathlib.md5sum] = "f3c9ad06dfcea780b5362c57a4bc48b8" | ||
9 | SRC_URI[mathlib.sha256sum] = "85df897c94e8768e9a1f186c21702ed3887d39cda6dc67cb4580fa3f083e8925" | ||