diff options
author | Koen Kooi <koen@dominion.thruhere.net> | 2011-11-03 16:00:44 +0100 |
---|---|---|
committer | Koen Kooi <koen@dominion.thruhere.net> | 2011-11-03 16:00:44 +0100 |
commit | 7f33ca1fd48f2ee0b67f8244d81e95486bdc31ea (patch) | |
tree | 20a282c101c789d2d29dd514055ed2e27a04a2bf /recipes-ti | |
parent | 234e6c7d8c99df51a5eef2f1a73ae65fb20c7667 (diff) | |
download | meta-ti-7f33ca1fd48f2ee0b67f8244d81e95486bdc31ea.tar.gz |
matrix-gui 2.0: remove initscript, lighttpd takes care of that now
Also get rid of browser dependency, it's not needed for the server to work
Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
Diffstat (limited to 'recipes-ti')
-rw-r--r-- | recipes-ti/matrix/matrix-gui/matrix-gui.service | 10 | ||||
-rw-r--r-- | recipes-ti/matrix/matrix-gui_2.0.bb | 17 |
2 files changed, 3 insertions, 24 deletions
diff --git a/recipes-ti/matrix/matrix-gui/matrix-gui.service b/recipes-ti/matrix/matrix-gui/matrix-gui.service deleted file mode 100644 index cc606194..00000000 --- a/recipes-ti/matrix/matrix-gui/matrix-gui.service +++ /dev/null | |||
@@ -1,10 +0,0 @@ | |||
1 | [Unit] | ||
2 | Description=Texas Instruments Matrix GUI | ||
3 | ConditionPathExists=|__MATRIX_BASE_DIR__ | ||
4 | |||
5 | [Service] | ||
6 | WorkingDirectory=__MATRIX_BASE_DIR__ | ||
7 | ExecStart=/usr/bin/node -- server.js | ||
8 | |||
9 | [Install] | ||
10 | WantedBy=multi-user.target | ||
diff --git a/recipes-ti/matrix/matrix-gui_2.0.bb b/recipes-ti/matrix/matrix-gui_2.0.bb index a0965d57..dde76eef 100644 --- a/recipes-ti/matrix/matrix-gui_2.0.bb +++ b/recipes-ti/matrix/matrix-gui_2.0.bb | |||
@@ -6,15 +6,14 @@ LIC_FILES_CHKSUM = "file://scripts/jquery-1.6.2.min.js;md5=a1a8cb16a060f6280a767 | |||
6 | 6 | ||
7 | SECTION = "multimedia" | 7 | SECTION = "multimedia" |
8 | 8 | ||
9 | PR = "r3" | 9 | PR = "r4" |
10 | 10 | ||
11 | inherit allarch | 11 | inherit allarch |
12 | 12 | ||
13 | BRANCH ?= "master" | 13 | BRANCH ?= "master" |
14 | SRCREV = "8e2bd5ffdded23bb662476fcd2490fa1526801f8" | 14 | SRCREV = "8e2bd5ffdded23bb662476fcd2490fa1526801f8" |
15 | 15 | ||
16 | SRC_URI = "git://gitorious.org/matrix-gui-v2/matrix-gui-v2.git;protocol=git;branch=${BRANCH} \ | 16 | SRC_URI = "git://gitorious.org/matrix-gui-v2/matrix-gui-v2.git;protocol=git;branch=${BRANCH}" |
17 | file://matrix-gui.service" | ||
18 | 17 | ||
19 | require matrix-gui-paths.inc | 18 | require matrix-gui-paths.inc |
20 | 19 | ||
@@ -27,18 +26,8 @@ do_install(){ | |||
27 | 26 | ||
28 | # Install our php.ini file | 27 | # Install our php.ini file |
29 | install -m 0644 ${WORKDIR}/php.ini ${D}${MATRIX_BASE_DIR}/ | 28 | install -m 0644 ${WORKDIR}/php.ini ${D}${MATRIX_BASE_DIR}/ |
30 | |||
31 | # Set the proper path in the init script | ||
32 | sed -i -e s=__MATRIX_WEB_DIR__=${MATRIX_WEB_DIR}=g ${WORKDIR}/matrix-gui.service | ||
33 | |||
34 | install -d ${D}${base_libdir}/systemd/system/ | ||
35 | install -m 0755 ${WORKDIR}/matrix-gui.service ${D}${base_libdir}/systemd/system/ | ||
36 | |||
37 | # activate it on first boot | ||
38 | install -d ${D}${base_libdir}/systemd/system/multi-user.target.wants | ||
39 | ln -sf ../matrix-gui.service ${D}${base_libdir}/systemd/system/multi-user.target.wants/ | ||
40 | } | 29 | } |
41 | 30 | ||
42 | RDEPENDS_${PN} += "lighttpd lighttpd-module-cgi lighttpd-module-compress lighttpd-module-expire php php-cgi php-cli matrix-gui-browser" | 31 | RDEPENDS_${PN} += "lighttpd lighttpd-module-cgi lighttpd-module-compress lighttpd-module-expire php php-cgi php-cli" |
43 | 32 | ||
44 | FILES_${PN} += "${MATRIX_BASE_DIR}/*" | 33 | FILES_${PN} += "${MATRIX_BASE_DIR}/*" |