diff options
author | Peter A. Bigot <bigotp@acm.org> | 2011-12-27 18:51:58 -0600 |
---|---|---|
committer | Koen Kooi <koen@dominion.thruhere.net> | 2011-12-29 10:03:11 +0100 |
commit | 47eebd34728bf2edb38548024b3161e59643f53e (patch) | |
tree | b763f32130cc75d1294d450a834529299979a01c /recipes-ti | |
parent | 104b1fca33b731622ed31ad76aacb00595b9b206 (diff) | |
download | meta-ti-47eebd34728bf2edb38548024b3161e59643f53e.tar.gz |
ti-codec-engine: work around XDC runtime error
do_compile produces:
js: "/prj/oe/bb/build/tmp-eglibc/work/beagleboard-angstrom-linux-gnueabi/ti-codec-engine-2_26_02_11-r114a/codec_engine_2_26_02_11/packages/ti/sdo/ce/osal/linux/package.xs", line 50: XDC runtime error: gnu.targets.arm.GCArmv5T: '$used' is sealed
Fix comments out the conditional check per suggestion in
http://e2e.ti.com/support/dsp/omap_applications_processors/f/447/t/110920.aspx
Signed-off-by: Peter A. Bigot <bigotp@acm.org>
Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
Diffstat (limited to 'recipes-ti')
-rw-r--r-- | recipes-ti/codec-engine/ti-codec-engine/bypass-GCArmv5T-used-is-sealed.patch | 22 | ||||
-rw-r--r-- | recipes-ti/codec-engine/ti-codec-engine_2.26.02.11.bb | 3 |
2 files changed, 25 insertions, 0 deletions
diff --git a/recipes-ti/codec-engine/ti-codec-engine/bypass-GCArmv5T-used-is-sealed.patch b/recipes-ti/codec-engine/ti-codec-engine/bypass-GCArmv5T-used-is-sealed.patch new file mode 100644 index 00000000..b93161f4 --- /dev/null +++ b/recipes-ti/codec-engine/ti-codec-engine/bypass-GCArmv5T-used-is-sealed.patch | |||
@@ -0,0 +1,22 @@ | |||
1 | do_compile produces: | ||
2 | |||
3 | js: "/prj/oe/bb/build/tmp-eglibc/work/beagleboard-angstrom-linux-gnueabi/ti-codec-engine-2_26_02_11-r114a/codec_engine_2_26_02_11/packages/ti/sdo/ce/osal/linux/package.xs", line 50: XDC runtime error: gnu.targets.arm.GCArmv5T: '$used' is sealed | ||
4 | |||
5 | Fix per suggestion in http://e2e.ti.com/support/dsp/omap_applications_processors/f/447/t/110920.aspx | ||
6 | |||
7 | --- ./packages/ti/sdo/ce/osal/linux/package.xs.orig 2010-12-01 23:24:48.000000000 -0600 | ||
8 | +++ ./packages/ti/sdo/ce/osal/linux/package.xs 2011-12-27 14:59:39.382423341 -0600 | ||
9 | @@ -47,10 +47,10 @@ | ||
10 | } | ||
11 | |||
12 | /* Conditionally load CMEM here */ | ||
13 | - var targetMod = xdc.useModule(prog.build.target.$name); | ||
14 | - if ((":"+targetMod.getISAChain().join(":")+":").match(/:v5T:/i)) { | ||
15 | + //var targetMod = xdc.useModule(prog.build.target.$name); | ||
16 | + //if ((":"+targetMod.getISAChain().join(":")+":").match(/:v5T:/i)) { | ||
17 | xdc.useModule('ti.sdo.linuxutils.cmem.CMEM'); | ||
18 | - } | ||
19 | + //} | ||
20 | |||
21 | var osalGlobal = xdc.useModule('ti.sdo.ce.osal.Global'); | ||
22 | |||
diff --git a/recipes-ti/codec-engine/ti-codec-engine_2.26.02.11.bb b/recipes-ti/codec-engine/ti-codec-engine_2.26.02.11.bb index 2c4b4a19..e66fa4a5 100644 --- a/recipes-ti/codec-engine/ti-codec-engine_2.26.02.11.bb +++ b/recipes-ti/codec-engine/ti-codec-engine_2.26.02.11.bb | |||
@@ -2,6 +2,9 @@ require ti-codec-engine.inc | |||
2 | 2 | ||
3 | LIC_FILES_CHKSUM = "file://codec_engine_${PV}_manifest.html;md5=912535f1b02ecf329a3979bf313f91e0" | 3 | LIC_FILES_CHKSUM = "file://codec_engine_${PV}_manifest.html;md5=912535f1b02ecf329a3979bf313f91e0" |
4 | PV = "2_26_02_11" | 4 | PV = "2_26_02_11" |
5 | PR_append = "1" | ||
6 | |||
7 | SRC_URI += "file://bypass-GCArmv5T-used-is-sealed.patch" | ||
5 | 8 | ||
6 | SRC_URI[cetarball.md5sum] = "4f755f77119e4da19ab5cc7ae7ccfdb4" | 9 | SRC_URI[cetarball.md5sum] = "4f755f77119e4da19ab5cc7ae7ccfdb4" |
7 | SRC_URI[cetarball.sha256sum] = "17fa053719265e0901fe3c3f90c9204957c6d0f5351d6b3ba4900df58cb7300f" | 10 | SRC_URI[cetarball.sha256sum] = "17fa053719265e0901fe3c3f90c9204957c6d0f5351d6b3ba4900df58cb7300f" |