summaryrefslogtreecommitdiffstats
path: root/recipes-ti
diff options
context:
space:
mode:
authorJacob Stiffler <j-stiffler@ti.com>2015-06-05 16:56:29 +0000
committerDenys Dmytriyenko <denys@ti.com>2015-06-05 10:17:40 -0400
commit147aeb445c891b70dd468dee00420a22e26a58e4 (patch)
tree2d1396f5b770d869e92d76e6b6c547426695408a /recipes-ti
parentedbe41e86b62377c18cc68647c808e4dd269bdfb (diff)
downloadmeta-ti-147aeb445c891b70dd468dee00420a22e26a58e4.tar.gz
rtos-recipes: Add files to ${PN}-dev instead of ${PN}.
* These packages only contain firmware development files. Signed-off-by: Jacob Stiffler <j-stiffler@ti.com> Signed-off-by: Denys Dmytriyenko <denys@ti.com>
Diffstat (limited to 'recipes-ti')
-rw-r--r--recipes-ti/bios/ti-sysbios.inc4
-rw-r--r--recipes-ti/bios/ti-sysbios_6.41.02.41.bb4
-rw-r--r--recipes-ti/framework-components/ti-framework-components.inc3
-rw-r--r--recipes-ti/framework-components/ti-framework-components_3.40.00.02.bb2
-rw-r--r--recipes-ti/ipc/ti-ipc-rtos.inc3
-rw-r--r--recipes-ti/ipc/ti-ipc-rtos_3.36.01.11.bb1
-rw-r--r--recipes-ti/xdais/ti-xdais.inc5
-rw-r--r--recipes-ti/xdais/ti-xdais_7.24.00.04.bb3
8 files changed, 17 insertions, 8 deletions
diff --git a/recipes-ti/bios/ti-sysbios.inc b/recipes-ti/bios/ti-sysbios.inc
index d04a1581..c44fec32 100644
--- a/recipes-ti/bios/ti-sysbios.inc
+++ b/recipes-ti/bios/ti-sysbios.inc
@@ -19,3 +19,7 @@ do_install() {
19 cp -pPrf ${S}/* ${D}${SYSBIOS_INSTALL_DIR_RECIPE} 19 cp -pPrf ${S}/* ${D}${SYSBIOS_INSTALL_DIR_RECIPE}
20} 20}
21 21
22ALLOW_EMPTY_${PN} = "1"
23FILES_${PN}-dev += "${SYSBIOS_INSTALL_DIR_RECIPE}"
24
25INSANE_SKIP_${PN}-dev = "arch ldflags staticdev"
diff --git a/recipes-ti/bios/ti-sysbios_6.41.02.41.bb b/recipes-ti/bios/ti-sysbios_6.41.02.41.bb
index fcad0861..ccc6ad19 100644
--- a/recipes-ti/bios/ti-sysbios_6.41.02.41.bb
+++ b/recipes-ti/bios/ti-sysbios_6.41.02.41.bb
@@ -1,7 +1,7 @@
1require ti-sysbios.inc 1require ti-sysbios.inc
2 2
3PV = "6_41_02_41" 3PV = "6_41_02_41"
4PR = "r0" 4PR = "r1"
5 5
6LIC_FILES_CHKSUM = "file://bios_${PV}_manifest.html;md5=a4af75ec6d586c5267c71075eebff418" 6LIC_FILES_CHKSUM = "file://bios_${PV}_manifest.html;md5=a4af75ec6d586c5267c71075eebff418"
7 7
@@ -10,5 +10,3 @@ SRC_URI[sysbiosbin.sha256sum] = "2c47b4a3aa9513d10e5811a8ac7ed1d6ce3d13df57a0bff
10 10
11TI_BIN_UNPK_CMDS="" 11TI_BIN_UNPK_CMDS=""
12TI_BIN_UNPK_ARGS = "--mode unattended --prefix ${WORKDIR}" 12TI_BIN_UNPK_ARGS = "--mode unattended --prefix ${WORKDIR}"
13
14INSANE_SKIP_${PN} = "installed-vs-shipped"
diff --git a/recipes-ti/framework-components/ti-framework-components.inc b/recipes-ti/framework-components/ti-framework-components.inc
index b8d3f7c3..e111ec45 100644
--- a/recipes-ti/framework-components/ti-framework-components.inc
+++ b/recipes-ti/framework-components/ti-framework-components.inc
@@ -17,4 +17,5 @@ do_install() {
17 17
18INSANE_SKIP_${PN} = "ldflags" 18INSANE_SKIP_${PN} = "ldflags"
19 19
20FILES_${PN} += "${FC_INSTALL_DIR_RECIPE}" 20ALLOW_EMPTY_${PN} = "1"
21FILES_${PN}-dev += "${FC_INSTALL_DIR_RECIPE}"
diff --git a/recipes-ti/framework-components/ti-framework-components_3.40.00.02.bb b/recipes-ti/framework-components/ti-framework-components_3.40.00.02.bb
index 2dd8548b..78f764d1 100644
--- a/recipes-ti/framework-components/ti-framework-components_3.40.00.02.bb
+++ b/recipes-ti/framework-components/ti-framework-components_3.40.00.02.bb
@@ -1,7 +1,7 @@
1require ti-framework-components.inc 1require ti-framework-components.inc
2 2
3PV = "3_40_00_02" 3PV = "3_40_00_02"
4PR = "r0" 4PR = "r1"
5 5
6LIC_FILES_CHKSUM = "file://framework_components_${PV}_Manifest.html;md5=e3ce0b3e17175b7200f346d0c6dbbcc6" 6LIC_FILES_CHKSUM = "file://framework_components_${PV}_Manifest.html;md5=e3ce0b3e17175b7200f346d0c6dbbcc6"
7 7
diff --git a/recipes-ti/ipc/ti-ipc-rtos.inc b/recipes-ti/ipc/ti-ipc-rtos.inc
index fe179f5a..d14c7567 100644
--- a/recipes-ti/ipc/ti-ipc-rtos.inc
+++ b/recipes-ti/ipc/ti-ipc-rtos.inc
@@ -15,4 +15,5 @@ do_install() {
15 cp -pPrf ${S}/* ${D}${IPC_INSTALL_DIR_RECIPE} 15 cp -pPrf ${S}/* ${D}${IPC_INSTALL_DIR_RECIPE}
16} 16}
17 17
18FILES_${PN} += "${IPC_INSTALL_DIR_RECIPE}" 18ALLOW_EMPTY_${PN} = "1"
19FILES_${PN}-dev += "${IPC_INSTALL_DIR_RECIPE}"
diff --git a/recipes-ti/ipc/ti-ipc-rtos_3.36.01.11.bb b/recipes-ti/ipc/ti-ipc-rtos_3.36.01.11.bb
index 07a81363..e3f64b74 100644
--- a/recipes-ti/ipc/ti-ipc-rtos_3.36.01.11.bb
+++ b/recipes-ti/ipc/ti-ipc-rtos_3.36.01.11.bb
@@ -1,6 +1,7 @@
1require ti-ipc-rtos.inc 1require ti-ipc-rtos.inc
2 2
3PV = "3_36_01_11" 3PV = "3_36_01_11"
4PR = "r1"
4 5
5LIC_FILES_CHKSUM = "file://${S}/ipc-linux.mak;beginline=1;endline=30;md5=7b327f9b710fd7c95e545b91cec79255" 6LIC_FILES_CHKSUM = "file://${S}/ipc-linux.mak;beginline=1;endline=30;md5=7b327f9b710fd7c95e545b91cec79255"
6 7
diff --git a/recipes-ti/xdais/ti-xdais.inc b/recipes-ti/xdais/ti-xdais.inc
index 2e7eb13e..a7017e75 100644
--- a/recipes-ti/xdais/ti-xdais.inc
+++ b/recipes-ti/xdais/ti-xdais.inc
@@ -14,3 +14,8 @@ do_install() {
14 install -d ${D}${XDAIS_INSTALL_DIR_RECIPE} 14 install -d ${D}${XDAIS_INSTALL_DIR_RECIPE}
15 cp -pPrf ${S}/* ${D}${XDAIS_INSTALL_DIR_RECIPE} 15 cp -pPrf ${S}/* ${D}${XDAIS_INSTALL_DIR_RECIPE}
16} 16}
17
18INSANE_SKIP_${PN}-dev = "arch"
19
20ALLOW_EMPTY_${PN} = "1"
21FILES_${PN}-dev += "${XDAIS_INSTALL_DIR_RECIPE}"
diff --git a/recipes-ti/xdais/ti-xdais_7.24.00.04.bb b/recipes-ti/xdais/ti-xdais_7.24.00.04.bb
index 0f275144..8148f73a 100644
--- a/recipes-ti/xdais/ti-xdais_7.24.00.04.bb
+++ b/recipes-ti/xdais/ti-xdais_7.24.00.04.bb
@@ -1,10 +1,9 @@
1require ti-xdais.inc 1require ti-xdais.inc
2 2
3PV = "7_24_00_04" 3PV = "7_24_00_04"
4PR = "r1"
4 5
5LIC_FILES_CHKSUM = "file://xdais_7_24_00_04_Manifest.html;md5=fd16442230745f0877cfe1c622669fd6" 6LIC_FILES_CHKSUM = "file://xdais_7_24_00_04_Manifest.html;md5=fd16442230745f0877cfe1c622669fd6"
6 7
7SRC_URI[xdaistarball.md5sum] = "f7514085b531f2ae49b37b30194e4989" 8SRC_URI[xdaistarball.md5sum] = "f7514085b531f2ae49b37b30194e4989"
8SRC_URI[xdaistarball.sha256sum] = "79fd30377ab4c497292aeefb0565f81703d9020d1242b02ca9968c561e0de9a1" 9SRC_URI[xdaistarball.sha256sum] = "79fd30377ab4c497292aeefb0565f81703d9020d1242b02ca9968c561e0de9a1"
9
10INSANE_SKIP_${PN} = "installed-vs-shipped"