summaryrefslogtreecommitdiffstats
path: root/recipes-ti
diff options
context:
space:
mode:
authorYogesh Siraswar <yogeshs@ti.com>2021-11-16 10:39:22 +0000
committerYogesh Siraswar <yogeshs@ti.com>2021-11-16 11:14:52 +0000
commit3f15773534e453675bfea5806fbcff40c6a7b6a7 (patch)
treef6aecdb79c2dcad55f9d96d5c58f45c988cd4744 /recipes-ti
parent926e364877e0fb5f3126db9a5bf81ba9e7b8a258 (diff)
downloadmeta-ti-3f15773534e453675bfea5806fbcff40c6a7b6a7.tar.gz
ti-rtos-firmware: Add j7200 hs support
We cannot use j7200 keyword for match b'n j7200-evm and j7200-hs-evm due to existing j7 keyword, we need to duplicate all the j7200 entries for hs. Also sign the DM firmware for J7200 similar to J7 HS Signed-off-by: Yogesh Siraswar <yogeshs@ti.com>
Diffstat (limited to 'recipes-ti')
-rw-r--r--recipes-ti/ti-rtos-bin/ti-rtos-firmware.bb34
1 files changed, 34 insertions, 0 deletions
diff --git a/recipes-ti/ti-rtos-bin/ti-rtos-firmware.bb b/recipes-ti/ti-rtos-bin/ti-rtos-firmware.bb
index ea69ad89..6d24f7fe 100644
--- a/recipes-ti/ti-rtos-bin/ti-rtos-firmware.bb
+++ b/recipes-ti/ti-rtos-bin/ti-rtos-firmware.bb
@@ -15,6 +15,7 @@ inherit update-alternatives
15PLAT_SFX = "" 15PLAT_SFX = ""
16PLAT_SFX_j7 = "j721e" 16PLAT_SFX_j7 = "j721e"
17PLAT_SFX_j7200-evm = "j7200" 17PLAT_SFX_j7200-evm = "j7200"
18PLAT_SFX_j7200-hs-evm = "j7200"
18PLAT_SFX_am65xx = "am65xx" 19PLAT_SFX_am65xx = "am65xx"
19PLAT_SFX_am64xx = "am64xx" 20PLAT_SFX_am64xx = "am64xx"
20 21
@@ -55,6 +56,15 @@ do_install_prepend_j7-hs-evm() {
55 ) 56 )
56} 57}
57 58
59# J7 HS support
60do_install_prepend_j7200-hs-evm() {
61 export TI_SECURE_DEV_PKG=${TI_SECURE_DEV_PKG}
62 ( cd ${RTOS_DM_FW_DIR}; \
63 mv ${DM_FIRMWARE} ${DM_FIRMWARE}.unsigned; \
64 ${TI_SECURE_DEV_PKG}/scripts/secure-binary-image.sh ${DM_FIRMWARE}.unsigned ${DM_FIRMWARE}; \
65 )
66}
67
58# Update the am64xx ipc binaries to be consistent with other platforms 68# Update the am64xx ipc binaries to be consistent with other platforms
59do_install_prepend_am64xx() { 69do_install_prepend_am64xx() {
60 ( cd ${RTOS_IPC_FW_DIR}; \ 70 ( cd ${RTOS_IPC_FW_DIR}; \
@@ -100,6 +110,18 @@ do_install_j7200-evm() {
100 install -m 0644 ${RTOS_ETH_FW_DIR}/app_remoteswitchcfg_server_strip.xer5f ${LEGACY_ETH_FW_DIR} 110 install -m 0644 ${RTOS_ETH_FW_DIR}/app_remoteswitchcfg_server_strip.xer5f ${LEGACY_ETH_FW_DIR}
101} 111}
102 112
113do_install_j7200-hs-evm() {
114 install -d ${LEGACY_IPC_FW_DIR}
115 install -m 0644 ${RTOS_IPC_FW_DIR}/ipc_echo_test_mcu1_1_release_strip.xer5f ${LEGACY_IPC_FW_DIR}
116 install -m 0644 ${RTOS_IPC_FW_DIR}/ipc_echo_test_mcu2_0_release_strip.xer5f ${LEGACY_IPC_FW_DIR}
117 install -m 0644 ${RTOS_IPC_FW_DIR}/ipc_echo_test_mcu2_1_release_strip.xer5f ${LEGACY_IPC_FW_DIR}
118 # DM Firmware
119 install -m 0644 ${RTOS_DM_FW_DIR}/ipc_echo_testb_mcu1_0_release_strip.xer5f ${LEGACY_DM_FW_DIR}
120 # ETH firmware
121 install -d ${LEGACY_ETH_FW_DIR}
122 install -m 0644 ${RTOS_ETH_FW_DIR}/app_remoteswitchcfg_server_strip.xer5f ${LEGACY_ETH_FW_DIR}
123}
124
103do_install_am65xx() { 125do_install_am65xx() {
104 install -d ${LEGACY_IPC_FW_DIR} 126 install -d ${LEGACY_IPC_FW_DIR}
105 install -m 0644 ${RTOS_IPC_FW_DIR}/ipc_echo_test_mcu1_0_release_strip.xer5f ${LEGACY_IPC_FW_DIR} 127 install -m 0644 ${RTOS_IPC_FW_DIR}/ipc_echo_test_mcu1_0_release_strip.xer5f ${LEGACY_IPC_FW_DIR}
@@ -148,6 +170,13 @@ ALTERNATIVE_${PN}_j7200-evm = "\
148 j7200-main-r5f0_1-fw \ 170 j7200-main-r5f0_1-fw \
149 " 171 "
150 172
173ALTERNATIVE_${PN}_j7200-hs-evm = "\
174 j7200-mcu-r5f0_0-fw \
175 j7200-mcu-r5f0_1-fw \
176 j7200-main-r5f0_0-fw \
177 j7200-main-r5f0_1-fw \
178 "
179
151# Set up link names for the firmwares 180# Set up link names for the firmwares
152 181
153TARGET_MCU_R5FSS0_0_am65xx = "am65x-mcu-r5f0_0-fw" 182TARGET_MCU_R5FSS0_0_am65xx = "am65x-mcu-r5f0_0-fw"
@@ -174,6 +203,11 @@ TARGET_MCU_R5FSS0_1_j7200-evm = "j7200-mcu-r5f0_1-fw"
174TARGET_MAIN_R5FSS0_0_j7200-evm = "j7200-main-r5f0_0-fw" 203TARGET_MAIN_R5FSS0_0_j7200-evm = "j7200-main-r5f0_0-fw"
175TARGET_MAIN_R5FSS0_1_j7200-evm = "j7200-main-r5f0_1-fw" 204TARGET_MAIN_R5FSS0_1_j7200-evm = "j7200-main-r5f0_1-fw"
176 205
206TARGET_MCU_R5FSS0_0_j7200-hs-evm = "j7200-mcu-r5f0_0-fw"
207TARGET_MCU_R5FSS0_1_j7200-hs-evm = "j7200-mcu-r5f0_1-fw"
208TARGET_MAIN_R5FSS0_0_j7200-hs-evm = "j7200-main-r5f0_0-fw"
209TARGET_MAIN_R5FSS0_1_j7200-hs-evm = "j7200-main-r5f0_1-fw"
210
177ALTERNATIVE_LINK_NAME[am65x-mcu-r5f0_0-fw] = "${base_libdir}/firmware/${TARGET_MCU_R5FSS0_0}" 211ALTERNATIVE_LINK_NAME[am65x-mcu-r5f0_0-fw] = "${base_libdir}/firmware/${TARGET_MCU_R5FSS0_0}"
178ALTERNATIVE_LINK_NAME[am65x-mcu-r5f0_1-fw] = "${base_libdir}/firmware/${TARGET_MCU_R5FSS0_1}" 212ALTERNATIVE_LINK_NAME[am65x-mcu-r5f0_1-fw] = "${base_libdir}/firmware/${TARGET_MCU_R5FSS0_1}"
179 213