summaryrefslogtreecommitdiffstats
path: root/recipes-ti
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denys@konsulko.com>2021-04-03 06:09:54 +0000
committerPraneeth Bajjuri <praneeth@ti.com>2021-04-05 23:06:20 -0500
commitaf3d951506830aca8c576131b554c6db35e7c235 (patch)
tree8f551c9ac1bd35a5ac56388f775e3457a17e413a /recipes-ti
parentd838f3bffe39f0bc7d56f9752311b6ebff65796e (diff)
downloadmeta-ti-af3d951506830aca8c576131b554c6db35e7c235.tar.gz
ti-ipc-examples: fix deprecation of sys_errlist[] in glibc
It was giving this warning for years, finally gone: | warning: `sys_errlist' is deprecated; use `strerror' or `strerror_r' instead Signed-off-by: Denys Dmytriyenko <denys@konsulko.com> Cc: Suman Anna <s-anna@ti.com>
Diffstat (limited to 'recipes-ti')
-rw-r--r--recipes-ti/ipc/ti-ipc-examples-linux/0001-examples-ClusterMgr-sys_errlist-has-been-deprecated-.patch40
-rw-r--r--recipes-ti/ipc/ti-ipc-examples-linux_git.bb2
2 files changed, 42 insertions, 0 deletions
diff --git a/recipes-ti/ipc/ti-ipc-examples-linux/0001-examples-ClusterMgr-sys_errlist-has-been-deprecated-.patch b/recipes-ti/ipc/ti-ipc-examples-linux/0001-examples-ClusterMgr-sys_errlist-has-been-deprecated-.patch
new file mode 100644
index 00000000..ea514695
--- /dev/null
+++ b/recipes-ti/ipc/ti-ipc-examples-linux/0001-examples-ClusterMgr-sys_errlist-has-been-deprecated-.patch
@@ -0,0 +1,40 @@
1From cca4fd812959a0cd241dd3bbebfd461ece94c9b8 Mon Sep 17 00:00:00 2001
2From: Denys Dmytriyenko <denis@denix.org>
3Date: Mon, 29 Mar 2021 19:42:00 -0400
4Subject: [PATCH] examples/ClusterMgr: sys_errlist[] has been deprecated in
5 glibc
6
7Use strerror() instead.
8
9Upstream-Status: Pending
10
11Signed-off-by: Denys Dmytriyenko <denis@denix.org>
12---
13 src/examples/templates/ex46_graph/manager/ClusterMgr.c | 4 ++--
14 1 file changed, 2 insertions(+), 2 deletions(-)
15
16diff --git a/src/examples/templates/ex46_graph/manager/ClusterMgr.c b/src/examples/templates/ex46_graph/manager/ClusterMgr.c
17index 19216c9..a1fa679 100644
18--- a/src/examples/templates/ex46_graph/manager/ClusterMgr.c
19+++ b/src/examples/templates/ex46_graph/manager/ClusterMgr.c
20@@ -714,7 +714,7 @@ static pid_t ClusterMgr_system(char *cmd, bool wait)
21 pid = fork();
22
23 if (pid == -1) {
24- LOG "CM_system: fork error: %s\n", sys_errlist[errno] LOGF
25+ LOG "CM_system: fork error: %s\n", strerror(errno) LOGF
26 status = -1;
27 goto leave;
28 }
29@@ -739,7 +739,7 @@ static pid_t ClusterMgr_system(char *cmd, bool wait)
30 else {
31 /* overlay a new executable */
32 execvp(argv[0], argv);
33- LOG "CM_system: execvp error: %s\n", sys_errlist[errno] LOGF
34+ LOG "CM_system: execvp error: %s\n", strerror(errno) LOGF
35 status = -1;
36 }
37
38--
392.7.4
40
diff --git a/recipes-ti/ipc/ti-ipc-examples-linux_git.bb b/recipes-ti/ipc/ti-ipc-examples-linux_git.bb
index 471d7ff2..ab479556 100644
--- a/recipes-ti/ipc/ti-ipc-examples-linux_git.bb
+++ b/recipes-ti/ipc/ti-ipc-examples-linux_git.bb
@@ -1,6 +1,8 @@
1DESCRIPTION = "TI Inter Process Communication (IPC) examples with Host running bios" 1DESCRIPTION = "TI Inter Process Communication (IPC) examples with Host running bios"
2require ti-ipc-examples.inc 2require ti-ipc-examples.inc
3 3
4SRC_URI += "file://0001-examples-ClusterMgr-sys_errlist-has-been-deprecated-.patch;patchdir=../git/ipc-examples"
5
4DEPENDS = "ti-ipc ti-xdctools-native ti-sysbios ti-ipc-rtos zip-native" 6DEPENDS = "ti-ipc ti-xdctools-native ti-sysbios ti-ipc-rtos zip-native"
5 7
6do_compile_append() { 8do_compile_append() {