diff options
author | Praneeth Bajjuri <praneeth@ti.com> | 2021-03-27 00:14:52 +0000 |
---|---|---|
committer | Yogesh Siraswar <yogeshs@ti.com> | 2021-07-13 16:43:48 +0000 |
commit | 9ada213d1e7ad90e5a3b73c21fec24f57e6b0601 (patch) | |
tree | b6a26b519d2395c9ac8940618af008129ea11602 /recipes-ti | |
parent | d54da744941ff97f2502bad2d7c51c5387bde929 (diff) | |
download | meta-ti-9ada213d1e7ad90e5a3b73c21fec24f57e6b0601.tar.gz |
ti-rtos-firmware: sign DM firmware for J721e HS platform
U-boot build process requires DM firmware to be signed for J7 HS.
It's better for ti-rtos-firmware package (that delivers DM firmware) to sign
it once and provide signed version to other packages, instead of U-boot needing
to re-sign it during build in staging location.
Signed-off-by: Praneeth Bajjuri <praneeth@ti.com>
Signed-off-by: Denys Dmytriyenko <denys@konsulko.com>
Diffstat (limited to 'recipes-ti')
-rw-r--r-- | recipes-ti/ti-rtos-bin/ti-rtos-firmware.bb | 12 |
1 files changed, 12 insertions, 0 deletions
diff --git a/recipes-ti/ti-rtos-bin/ti-rtos-firmware.bb b/recipes-ti/ti-rtos-bin/ti-rtos-firmware.bb index 7fafd516..e5a4c43b 100644 --- a/recipes-ti/ti-rtos-bin/ti-rtos-firmware.bb +++ b/recipes-ti/ti-rtos-bin/ti-rtos-firmware.bb | |||
@@ -76,6 +76,18 @@ DEPENDS += "openssl-native" | |||
76 | 76 | ||
77 | FILES_${PN} += "${base_libdir}" | 77 | FILES_${PN} += "${base_libdir}" |
78 | 78 | ||
79 | TI_SECURE_DEV_PKG ?= "" | ||
80 | |||
81 | DM_FIRMWARE = "ipc_echo_testb_mcu1_0_release_strip.xer5f" | ||
82 | |||
83 | do_install_prepend_j7-hs-evm() { | ||
84 | export TI_SECURE_DEV_PKG=${TI_SECURE_DEV_PKG} | ||
85 | ( cd ${S}/firmware/pdk-ipc/; \ | ||
86 | mv ${DM_FIRMWARE} ${DM_FIRMWARE}.unsigned; \ | ||
87 | ${TI_SECURE_DEV_PKG}/scripts/secure-binary-image.sh ${DM_FIRMWARE}.unsigned ${DM_FIRMWARE}; \ | ||
88 | ) | ||
89 | } | ||
90 | |||
79 | do_install() { | 91 | do_install() { |
80 | CP_ARGS="-Prf --preserve=mode,timestamps --no-preserve=ownership" | 92 | CP_ARGS="-Prf --preserve=mode,timestamps --no-preserve=ownership" |
81 | install -d ${D}${base_libdir} | 93 | install -d ${D}${base_libdir} |