diff options
author | Mahesh Radhakrishnan <m-radhakrishnan2@ti.com> | 2019-08-16 02:22:10 +0000 |
---|---|---|
committer | Denys Dmytriyenko <denys@ti.com> | 2019-08-17 01:01:37 +0000 |
commit | f73afc1ceb4776b9385012aa1cfa35abd284f200 (patch) | |
tree | 482ca4f8927d4e8b33a327586186ea363f2b1744 /recipes-ti | |
parent | e5ddf2550f335118a7f764871843a7918c092b49 (diff) | |
download | meta-ti-f73afc1ceb4776b9385012aa1cfa35abd284f200.tar.gz |
ti-cgt-7x: Initial version of TI-CGT-C7000 recipe
This tool is not publically fetchable yet and requires pre-downloading
Signed-off-by: Mahesh Radhakrishnan <m-radhakrishnan2@ti.com>
Signed-off-by: Denys Dmytriyenko <denys@ti.com>
Diffstat (limited to 'recipes-ti')
-rw-r--r-- | recipes-ti/devtools/ti-cgt7x_1.1.0.bb | 48 |
1 files changed, 48 insertions, 0 deletions
diff --git a/recipes-ti/devtools/ti-cgt7x_1.1.0.bb b/recipes-ti/devtools/ti-cgt7x_1.1.0.bb new file mode 100644 index 00000000..72bbcc12 --- /dev/null +++ b/recipes-ti/devtools/ti-cgt7x_1.1.0.bb | |||
@@ -0,0 +1,48 @@ | |||
1 | SUMMARY = "TI DSP Code Generation Tools" | ||
2 | DESCRIPTION = "Texas Instruments (TI) Code Generation Tools are custom \ | ||
3 | utilities targeted for TI embedded processors. This Digital Signal \ | ||
4 | Processor (DSP) suite contains tools needed to create and debug \ | ||
5 | applications for the C7000 DSP family. This includes tools such as: \ | ||
6 | compiler, linker, assembler, etc. This also includes C runtime \ | ||
7 | libraries and standard header files needed to produce a working DSP application." | ||
8 | HOMEPAGE = "https://www-a.ti.com/downloads/sds_support/TICodegenerationTools/download.htm" | ||
9 | LICENSE = "(TI-TSPA & Thai-Open-Source-Software-Center) & BSD-3-Clause & BSL-1.0 & Patrick-Powell & AFL-3.0 & MIT & BSD-2-Clause & PD" | ||
10 | |||
11 | LIC_FILES_CHKSUM = "file://ti-cgt-c7000_${PV}/C7000_1.0.x_CodeGenerationTools_Manifest.html;md5=3074e433c5d52657076d1d138dfbdaf8" | ||
12 | |||
13 | require recipes-ti/includes/ti-unpack.inc | ||
14 | require recipes-ti/includes/ti-paths.inc | ||
15 | |||
16 | # only x86_64 is supported | ||
17 | COMPATIBLE_HOST = "x86_64.*-linux" | ||
18 | COMPATIBLE_HOST_class-target = "null" | ||
19 | |||
20 | BINFILE = "ti_cgt_c7000_${PV}_linux_installer_x86.bin" | ||
21 | BINFILE_NAME = "cgt7x_x86_installer" | ||
22 | |||
23 | # Please note, "install.source.dir.local" is not a real URL, below files need to be pre-downloaded | ||
24 | SRC_URI = "http://install.source.dir.local/${BINFILE};name=${BINFILE_NAME}" | ||
25 | |||
26 | TI_BIN_UNPK_ARGS = "--prefix ${S}" | ||
27 | TI_BIN_UNPK_CMDS = "" | ||
28 | |||
29 | SRC_URI[cgt7x_x86_installer.md5sum] = "feb668b4213403c661909adcf65d2ba8" | ||
30 | SRC_URI[cgt7x_x86_installer.sha256sum] = "4a3954c973622c00a9b91fa90473cf921f4b763300b0e7c32735304867856ab8" | ||
31 | |||
32 | S = "${WORKDIR}/c7000_${PV}" | ||
33 | |||
34 | do_install() { | ||
35 | install -d ${D}/${TI_CGT7X_INSTALL_DIR_RECIPE} | ||
36 | cp -rP --preserve=mode,links,timestamps --no-preserve=ownership ${WORKDIR}/c7000_${PV}/ti-cgt-c7000_${PV}/. ${D}/${TI_CGT7X_INSTALL_DIR_RECIPE} | ||
37 | } | ||
38 | |||
39 | |||
40 | FILES_${PN} += "${TI_CGT7X_INSTALL_DIR_RECIPE}" | ||
41 | |||
42 | INSANE_SKIP_${PN} += "arch staticdev textrel" | ||
43 | |||
44 | INHIBIT_PACKAGE_STRIP = "1" | ||
45 | INHIBIT_SYSROOT_STRIP = "1" | ||
46 | INHIBIT_PACKAGE_DEBUG_SPLIT = "1" | ||
47 | |||
48 | BBCLASSEXTEND = "native nativesdk" | ||