summaryrefslogtreecommitdiffstats
path: root/recipes-ti
diff options
context:
space:
mode:
authorSam Nelson <sam.nelson@ti.com>2015-02-27 00:08:25 +0000
committerDenys Dmytriyenko <denys@ti.com>2015-02-26 14:04:22 -0500
commit6356441620e29db519a0e4d41af4c9ea8b1a9056 (patch)
tree60063e234e5865e404a0da377f8f499cc7ac6b64 /recipes-ti
parentb490d090a1bb1f7fd0f4ecc507bb4518167ba72d (diff)
downloadmeta-ti-6356441620e29db519a0e4d41af4c9ea8b1a9056.tar.gz
netapi: Add recipe for NETAPI module
- Provide TI user space network library and test code - Supports k2h, k2k, k2l & k2e devices Signed-off-by: Sam Nelson <sam.nelson@ti.com> Signed-off-by: Denys Dmytriyenko <denys@ti.com>
Diffstat (limited to 'recipes-ti')
-rw-r--r--recipes-ti/netapi/netapi-test_git.bb49
-rw-r--r--recipes-ti/netapi/netapi.inc16
-rw-r--r--recipes-ti/netapi/netapi_git.bb32
3 files changed, 97 insertions, 0 deletions
diff --git a/recipes-ti/netapi/netapi-test_git.bb b/recipes-ti/netapi/netapi-test_git.bb
new file mode 100644
index 00000000..9d49c294
--- /dev/null
+++ b/recipes-ti/netapi/netapi-test_git.bb
@@ -0,0 +1,49 @@
1DESCRIPTION = "Provides test and application binaries using NETAPI module"
2COMPATIBLE_MACHINE = "keystone"
3DEPENDS = "netapi ipsecmgr"
4
5include netapi.inc
6
7EXTRA_OEMAKE = "PDK_INSTALL_PATH=${STAGING_INCDIR}"
8
9do_compile () {
10# Build the netapi binaries
11 for device in ${DEVICELIST}
12 do
13 for choice in ${CHOICELIST}
14 do
15 oe_runmake -f makefile_armv7 tests NETAPI_SRC_DIR=${S} NETAPI_INC_DIR=${BASEDIR} \
16 USEDYNAMIC_LIB="$choice" DEVICE="$device"
17 done
18
19# Now build the netapi appplications
20 cd ${S}/applications/ipsec_offload/ipsecmgr/build
21 oe_runmake clean NETAPI_SRC_DIR=${S} DEVICE="$device"
22 oe_runmake app NETAPI_SRC_DIR=${S} DEVICE="$device"
23
24 cd ${S}/applications/ipsec_offload/config-app/build
25 oe_runmake clean DEVICE="$device"
26 oe_runmake app DEVICE="$device"
27 cd ${S}
28 done
29}
30
31do_install () {
32 for device in ${DEVICELIST}
33 do
34 oe_runmake -f makefile_armv7 installbin INSTALL_INC_BASE_DIR=${D}/${includedir} \
35 INSTALL_LIB_BASE_DIR=${D}${libdir} INSTALL_BIN_BASE_DIR=${D}${bindir} \
36 SYSCONFDIR=${D}${sysconfdir} DEVICE="$device"
37
38 cd ${S}/applications/ipsec_offload/ipsecmgr/build
39 oe_runmake install \
40 INSTALL_BIN_BASE_DIR=${D}${bindir} SYSCONFDIR=${D}${sysconfdir} \
41 DEVICE="$device"
42
43 cd ${S}/applications/ipsec_offload/config-app/build
44 oe_runmake install \
45 INSTALL_BIN_BASE_DIR=${D}${bindir} SYSCONFDIR=${D}${sysconfdir} \
46 DEVICE="$device"
47 cd ${S}
48 done
49}
diff --git a/recipes-ti/netapi/netapi.inc b/recipes-ti/netapi/netapi.inc
new file mode 100644
index 00000000..b8d481ab
--- /dev/null
+++ b/recipes-ti/netapi/netapi.inc
@@ -0,0 +1,16 @@
1LICENSE = "BSD-3-Clause"
2LIC_FILES_CHKSUM = "file://${WORKDIR}/git/COPYING.txt;md5=f2b4f162358b1ffaf3f2307287ca2074"
3
4BRANCH = "master"
5SRC_URI = "git://git.ti.com/keystone-rtos/netapi.git;protocol=git;branch=${BRANCH}"
6
7# Below Commit ID corresponds to "DEV.NETAPI.01.01.00.04"
8SRCREV= "dc08af268200908d3d8a456ac852c65c53d2fd12"
9PV = "01.01.00.04"
10
11DEVICELIST = "k2h k2k k2l k2e"
12
13CHOICELIST = "yes no"
14
15BASEDIR = "${WORKDIR}/git"
16S = "${BASEDIR}/ti/runtime/netapi"
diff --git a/recipes-ti/netapi/netapi_git.bb b/recipes-ti/netapi/netapi_git.bb
new file mode 100644
index 00000000..d88e95ab
--- /dev/null
+++ b/recipes-ti/netapi/netapi_git.bb
@@ -0,0 +1,32 @@
1DESCRIPTION = "Provides NETAPI module: TI user space network library"
2
3COMPATIBLE_MACHINE = "keystone"
4
5DEPENDS = "common-csl-ip rm-lld qmss-lld cppi-lld sa-lld hplib pktlib nwal-lld"
6
7include netapi.inc
8
9EXTRA_OEMAKE = "-f makefile_armv7 PDK_INSTALL_PATH=${STAGING_INCDIR}"
10
11do_compile () {
12# Now build the netapi
13 for device in ${DEVICELIST}
14 do
15 for choice in ${CHOICELIST}
16 do
17 oe_runmake clean NETAPI_SRC_DIR=${S} NETAPI_INC_DIR=${BASEDIR} \
18 USEDYNAMIC_LIB="$choice" DEVICE="$device"
19 oe_runmake lib NETAPI_SRC_DIR=${S} NETAPI_INC_DIR=${BASEDIR} \
20 USEDYNAMIC_LIB="$choice" DEVICE="$device"
21 done
22 done
23}
24
25do_install () {
26 for device in ${DEVICELIST}
27 do
28 oe_runmake install INSTALL_INC_BASE_DIR=${D}${includedir} \
29 INSTALL_LIB_BASE_DIR=${D}${libdir} INSTALL_BIN_BASE_DIR=${D}${bindir} \
30 SYSCONFDIR=${D}${sysconfdir} DEVICE="$device"
31 done
32}