summaryrefslogtreecommitdiffstats
path: root/recipes-ti
diff options
context:
space:
mode:
authorKoen Kooi <koen@dominion.thruhere.net>2011-08-10 08:38:18 +0200
committerKoen Kooi <koen@dominion.thruhere.net>2011-08-16 09:46:08 +0200
commit18698b86c76b2adafc2ef7061b331e3423dcbe6c (patch)
tree9ccc797acf8359689b23a8011f996da721c68cb4 /recipes-ti
parent9e85b31e35bb6dadc7c6997c7e0c8fb23b38249b (diff)
downloadmeta-ti-18698b86c76b2adafc2ef7061b331e3423dcbe6c.tar.gz
TI recipes: only use PACKAGE_ARCH = "${MACHINE_ARCH}" where needed
With machine specific staging in OE-core the tools (xdc, dmai, etc) can drop the PACKAGE_ARCH munging. Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
Diffstat (limited to 'recipes-ti')
-rw-r--r--recipes-ti/codec-engine/ti-codec-engine.inc2
-rw-r--r--recipes-ti/codec-engine/ti-codecs-omap3530_4.00.00.00.bb1
-rw-r--r--recipes-ti/dmai/ti-dmai.inc2
-rw-r--r--recipes-ti/gstreamer-ti/gstreamer-ti.inc2
-rw-r--r--recipes-ti/includes/ti-staging.inc2
-rw-r--r--recipes-ti/local-power-manager/ti-local-power-manager.inc1
6 files changed, 8 insertions, 2 deletions
diff --git a/recipes-ti/codec-engine/ti-codec-engine.inc b/recipes-ti/codec-engine/ti-codec-engine.inc
index 18c8cf40..fde181e7 100644
--- a/recipes-ti/codec-engine/ti-codec-engine.inc
+++ b/recipes-ti/codec-engine/ti-codec-engine.inc
@@ -186,6 +186,8 @@ do_install() {
186 cp -pPrf ${S}/* ${D}${CE_INSTALL_DIR_RECIPE} 186 cp -pPrf ${S}/* ${D}${CE_INSTALL_DIR_RECIPE}
187} 187}
188 188
189PACKAGE_ARCH = "${MACHINE_ARCH}"
190
189PACKAGES += "ti-codec-engine-examples" 191PACKAGES += "ti-codec-engine-examples"
190 192
191RDEPENDS_ti-codec-engine-examples = " ti-cmem-module" 193RDEPENDS_ti-codec-engine-examples = " ti-cmem-module"
diff --git a/recipes-ti/codec-engine/ti-codecs-omap3530_4.00.00.00.bb b/recipes-ti/codec-engine/ti-codecs-omap3530_4.00.00.00.bb
index 0bacf91d..ae218b10 100644
--- a/recipes-ti/codec-engine/ti-codecs-omap3530_4.00.00.00.bb
+++ b/recipes-ti/codec-engine/ti-codecs-omap3530_4.00.00.00.bb
@@ -200,6 +200,7 @@ do_install() {
200 cp -pPrf ${CODEC_SUITE_NAME}/* ${D}${CODEC_INSTALL_DIR_RECIPE} 200 cp -pPrf ${CODEC_SUITE_NAME}/* ${D}${CODEC_INSTALL_DIR_RECIPE}
201} 201}
202 202
203PACKAGE_ARCH = "${MACHINE_ARCH}"
203 204
204PACKAGES += "ti-codecs-omap3530-server" 205PACKAGES += "ti-codecs-omap3530-server"
205FILES_ti-codecs-omap3530-server = "${installdir}/ti-codecs-server/*" 206FILES_ti-codecs-omap3530-server = "${installdir}/ti-codecs-server/*"
diff --git a/recipes-ti/dmai/ti-dmai.inc b/recipes-ti/dmai/ti-dmai.inc
index a84f303a..8b536fc8 100644
--- a/recipes-ti/dmai/ti-dmai.inc
+++ b/recipes-ti/dmai/ti-dmai.inc
@@ -141,6 +141,8 @@ do_install () {
141 cp -pPrf ${S}/* ${D}${DMAI_INSTALL_DIR_RECIPE} 141 cp -pPrf ${S}/* ${D}${DMAI_INSTALL_DIR_RECIPE}
142} 142}
143 143
144PACKAGE_ARCH = "${MACHINE_ARCH}"
145
144PACKAGES += "ti-dmai-apps" 146PACKAGES += "ti-dmai-apps"
145FILES_ti-dmai-apps = "${installdir}/ti-dmai-apps/*" 147FILES_ti-dmai-apps = "${installdir}/ti-dmai-apps/*"
146INSANE_SKIP_ti-dmai-apps = True 148INSANE_SKIP_ti-dmai-apps = True
diff --git a/recipes-ti/gstreamer-ti/gstreamer-ti.inc b/recipes-ti/gstreamer-ti/gstreamer-ti.inc
index ded16ce8..422d8c7e 100644
--- a/recipes-ti/gstreamer-ti/gstreamer-ti.inc
+++ b/recipes-ti/gstreamer-ti/gstreamer-ti.inc
@@ -143,6 +143,8 @@ pkg_postinst_${PN} () {
143 fi 143 fi
144} 144}
145 145
146PACKAGE_ARCH = "${MACHINE_ARCH}"
147
146INITSCRIPT_NAME = "gstti-init" 148INITSCRIPT_NAME = "gstti-init"
147INITSCRIPT_PARAMS = "start 30 5 2 . stop 40 0 1 6 ." 149INITSCRIPT_PARAMS = "start 30 5 2 . stop 40 0 1 6 ."
148 150
diff --git a/recipes-ti/includes/ti-staging.inc b/recipes-ti/includes/ti-staging.inc
index 2bacd7a9..48ee061c 100644
--- a/recipes-ti/includes/ti-staging.inc
+++ b/recipes-ti/includes/ti-staging.inc
@@ -1,5 +1,3 @@
1PACKAGE_ARCH = "${MACHINE_ARCH}"
2
3PACKAGE_STRIP = "no" 1PACKAGE_STRIP = "no"
4 2
5ALLOW_EMPTY_${PN} = "1" 3ALLOW_EMPTY_${PN} = "1"
diff --git a/recipes-ti/local-power-manager/ti-local-power-manager.inc b/recipes-ti/local-power-manager/ti-local-power-manager.inc
index 7ccbf997..46ea86b7 100644
--- a/recipes-ti/local-power-manager/ti-local-power-manager.inc
+++ b/recipes-ti/local-power-manager/ti-local-power-manager.inc
@@ -109,6 +109,7 @@ do_install () {
109 cp -pPrf ${S}/* ${D}${LPM_INSTALL_DIR_RECIPE} 109 cp -pPrf ${S}/* ${D}${LPM_INSTALL_DIR_RECIPE}
110} 110}
111 111
112PACKAGE_ARCH = "${MACHINE_ARCH}"
112PACKAGES += "ti-lpm-module" 113PACKAGES += "ti-lpm-module"
113FILES_ti-lpm-module = "/lib/modules/${KERNEL_VERSION}/kernel/drivers/dsp/*lpm*ko" 114FILES_ti-lpm-module = "/lib/modules/${KERNEL_VERSION}/kernel/drivers/dsp/*lpm*ko"
114RDEPENDS_ti-lpm-module += "ti-dsplink-module" 115RDEPENDS_ti-lpm-module += "ti-dsplink-module"