diff options
author | Sam Nelson <sam.nelson@ti.com> | 2018-08-24 23:46:53 +0000 |
---|---|---|
committer | Denys Dmytriyenko <denys@ti.com> | 2018-08-26 16:07:09 +0000 |
commit | d008f3b0513902ef451514655289ed02f7700397 (patch) | |
tree | 5630e28319ab1a7db09c4db91b3e69256338582f /recipes-ti | |
parent | 1f8afb8cc608f6cf651e4dce08bff4a564b29b85 (diff) | |
download | meta-ti-d008f3b0513902ef451514655289ed02f7700397.tar.gz |
ti-ipc: Update to new version 3.50.01.01
-Updates to use sciclient for configuring interrupt routing in SOC
Signed-off-by: Sam Nelson <sam.nelson@ti.com>
Signed-off-by: Denys Dmytriyenko <denys@ti.com>
Diffstat (limited to 'recipes-ti')
-rw-r--r-- | recipes-ti/ipc/ti-ipc-common.inc | 2 | ||||
-rw-r--r-- | recipes-ti/ipc/ti-ipc-examples_git.bb | 2 | ||||
-rw-r--r-- | recipes-ti/ipc/ti-ipc-rtos.inc | 12 | ||||
-rw-r--r-- | recipes-ti/ipc/ti-ipc-rtos_git.bb | 1 | ||||
-rw-r--r-- | recipes-ti/ipc/ti-ipc.inc | 4 |
5 files changed, 14 insertions, 7 deletions
diff --git a/recipes-ti/ipc/ti-ipc-common.inc b/recipes-ti/ipc/ti-ipc-common.inc index 6aea8e64..543990a7 100644 --- a/recipes-ti/ipc/ti-ipc-common.inc +++ b/recipes-ti/ipc/ti-ipc-common.inc | |||
@@ -1,4 +1,4 @@ | |||
1 | PV = "3.50.01.00" | 1 | PV = "3.50.01.01" |
2 | INC_PR = "r0" | 2 | INC_PR = "r0" |
3 | 3 | ||
4 | PACKAGE_ARCH = "${MACHINE_ARCH}" | 4 | PACKAGE_ARCH = "${MACHINE_ARCH}" |
diff --git a/recipes-ti/ipc/ti-ipc-examples_git.bb b/recipes-ti/ipc/ti-ipc-examples_git.bb index c46e5c81..d8733aeb 100644 --- a/recipes-ti/ipc/ti-ipc-examples_git.bb +++ b/recipes-ti/ipc/ti-ipc-examples_git.bb | |||
@@ -3,6 +3,8 @@ require ti-ipc-examples.inc | |||
3 | 3 | ||
4 | DEPENDS = "ti-ipc ti-xdctools-native ti-sysbios ti-ipc-rtos zip-native" | 4 | DEPENDS = "ti-ipc ti-xdctools-native ti-sysbios ti-ipc-rtos zip-native" |
5 | 5 | ||
6 | DEPENDS_append_am65xx-evm = " sciclient-rtos" | ||
7 | |||
6 | do_compile_append() { | 8 | do_compile_append() { |
7 | 9 | ||
8 | if [ "${PLATFORM}" != "UNKNOWN" ]; then | 10 | if [ "${PLATFORM}" != "UNKNOWN" ]; then |
diff --git a/recipes-ti/ipc/ti-ipc-rtos.inc b/recipes-ti/ipc/ti-ipc-rtos.inc index 13b19146..4b2d7d7e 100644 --- a/recipes-ti/ipc/ti-ipc-rtos.inc +++ b/recipes-ti/ipc/ti-ipc-rtos.inc | |||
@@ -24,11 +24,13 @@ protocol=${TI_IPC_METADATA_GIT_PROTOCOL};\ | |||
24 | branch=${TI_IPC_METADATA_GIT_BRANCH};\ | 24 | branch=${TI_IPC_METADATA_GIT_BRANCH};\ |
25 | name=${TI_IPC_METADATA_NAME}" | 25 | name=${TI_IPC_METADATA_NAME}" |
26 | 26 | ||
27 | # Corresponds to tag: 3.50.01.00 | 27 | # Corresponds to tag: 3.50.01.01 |
28 | SRCREV_ipc-metadata = "19a8e70cf6ca4fe0984987e25d937c61a62c7658" | 28 | TI_IPC_METADATA_SRCREV = "c749d4dd70cc259679dc862a164ad147d51381f6" |
29 | # Corresponds to tag: 3.50.01.01 | ||
30 | TI_IPC_EXAMPLES_SRCREV = "71f6e59a6b2c7e20c2656e5000f318339ded2f3c" | ||
29 | 31 | ||
30 | # Corresponds to tag: 3.50.01.00 | 32 | SRCREV_ipc-metadata = "${TI_IPC_METADATA_SRCREV}" |
31 | SRCREV_ipc-examples = "1975687076426b587be8d2530df56c24425ca53a" | 33 | SRCREV_ipc-examples = "${TI_IPC_EXAMPLES_SRCREV}" |
32 | 34 | ||
33 | S_ipc-examples = "${WORKDIR}/git/ipc-examples" | 35 | S_ipc-examples = "${WORKDIR}/git/ipc-examples" |
34 | S_ipc-metadata = "${WORKDIR}/git/ipc-metadata" | 36 | S_ipc-metadata = "${WORKDIR}/git/ipc-metadata" |
@@ -89,3 +91,5 @@ EXTRA_OEMAKE = "\ | |||
89 | JOBS="--jobs=${BB_NUMBER_THREADS}" \ | 91 | JOBS="--jobs=${BB_NUMBER_THREADS}" \ |
90 | JAVA_TOOL_OPTIONS=-Xss2560k \ | 92 | JAVA_TOOL_OPTIONS=-Xss2560k \ |
91 | " | 93 | " |
94 | EXTRA_OEMAKE_append_am65xx-evm = " PDK_INSTALL_DIR=${PDK_INSTALL_DIR}" | ||
95 | |||
diff --git a/recipes-ti/ipc/ti-ipc-rtos_git.bb b/recipes-ti/ipc/ti-ipc-rtos_git.bb index c374bb1f..ee7778a9 100644 --- a/recipes-ti/ipc/ti-ipc-rtos_git.bb +++ b/recipes-ti/ipc/ti-ipc-rtos_git.bb | |||
@@ -3,6 +3,7 @@ require ti-ipc-common.inc | |||
3 | require ti-ipc-rtos.inc | 3 | require ti-ipc-rtos.inc |
4 | 4 | ||
5 | DEPENDS = "ti-xdctools-native ti-sysbios doxygen-native zip-native" | 5 | DEPENDS = "ti-xdctools-native ti-sysbios doxygen-native zip-native" |
6 | DEPENDS_append_am65xx-evm = " sciclient-rtos" | ||
6 | 7 | ||
7 | PACKAGES =+ "${PN}-fw" | 8 | PACKAGES =+ "${PN}-fw" |
8 | FILES_${PN}-fw = "${base_libdir}/firmware/*" | 9 | FILES_${PN}-fw = "${base_libdir}/firmware/*" |
diff --git a/recipes-ti/ipc/ti-ipc.inc b/recipes-ti/ipc/ti-ipc.inc index b10e242a..ca392924 100644 --- a/recipes-ti/ipc/ti-ipc.inc +++ b/recipes-ti/ipc/ti-ipc.inc | |||
@@ -8,8 +8,8 @@ TI_IPC_GIT_URI = "git://git.ti.com/ipc/ipcdev.git" | |||
8 | TI_IPC_GIT_PROTOCOL = "git" | 8 | TI_IPC_GIT_PROTOCOL = "git" |
9 | TI_IPC_GIT_BRANCH = "3.50" | 9 | TI_IPC_GIT_BRANCH = "3.50" |
10 | 10 | ||
11 | #Corresponds to 3.50.01.00C | 11 | #Corresponds to 3.50.01.01 |
12 | TI_IPC_SRCREV = "32294eb80e9889ba12d0c008b21acab4545713af" | 12 | TI_IPC_SRCREV = "771859b9687476c3ba1b5bf0d4afb3c97876137e" |
13 | 13 | ||
14 | BRANCH = "${TI_IPC_GIT_BRANCH}" | 14 | BRANCH = "${TI_IPC_GIT_BRANCH}" |
15 | SRC_URI = "${TI_IPC_GIT_URI};protocol=${TI_IPC_GIT_PROTOCOL};branch=${BRANCH};name=ipcdev" | 15 | SRC_URI = "${TI_IPC_GIT_URI};protocol=${TI_IPC_GIT_PROTOCOL};branch=${BRANCH};name=ipcdev" |