diff options
author | Mahesh Radhakrishnan <m-radhakrishnan2@ti.com> | 2018-09-28 22:26:29 +0000 |
---|---|---|
committer | Denys Dmytriyenko <denys@ti.com> | 2018-10-01 03:19:15 +0000 |
commit | 23425e7fb2331bd666d482c66ae87f684a06942f (patch) | |
tree | 9b8b9b2413ec840c383a4e7ff3c3388a1516d5a7 /recipes-ti | |
parent | 382deb52ad8c5dd6dc9c455730d2ff3015115ea1 (diff) | |
download | meta-ti-23425e7fb2331bd666d482c66ae87f684a06942f.tar.gz |
ti-ns: Adding support for TI network services
Signed-off-by: Mahesh Radhakrishnan <m-radhakrishnan2@ti.com>
Signed-off-by: Denys Dmytriyenko <denys@ti.com>
Diffstat (limited to 'recipes-ti')
-rw-r--r-- | recipes-ti/includes/ti-paths.inc | 2 | ||||
-rw-r--r-- | recipes-ti/ns/ti-ns.inc | 21 | ||||
-rw-r--r-- | recipes-ti/ns/ti-ns_2.40.01.02.bb | 14 |
3 files changed, 37 insertions, 0 deletions
diff --git a/recipes-ti/includes/ti-paths.inc b/recipes-ti/includes/ti-paths.inc index 93494f08..250074b4 100644 --- a/recipes-ti/includes/ti-paths.inc +++ b/recipes-ti/includes/ti-paths.inc | |||
@@ -34,6 +34,7 @@ export LINK_INSTALL_DIR_RECIPE = "${installdir}/ti-dsplink-tree" | |||
34 | export LINUXUTILS_INSTALL_DIR_RECIPE = "${installdir}/ti-linuxutils-tree" | 34 | export LINUXUTILS_INSTALL_DIR_RECIPE = "${installdir}/ti-linuxutils-tree" |
35 | export LPM_INSTALL_DIR_RECIPE = "${installdir}/ti-local-power-manager-tree" | 35 | export LPM_INSTALL_DIR_RECIPE = "${installdir}/ti-local-power-manager-tree" |
36 | export NDK_INSTALL_DIR_RECIPE = "${installdir}/ti-ndk-tree" | 36 | export NDK_INSTALL_DIR_RECIPE = "${installdir}/ti-ndk-tree" |
37 | export NS_INSTALL_DIR_RECIPE = "${installdir}/ti-ns-tree" | ||
37 | export OMX_INSTALL_DIR_RECIPE = "${installdir}/ti-omx-tree" | 38 | export OMX_INSTALL_DIR_RECIPE = "${installdir}/ti-omx-tree" |
38 | export OSAL_INSTALL_DIR_RECIPE = "${installdir}/ti-osal-tree" | 39 | export OSAL_INSTALL_DIR_RECIPE = "${installdir}/ti-osal-tree" |
39 | export RTFS_INSTALL_DIR_RECIPE = "${installdir}/ti-rtfs-tree" | 40 | export RTFS_INSTALL_DIR_RECIPE = "${installdir}/ti-rtfs-tree" |
@@ -86,6 +87,7 @@ export LINK_INSTALL_DIR = "${STAGING_DIR_TARGET}${LINK_INSTALL_DIR_RECIPE} | |||
86 | export LINUXUTILS_INSTALL_DIR = "${STAGING_DIR_TARGET}${LINUXUTILS_INSTALL_DIR_RECIPE}" | 87 | export LINUXUTILS_INSTALL_DIR = "${STAGING_DIR_TARGET}${LINUXUTILS_INSTALL_DIR_RECIPE}" |
87 | export LPM_INSTALL_DIR = "${STAGING_DIR_TARGET}${LPM_INSTALL_DIR_RECIPE}" | 88 | export LPM_INSTALL_DIR = "${STAGING_DIR_TARGET}${LPM_INSTALL_DIR_RECIPE}" |
88 | export NDK_INSTALL_DIR = "${STAGING_DIR_TARGET}${NDK_INSTALL_DIR_RECIPE}" | 89 | export NDK_INSTALL_DIR = "${STAGING_DIR_TARGET}${NDK_INSTALL_DIR_RECIPE}" |
90 | export NS_INSTALL_DIR = "${STAGING_DIR_TARGET}${NS_INSTALL_DIR_RECIPE}" | ||
89 | export OMX_INSTALL_DIR = "${STAGING_DIR_TARGET}${OMX_INSTALL_DIR_RECIPE}" | 91 | export OMX_INSTALL_DIR = "${STAGING_DIR_TARGET}${OMX_INSTALL_DIR_RECIPE}" |
90 | export SYSBIOS_INSTALL_DIR = "${STAGING_DIR_TARGET}${SYSBIOS_INSTALL_DIR_RECIPE}" | 92 | export SYSBIOS_INSTALL_DIR = "${STAGING_DIR_TARGET}${SYSBIOS_INSTALL_DIR_RECIPE}" |
91 | export SYSLINK_INSTALL_DIR = "${STAGING_DIR_TARGET}${SYSLINK_INSTALL_DIR_RECIPE}" | 93 | export SYSLINK_INSTALL_DIR = "${STAGING_DIR_TARGET}${SYSLINK_INSTALL_DIR_RECIPE}" |
diff --git a/recipes-ti/ns/ti-ns.inc b/recipes-ti/ns/ti-ns.inc new file mode 100644 index 00000000..2a50c56c --- /dev/null +++ b/recipes-ti/ns/ti-ns.inc | |||
@@ -0,0 +1,21 @@ | |||
1 | SUMMARY = "TI Network Services" | ||
2 | HOMEPAGE = "http://software-dl.ti.com/dsps/dsps_public_sw/sdo_sb/targetcontent/ns/index.html" | ||
3 | SECTION = "devel" | ||
4 | LICENSE = "BSD" | ||
5 | |||
6 | require recipes-ti/includes/ti-paths.inc | ||
7 | |||
8 | S = "${WORKDIR}/ns_${PV}" | ||
9 | |||
10 | SRC_URI = "http://software-dl.ti.com/dsps/dsps_public_sw/sdo_sb/targetcontent/ns/${PV}/exports/ns_${PV}.zip;name=nszip" | ||
11 | |||
12 | do_install() { | ||
13 | CP_ARGS="-Prf --preserve=mode,timestamps --no-preserve=ownership" | ||
14 | install -d ${D}${NS_INSTALL_DIR_RECIPE} | ||
15 | cp ${CP_ARGS} ${S}/* ${D}${NS_INSTALL_DIR_RECIPE} | ||
16 | } | ||
17 | |||
18 | ALLOW_EMPTY_${PN} = "1" | ||
19 | FILES_${PN}-dev += "${NS_INSTALL_DIR_RECIPE}" | ||
20 | |||
21 | INSANE_SKIP_${PN}-dev = "arch ldflags staticdev file-rdeps" | ||
diff --git a/recipes-ti/ns/ti-ns_2.40.01.02.bb b/recipes-ti/ns/ti-ns_2.40.01.02.bb new file mode 100644 index 00000000..6de00209 --- /dev/null +++ b/recipes-ti/ns/ti-ns_2.40.01.02.bb | |||
@@ -0,0 +1,14 @@ | |||
1 | require ti-ns.inc | ||
2 | |||
3 | PV = "2_40_01_02" | ||
4 | PR = "r0" | ||
5 | SRC_URI = "http://software-dl.ti.com/targetcontent/ns/${PV}/exports/ns_${PV}.zip;name=nszip" | ||
6 | |||
7 | LIC_FILES_CHKSUM = "file://manifest_ns_${PV}.html;md5=29e319bb254ad52bdaebf8f6387c2f85" | ||
8 | |||
9 | SRC_URI[nszip.md5sum] = "03146829fc7cf1e7b2acbeb6c1f772e9" | ||
10 | SRC_URI[nszip.sha256sum] = "e41f254d9db341ad3efea7f6f59df46802769eba3e2f03b6d2a53d186de18687" | ||
11 | |||
12 | INHIBIT_PACKAGE_STRIP = "1" | ||
13 | INHIBIT_PACKAGE_DEBUG_SPLIT = "1" | ||
14 | INHIBIT_SYSROOT_STRIP = "1" | ||