summaryrefslogtreecommitdiffstats
path: root/recipes-ti
diff options
context:
space:
mode:
authorPraneeth Bajjuri <praneeth@ti.com>2021-03-27 00:14:52 +0000
committerPraneeth Bajjuri <praneeth@ti.com>2021-03-26 13:18:18 -0500
commit8b1aa75cfee14286926e25e13a072c3748f85eae (patch)
tree8b09b1e1a24c0deab2df5922cb52af00853f49d8 /recipes-ti
parent5809a83e37e4ebfd5d0ac56a93b0f7faafe43d8f (diff)
downloadmeta-ti-8b1aa75cfee14286926e25e13a072c3748f85eae.tar.gz
ti-rtos-firmware: sign DM firmware for J721e HS platform
U-boot build process requires DM firmware to be signed for J7 HS. It's better for ti-rtos-firmware package (that delivers DM firmware) to sign it once and provide signed version to other packages, instead of U-boot needing to re-sign it during build in staging location. Signed-off-by: Praneeth Bajjuri <praneeth@ti.com> Signed-off-by: Denys Dmytriyenko <denys@konsulko.com>
Diffstat (limited to 'recipes-ti')
-rw-r--r--recipes-ti/ti-rtos-bin/ti-rtos-firmware.bb12
1 files changed, 12 insertions, 0 deletions
diff --git a/recipes-ti/ti-rtos-bin/ti-rtos-firmware.bb b/recipes-ti/ti-rtos-bin/ti-rtos-firmware.bb
index e85948b2..38e9adc6 100644
--- a/recipes-ti/ti-rtos-bin/ti-rtos-firmware.bb
+++ b/recipes-ti/ti-rtos-bin/ti-rtos-firmware.bb
@@ -74,6 +74,18 @@ SRC_URI[sha256sum] = "${CORESDK_RTOS_FIRMWARE_SHA256SUM}"
74 74
75FILES_${PN} += "${base_libdir}" 75FILES_${PN} += "${base_libdir}"
76 76
77TI_SECURE_DEV_PKG ?= ""
78
79DM_FIRMWARE = "ipc_echo_testb_mcu1_0_release_strip.xer5f"
80
81do_install_prepend_j7-hs-evm() {
82 export TI_SECURE_DEV_PKG=${TI_SECURE_DEV_PKG}
83 ( cd ${S}/firmware/pdk-ipc/; \
84 mv ${DM_FIRMWARE} ${DM_FIRMWARE}.unsigned; \
85 ${TI_SECURE_DEV_PKG}/scripts/secure-binary-image.sh ${DM_FIRMWARE}.unsigned ${DM_FIRMWARE}; \
86 )
87}
88
77do_install() { 89do_install() {
78 CP_ARGS="-Prf --preserve=mode,timestamps --no-preserve=ownership" 90 CP_ARGS="-Prf --preserve=mode,timestamps --no-preserve=ownership"
79 install -d ${D}${base_libdir} 91 install -d ${D}${base_libdir}