diff options
author | Luca Ceresoli <luca@lucaceresoli.net> | 2019-12-04 17:45:29 +0100 |
---|---|---|
committer | Denys Dmytriyenko <denys@ti.com> | 2019-12-09 18:15:23 +0000 |
commit | fb189e30ebb76afb88171a8fbd813e0eeb14565d (patch) | |
tree | 8c8a069dd1d61bcd4ac58859c320c85d8fa325a0 /recipes-ti | |
parent | 1108d0167890c575b3887c6df39242d838e3e0c8 (diff) | |
download | meta-ti-fb189e30ebb76afb88171a8fbd813e0eeb14565d.tar.gz |
Fix "basehash value changed" errors and BB_NUMBER_THREADS usage
Changing BB_NUMBER_THREADS between successive builds causes a "basehash
value changed" error. Additionally, using BB_NUMBER_THREADS to pass a
number of processes to run to xdc is wrong: PARALLEL_MAKE is the correct
variable to use.
Fix both problems by using oe.utils.parallel_make_argument() to obtain the
number of processes to run from PARALLEL_MAKE.
Fixes:
ERROR: When reparsing .../meta-ti/recipes-ti/ipc/ti-ipc-rtos_git.bb.do_configure, the basehash value changed from 63897a188012cedde03f756b5dbbfa70 to 13b80bf4f4327c367bd201eb4aa32ad7. The metadata is not deterministic and this needs to be fixed.
ERROR: When reparsing .../meta-ti/recipes-ti/ipc/ti-ipc-rtos_git.bb.do_compile, the basehash value changed from 2fb59a7db2a2f69d2c25c06c1b6a4245 to 314c664cc040afae2800fcc378dd9ae0. The metadata is not deterministic and this needs to be fixed.
Steps to reproduce:
BB_NUMBER_THREADS="3" bitbake ti-ipc-rtos ti-ipc-examples-linux
BB_NUMBER_THREADS="4" bitbake -c cleansstate osal-rtos
BB_NUMBER_THREADS="5" bitbake ti-ipc-rtos ti-ipc-examples-linux
Reported here: https://e2e.ti.com/support/processors/f/791/p/825142/3059419
Reported-by: Matthew McKee (e-mail unknown)
Suggested-by: Khem Raj <raj.khem@gmail.com>
Signed-off-by: Luca Ceresoli <luca@lucaceresoli.net>
Signed-off-by: Denys Dmytriyenko <denys@ti.com>
Diffstat (limited to 'recipes-ti')
-rw-r--r-- | recipes-ti/ipc/ti-ipc-rtos.inc | 3 |
1 files changed, 2 insertions, 1 deletions
diff --git a/recipes-ti/ipc/ti-ipc-rtos.inc b/recipes-ti/ipc/ti-ipc-rtos.inc index 7789b5a1..baf1ccc1 100644 --- a/recipes-ti/ipc/ti-ipc-rtos.inc +++ b/recipes-ti/ipc/ti-ipc-rtos.inc | |||
@@ -84,12 +84,13 @@ IPC_TARGETS_am65xx = "\ | |||
84 | ti.targets.arm.elf.R5F="${M4_TOOLCHAIN_INSTALL_DIR}" \ | 84 | ti.targets.arm.elf.R5F="${M4_TOOLCHAIN_INSTALL_DIR}" \ |
85 | " | 85 | " |
86 | 86 | ||
87 | PARALLEL_XDC = "${@oe.utils.parallel_make_argument(d, '--jobs=%d')}" | ||
87 | EXTRA_OEMAKE = "\ | 88 | EXTRA_OEMAKE = "\ |
88 | PLATFORM=${PLATFORM} \ | 89 | PLATFORM=${PLATFORM} \ |
89 | XDC_INSTALL_DIR="${XDC_INSTALL_DIR}" \ | 90 | XDC_INSTALL_DIR="${XDC_INSTALL_DIR}" \ |
90 | BIOS_INSTALL_DIR="${SYSBIOS_INSTALL_DIR}" \ | 91 | BIOS_INSTALL_DIR="${SYSBIOS_INSTALL_DIR}" \ |
91 | ${IPC_TARGETS} \ | 92 | ${IPC_TARGETS} \ |
92 | JOBS="--jobs=${BB_NUMBER_THREADS}" \ | 93 | ${PARALLEL_XDC} \ |
93 | JAVA_TOOL_OPTIONS=-Xss2560k \ | 94 | JAVA_TOOL_OPTIONS=-Xss2560k \ |
94 | " | 95 | " |
95 | EXTRA_OEMAKE_append_am65xx = " PDK_INSTALL_DIR=${PDK_INSTALL_DIR}" | 96 | EXTRA_OEMAKE_append_am65xx = " PDK_INSTALL_DIR=${PDK_INSTALL_DIR}" |