diff options
author | Denys Dmytriyenko <denys@ti.com> | 2020-08-25 07:01:01 +0000 |
---|---|---|
committer | Denys Dmytriyenko <denys@ti.com> | 2020-08-25 17:58:35 +0000 |
commit | c5e7e23e14f5d212ef14192d0845173cf14eefc1 (patch) | |
tree | d5ccc987db33fa2c7f4a8b7fa38afc28297023dd /recipes-ti | |
parent | 9ea5416a233d57dd7b450987379cdccf59569159 (diff) | |
download | meta-ti-c5e7e23e14f5d212ef14192d0845173cf14eefc1.tar.gz |
rtos, gcc-arm-none-eabi: Rename gcc-arm-none-eabi -> gcc-arm-baremetal
Rename gcc-arm-none-eabi to gcc-arm-baremetal.
As meta-arm now provides baremetal gcc-arm-none-eabi version 9, and due to layer
priorities, let's rename gcc-arm-none-eabi to gcc-arm-baremetal to force picking
the right version for RTOS builds.
Signed-off-by: Denys Dmytriyenko <denys@ti.com>
Diffstat (limited to 'recipes-ti')
-rw-r--r-- | recipes-ti/devtools/gcc-arm-baremetal_7-2018-q2-update.bb (renamed from recipes-ti/devtools/gcc-arm-none-eabi_7-2018-q2-update.bb) | 0 | ||||
-rw-r--r-- | recipes-ti/devtools/gcc-arm-none-eabi-native_4.9.2015q3.bb | 23 | ||||
-rw-r--r-- | recipes-ti/ipc/ti-ipc-rtos.inc | 4 |
3 files changed, 2 insertions, 25 deletions
diff --git a/recipes-ti/devtools/gcc-arm-none-eabi_7-2018-q2-update.bb b/recipes-ti/devtools/gcc-arm-baremetal_7-2018-q2-update.bb index f474c87f..f474c87f 100644 --- a/recipes-ti/devtools/gcc-arm-none-eabi_7-2018-q2-update.bb +++ b/recipes-ti/devtools/gcc-arm-baremetal_7-2018-q2-update.bb | |||
diff --git a/recipes-ti/devtools/gcc-arm-none-eabi-native_4.9.2015q3.bb b/recipes-ti/devtools/gcc-arm-none-eabi-native_4.9.2015q3.bb deleted file mode 100644 index 1fe5c525..00000000 --- a/recipes-ti/devtools/gcc-arm-none-eabi-native_4.9.2015q3.bb +++ /dev/null | |||
@@ -1,23 +0,0 @@ | |||
1 | DESCRIPTION = "Baremetal GCC for ARM" | ||
2 | LICENSE = "GPL-3.0-with-GCC-exception & GPLv3" | ||
3 | |||
4 | LIC_FILES_CHKSUM = "file://share/doc/gcc-arm-none-eabi/license.txt;md5=cba77c7fde3ed13e866b04a2f3d93918" | ||
5 | |||
6 | inherit native | ||
7 | require recipes-ti/includes/ti-paths.inc | ||
8 | |||
9 | SRC_URI = "https://launchpad.net/gcc-arm-embedded/4.9/4.9-2015-q3-update/+download/gcc-arm-none-eabi-4_9-2015q3-20150921-linux.tar.bz2;name=gcc-arm-none" | ||
10 | |||
11 | SRC_URI[gcc-arm-none.md5sum] = "8a4a74872830f80c788c944877d3ad8c" | ||
12 | SRC_URI[gcc-arm-none.sha256sum] = "c50078bfbd29e6c15615900e746f4d0acde917338e55860b0f145f57387c12ab" | ||
13 | |||
14 | S = "${WORKDIR}/gcc-arm-none-eabi-4_9-2015q3" | ||
15 | |||
16 | do_install() { | ||
17 | install -d ${D}${GCC_ARM_NONE_TOOLCHAIN_RECIPE} | ||
18 | cp -r ${S}/. ${D}${GCC_ARM_NONE_TOOLCHAIN_RECIPE} | ||
19 | } | ||
20 | |||
21 | FILES_${PN} = "${GCC_ARM_NONE_TOOLCHAIN_RECIPE}/*" | ||
22 | |||
23 | INSANE_SKIP_${PN} = "already-stripped" | ||
diff --git a/recipes-ti/ipc/ti-ipc-rtos.inc b/recipes-ti/ipc/ti-ipc-rtos.inc index a68ba806..b6b7892f 100644 --- a/recipes-ti/ipc/ti-ipc-rtos.inc +++ b/recipes-ti/ipc/ti-ipc-rtos.inc | |||
@@ -42,11 +42,11 @@ RELEASE_SUFFIX = "" | |||
42 | PR = "${INC_PR}.r0" | 42 | PR = "${INC_PR}.r0" |
43 | 43 | ||
44 | DEPENDS_append_keystone = " ti-cgt6x-native \ | 44 | DEPENDS_append_keystone = " ti-cgt6x-native \ |
45 | gcc-arm-none-eabi-native \ | 45 | gcc-arm-baremetal-native \ |
46 | " | 46 | " |
47 | DEPENDS_append_omap-a15 = " ti-cgt6x-native \ | 47 | DEPENDS_append_omap-a15 = " ti-cgt6x-native \ |
48 | ti-cgt-arm-native \ | 48 | ti-cgt-arm-native \ |
49 | gcc-arm-none-eabi-native \ | 49 | gcc-arm-baremetal-native \ |
50 | " | 50 | " |
51 | DEPENDS_append_omapl138 = " ti-cgt6x-native \ | 51 | DEPENDS_append_omapl138 = " ti-cgt6x-native \ |
52 | " | 52 | " |